USB drive listed in devices but missing elsewhere

September 9, 2014 at 23:07:36
Specs: Windows XP
I've had an WD Elements 1024 USB drive for 3 years, working fine in both XP and W7 64bit. Recently I unplugged it from XP, plugged in W7 but had problems accessing it, plugged it back into the XP machine, but now it is gone everywhere except in the device manager, where it is listed as a disk but without volumes. DiskTest does not recognize, but WD DataLifeGuard utilities find it and the non-destructive tests show ok, except that size appears as zero, and there is no SMART info. I have tried many of the suggestions found on the internet, to no avail. Has the drive failed? It just so happens that right before all this, I was sharing it through Remote Desktop, and had to fiddle with the disk security entries because I could not access it as a normal network share in a workgroup.

message edited by chelince

See More: USB drive listed in devices but missing elsewhere

Report •

September 10, 2014 at 04:26:12
It can't have failed if WD diagnostic software has passed it ok.

Look in Disk Management. It may just need a drive letter assigning to it.

See how to add a drive letter here:

Report •

September 10, 2014 at 12:03:47
"I was sharing it through Remote Desktop, and had to fiddle with the disk security entries because I could not access it as a normal network share in a workgroup".

What did you do?

Does the drive appear in the list in Windows Disk Management as Phil asked above?

Was this drive used as a backup? If so, were you using some included backup software or something else?

message edited by OtheHill

Report •

September 10, 2014 at 12:35:10
Disk Management will not show it. It won't even show when booting from Bart PE, or in DiskTest, which rules out a registry problem. It was probably my fault, I did some weird stuff with the drive, I think I should explain because the problem started after that. The drive was plugged into my XP, working just fine for many months. I connected to a Win 7 64-bit laptop, first using Remote Desktop with the option to share local resources. The shared resource was drive P, the usb disk. That worked fine. After a while I decided to not rely on Remote Desk and tried sharing it accross the network. The drive would show on the Win 7, but of course, I ran into the usual permissions problems, also started getting the message "Delayed Write Error" on the XP. I changed the permissions to the drive in XP, allowing full rights to EVERYONE. But at some point I had BOTH Remote Desk AND the share going, with my Win 7 trying to map to the drive with a letter. I am not sure, but I think at some point I ended up with TWO drives with the letter P. After that, everything went downhill. At some point I did change the letter from P to W in XP, but the drive went from the delayed write error to disappearing completely from everywhere EXCEPT the Device Manager where it showed as a disk functioning properly, but with no volumes. I uninstalled and rebooted, and XP added it back with the same results. Nothing was written to the drive, so I suspect all the data is still there, someone mentioned that the same happened to them but it was a matter of "unhiding" the partition, which he managed by using System Commander 7. At this point I will try anything before giving up. Any other hints?

PS: another important detail. I had an external enclosure with a Seagate plugged into the XP machine, as well as an audio usb interface. I wonder if that was too much USB power draw and could have affected the WD. The external enclosure does have its own power supply, however.

message edited by chelince

Report •

Related Solutions

September 10, 2014 at 14:56:31
Look in Windows Device Manager. Keep in mind that in Device Manager TWO items should show IF things are working correctly.

The enclosure should appear under USB controllers as a Mass Storage Device.

The hard drive should appear in the list of Disk Drives.

The external may have been improperly removed while there was data being written to it.

You could try running Easeus Partition Recovery Wizard from the link below.

Report •

September 10, 2014 at 15:04:18
The enclosure is listed and works fine in all respects and all apps. Already tried Easeus, same as disk manager, same as DiskTest. The WD drive is not listed at all.

I even burned a boot up CD with Easus and rebooted, drive not there at all. It looks dead except for the fact that it still appears as a disk in windows Device Manager, and is recognized as so even if uninstalled and windows is rebooted. The drive LED is on and blinking periodically as it used to, so it is alive in that sense.

message edited by chelince

Report •

Ask Question