USB Disk eject issue

Dell Dell optiplex 755 desktop desktop c...
August 26, 2010 at 07:39:26
Specs: Windows 7 64 bit and Linux, 4GB RAM

Many times when I try to eject my USB drive with "Safely remove hardware" button from the system tray, I get an error message "The device generic volume cannot be stopped now. Try stopping the device again later". I tried the following options and some of them work sometimes, not always.

1. Tried ejecting later. This one mostly will not work.
2. Kill explorer.exe from task manager and restart it. This one works 50% of the time, not always.
3. Tried USB disk ejector. Mostly doesn't work.
4. Tried unlocker. This one says the USB disk is not locked by any process.
5. Tried process explorer to see if any process has a lock on the usb drive. In most cases, it says nothing has a lock on the drive.

Can some one point me a better free software that can free up the usb drive?


See More: USB Disk eject issue

Report •

August 26, 2010 at 07:53:21
Are you running any programs from the usb drive, or have any of the files open that are on it?

My name is JRComp, and I approve this message.

Report •

August 26, 2010 at 07:56:45

I always run FreeOTFE from my pen drive which has Asuite installed, which in turn contains hundreds of portable applications. I use some of the applications almost every day. But, end of the day, I close all applications, unmount the FreeOTFE volume and then I try to eject the USB. The ejection works fine 50% of the times with out any problems.


Report •
Related Solutions

Ask Question