USB devices auto-disconnect then reconnect

January 28, 2010 at 10:59:19
Specs: all windows
my problem is that whenever i connect any flash usb or external usb hard drive to my laptop it works for 2 or 3 mins and then disconnect and reconnect by itself, i tried all the other usb ports and the same happens so plz help, tell me if its a power problem or anything else

See More: USB devices auto-disconnect then reconnect

Report •


#1
January 28, 2010 at 17:05:47
Are the devices connected to a USB hub attached to your laptop? If so, remove the hub and connect the devices directly to the USB port on your laptop, Post back with the result.

i_Xp/Vista/W7User


Report •

#2
January 29, 2010 at 05:37:07
no no, its connected directly < and also i tried the hub it didnt work too.

Report •

#3
February 4, 2010 at 08:17:15
plzzzz, somebody reply. i need ur help

Report •

Related Solutions

#4
February 4, 2010 at 08:22:02
Look in the event logs to see if there are any errors or messages that might provide information as to why this is happening.

On your desktop, right click on My Computer and select Manage. You'll find the Event Manager under System Tools.


Report •

#5
February 5, 2010 at 10:07:55
i've checked the errors out and this is the error that came up but i still dont know how to fix it
The system failed to flush data to the transaction log. Corruption may occur.

Report •

#6
February 11, 2010 at 00:17:12
I have exactly the same problem. My Freecom USB HDD auto
disconnects and then reconnects immediately. The log event
message mr nayef refers to is Event ID 57, which I see too, but
in fact that is the error message telling me that I didn't
disconnect the USB device in the proper way, as in via the
Safely Remove Hardware function, therefore it being a Hot
detach, see http://support.microsoft.com/kb/938940 ... So
nothing new there. Anyone with answers?

Report •

#7
February 12, 2010 at 12:21:03
finally i've found the solution for my problem, i'm not sure if its the solution for ur problem (capper).
i was sure that my problem was with my hardware so i disassembled my laptop and then disconnected the USB from the motherboard and then reconnected it. and that was the solution that simple.
but for u need first to check if the problem only on ur laptop , if so ,check the wire u r using, if thats not the problem 2 u need2 update ur chipset and try what i've done.
good luck :)

Report •

Ask Question