Unreadable Partition

Wd Western digital my book essential 500...
January 2, 2010 at 12:36:09
Specs: Windows 7 and Mac OSX 10.5, Intel Core2 Duo 2.4GHz/ 2.0GB RAM
I partitioned my [WD Western Digital My Book Essential 500GB External USB 2.0 500 GB Hard Drive] to 3 different partitions. The original (and very large ~350GB) NTFS partition for my backups, a 30GB FAT32 partition for transferring files quickly between the Mac and Windows 7 halves of my iMac, and a third 80GB partition for Mac specific backups.

*Important Note*
To access and write to and from the NTFS Partition on the Mac half of the iMac, I installed Tuxera NTFS. (Not sure if this really will help at all, but it is something.)

I decided to partition a a fourth partition to run Windows 7 from instead of partitioning my iMac's HD, and during the resizing of the partition, the program I was using went unresponsive, and after 2 hours of waiting, I was forced to quit the application.

When I tried to access the disk again from Windows XP, the smaller two partitions were readable and nothing was wrong with them. The main partition, however, was readaing as unformatted and I was very dissappointed because of this. I went ahead and upgraded the WinXP version I had installed to my iMac to Win7. Still unreadable. Very depressed about this, I went onto the Mac half and was surprised to find that ALL of the partitions mounted correctly and that they were all readable and I could access all of the files on the original large partition, and could even back them up if I wanted to. (It would take a few days due to size, etc. but I could still do it.)

I'm not sure why the Windows systems I have had installed can't read the disk, but the Mac system can. If there is anything I can do to have Windows open the NTFS partition and be able to read and write to it would be nice. In the meantime, I am looking for a device big enough to backup the partition in the long run. Any short or long term solution would be appreciated. Thanks for all the help in advance.

See More: Unreadable Partition

Report •

January 2, 2010 at 12:52:33
Testdisk may be able to repair a damaged partition. Read the tutorials before using and use at your own risk. You may be better off waiting until you copy what is accessible prior to using it. Get testdisk at the link below.


Report •

January 8, 2010 at 21:07:52
Thanks for your suggestion. I decided to try Testdisk, and it was able to read the partition and it's files, however it could not make it so that Windows could read the disk. I continued to do research and came up with a few ideas. My problem is now solved. There has been no data loss and Windows can now correctly read the partition.

What I did:
Since Windows could see the partition, but could not acess it, I went ahead and ran the Command Prompt, and then entered the command: chkdsk g: /f
This ran the Checkdisk utility on the drive and allows it to try and fix any errors it comes up with, and it found the corruption of the partition table and was able to fix it.

Thanks for all the help! =D

Report •

January 9, 2010 at 05:30:30
You are welcome

Report •
Related Solutions

Ask Question