Solved unable to use DVD/CD after upgrade from Vista to & on HP

April 9, 2014 at 19:17:11
Specs: Windows 7 Home Premium Service Pact 1, AMD Turion(tm) 64 X2 Mobile Technology TL-62 2.10 GHz - Ram 3.75 GB
I have a HP Pavilion DV9913CL laptop
Windows 7 Home Premium Service Pact 1
AMD Turion(tm) 64 X2 Mobile Technology TL-62 2.10 GHz
Ram 3.75
64 Bit Operation System

DVD/CD-ROM drive - Slimtype DVD A Ds8A1P ATA Device
Driver Date - 6/21/2006
Driver Version - 6.1.7601.17514
Driver Signer - Microsoft Windows

I Recently did upgrade from OEM Vista to Windows 7 home premium The install went fine and the system appears to be working fine.
Was also able to install my Windows Office 2010 without issue. The CD/DVD drive was working fine, however now I am unable to use the CD/DVD drive for anything.

Store purchased Music CD, self-burned Music CD, store DVD, personal files on DVD, older CD of Windows XP, even the Restore DVD’s made when the pc was new they all come back as unreadable.

The drive is listed in Device Manager, no error reported, driver update states most current driver installed.
I tried to disable/uninstall the drive then restart the computer.
Drive was found and installed then the drivers downloaded and reinstalled, did not correct the problem, same issue.
The restore disks even make the computer unresponsive.

I have tried to find drivers but no luck.
When I contacted HP about the problem, I was informed as the software was an upgrade to a version that was not on the market when the PC was made that there is no support unless I restore it back to Vista.
I have seen other postings of the issue but have not been able to find a solution as yet.
Suggestions ?

message edited by ahaz

See More: unable to use DVD/CD after upgrade from Vista to & on HP

Report •

April 10, 2014 at 15:41:18
You could try resolution 2 here:

[It's coming up on my computer as for Win 8 and 8.1 but I think that is because I'm using Win 8.1]

Always pop back and let us know the outcome - thanks

message edited by Derek

Report •

April 10, 2014 at 15:55:38
✔ Best Answer
I suspect the issue may not be with Windows at all.

Try booting to any bootable disk to see if the drive functions in the pre-Windows environment. If it doesn't then the drive may have died. If it does work when booting to it then you may need to update the drive firmware. See the link below or Google for Ds8A1P firmware update (second link).

Report •

April 11, 2014 at 02:28:47
I'm much of the same mind as OtH here; the drive has failed was my first thought. But a firmware update "may" help resolve it..

I seriously doubt it's a windows problem; as for the most part cd/dvd units are more or less install, detect in the bios and then recognised later by the OS and it works…?

OtH's suggestion to see if the dvd will function with a bootable cd installed - typically a Linux variant (Ubuntu, Debian, Knoppix etc…); or any anti-virus recovery disk… would be one way to determine if the drive is OK (or not).

Similarly booting up with your windows 8x cd - and seeing if it will at least start to go through the installation process (even a true repair routine - not via recovery console) would also determine if the drive is OK (or not). If it does appear to do that OK then you can cancel the operation and avoid doing anything to your installation as is. Although possibly a true repair routine (effectively a re-installation over the current one) may resolve it all?

Worst case scenario you obtain a replacement and more current cd/dvd unit? Which having said… my 2005/6 Acer Aspire cd/dvd unit (burner) has no problems running win-7; passed all the M$ compatibility checks OK. The unit is a dreaded Panasonic/Mats---a (A brand name the net nannies don't like - so it will appear here missing a few letters…).

May be a little late - but perhaps run the win-7x compatibility checker/test from M$-land to see if the drive is OK (or not) for win-7?

Can be run on-line of course from M$-land.; perhaps give this a whirl before doing anything as regards firmware etc.?

message edited by trvlr

Report •
Related Solutions

Ask Question