Trying to replace 40GB HDD with 160GB HDD

Acer / Aspire 1640
March 10, 2010 at 14:50:08
Specs: Windows XP
I hope you can help me.
This laptop has a 40GB Seagate Momentus 4200.2 drive installed - it works fine, but has less than 5% space left. I've cleared just about everything off it, but it needs replacing.

I bought a Samsung HM160HC drive and have cloned the old drive using CASPER.

The BIOS does not recognise the new drive - probably because it is 5400rpm rather than 4200.

Will a BIOS update fix the problem or is the HDD drive speed fixed to the motherboard and I've bought the wrong drive?

Assuming BIOS upgrade will fix it, how do I ensure I get the right one - it can be catastrophic if you use the wrong one and I have never flashed the bios on a pc before.

See More: Trying to replace 40GB HDD with 160GB HDD

Report •

March 10, 2010 at 15:30:02
"The BIOS does not recognise the new drive - probably because it is 5400rpm rather than 4200."

I searched the web using: Aspire 1640 hard drive upgrade

and there are lots of "hits" for hard drives larger than 137gb, so your bios does NOT have a drive size limitation.

The rpm of the drive is not something the bios can detect, and has no bearing on the matter.

Did you install the new drive inside the latop, or do you have it in a external enclosure and the computer isn't recognizing it ??.

If you installed the new drive inside the laptop...

Did you REMOVE the main battery as well as the AC adapter's connection when you removed the old hard drive and installed the new one?

Check your bios Setup and make sure the drive detection is set to Auto by the method Auto or LBA - if the bios is set to specific parameters for the 40gb drive, the 160gb drive will probably not be detected.

There are 4 pins on the header on the hard drive that don't plug into the connector to the laptop. You do not need to install a jumper on a pair of those pins, unless you can install two hard drives inside the laptop and you will have two installed when you install this one. Usually you can't plug the laptop connector into the pins the wrong way, but check the User's or Owners manual for your model to make sure you have plugged the connector into the right pins on the hard drive.

Manual for your hard drive:

If you have it in an external enclosure....

It may not show up in the bios Setup.

It should show up in Windows...
USB devices may not work correctly when they're connected to certain USB ports. Instructions for how to re-load your USB stack in 2000 or XP, if you need to - similar applies to Vista and Windows 7.

In addition, all external drives connected by USB require that the port (or ports) they connect to can actually supply 500ma of current.

USB external hard drive requirements.

See Response 9:

Report •

March 10, 2010 at 16:15:02
Tubes and Wires, thanks for the quick reply.
I had the original 40GB drive inside the laptop and the 160GB drive on the end of a USB SATA/IDE cable.
I ran CASPER (cloning software) from Boot CD and it has successfully cloned the drive.
I have not altered any Partition sizes (yet) as this is my fourth of fifth attempt!

There is no option in the BIOS to do anything about LBA or otherwise - it simply does not recognise the drive, although if I connect it via USB, it can read everything on it.

Yes, I did remove the Power pack before installing the drive.

I also downloaded the latest bios from ACER and it said I already have the latest one )or newer) so it didn't change it.

I have just tried installing the HDD again, makng sure it is as you describe, to no avail.

The bios shows no HDD drive when the replacemnt one is in the system, but it does show up when it is the old 40GB drive.

Any other thoughts - I could use the help!

Report •

March 10, 2010 at 19:28:26
"There is no option in the BIOS to do anything about LBA or otherwise...."

It is usually difficult or impossible for us to find out what you would see in a brand name bios version, so I can't tell you what to set.
Bios defaults should find the drive automatically.
Try loading Bios defaults, save setiings, then connecting the 160gb drive.

"I also downloaded the latest bios from ACER and it said I already have the latest one )or newer) so it didn't change it."

Flashing the bios is NOT A CURE-ALL !
NEVER flash the bios unless you find specific info it will cure a problem you are having, such as in bios release notes where you get bios updates. If the computer was made after 2001 the bios already supports recognizing any size of hard drive .

I haven't heard of or used Casper.
Are you sure your problem is not just that the copy is not bootable?

You can't re-size partitions in XP itself without deleting the existing data on the partition(s).

You can get free software that can copy the entire contents of the old hard drive from the maker of one of the brands of your hard drive's web sites. It can re-size the partition sizes at the same time as you are copying. E.g. Seagate has MaxBlast, the latest version of which was made by Acronis; Western Digital has similar made by Acronis. They can either be installed on and run from the source drive, or you can make a bootable CD and run it from that. The copy is always bootable. I've used MaxBlast myself to copy a smaller drive to a larger Seagate drive for a friend's laptop. However, you can only copy the entire drive's contents, not individual partitions.

Report •
Related Solutions

Ask Question