Solved Toshiba Satellite laptop keyboard & Wireless problems

Toshiba satellite / C55d
January 23, 2016 at 14:16:06
Specs: Windows 8.1
I have a Toshiba c55d b5219. And I have done what was said above and the computer tells me the airplane mode is on or off, but still won't let let me connect to wireless. My wireless button is f12 and it control the airplane mode.

The second problem is that the keyboard doesn't work when I get to the home screen. It works perfectly to let me sign in, but as soon as I hit enter, my number lock light goes off and all keys stop working. I changed the keyboard, so I know that isn't the problem. The computer is barely used because the keyboard nor the wireless works. Did I get ripped off by Toshiba? Help.

See More: Toshiba Satellite laptop keyboard & Wireless problems

January 23, 2016 at 14:37:50
✔ Best Answer
1: Turn the comp on,
2: Hold the power button down, until the comp turns off.
3: Repeat the process up to 10 times until you are offered an repair option.

Report •

January 23, 2016 at 15:35:08
Have you tried an external USB keyboard?

According to the following, a lot of Toshiba owners seem to be having a similar problems with the wi-fi. Most have fixed it by doing the following:

"take out the battery and Hold down the power button for 30 seconds. Then reinstall the battery"

Report •

January 23, 2016 at 17:00:55
Tried that several times with the old and new keyboard. The wireless won't come on. I have also tried going into the Toshiba folder, then to the tbs keys, but it only operates the airplane mode although the information box says wireless. I am trying the previous suggestion now. I have tried to reset and keep my applications, that hasn't worked. I am now resetting and wiping my applications. I will try the battery thing for the WiFi again. It can't hurt.

Report •

Related Solutions

January 30, 2016 at 15:44:02
This worked. I had to reset my computer loosing all of my stuff, but I didn't have much on it, fortunately. Thanks so much.

Now can you help me get the WiFi working. I did the remove battery hold power button thing and that didn't work. Any suggestions.

Report •

January 30, 2016 at 15:46:54
Run Farbar Service Scanner ( FFS )
Check/tick all the boxes.
Press "Scan".
It will create a log (FSS.txt) in the same directory the tool is run.
Please Copy and Paste the contents of the log in your next reply.

Report •

Ask Question