Thin client question

Fujitsu / S6010
November 21, 2009 at 16:38:32
Specs: Windows NT 4 (SP5), AMD Geode 300 / 128 MB
Hi all,

I've got an issue regarding a Neoware Eon 5000T thin client I recently bought used. The hardware itself works fine, however the previous owner left a copy of Windows NT 4 (SP5) on the DiskOnModule chip which expects to connect to some Windows NT server that does not exist, so it will not boot because it tells me I must be logged in as an admin. I also can't write to the DiskOnModule chip.

So here's the issue - I can't figure out a way to read and write to the DiskOnModule chip. It connects to a 40-pin IDE slot which contains one extra pin compared to regular IDEs (always one pin missing in the middle). None of my towers recognize it as a storage medium and just ignore it completely (even in BIOS config). Would there be a way to write data to it by using some connector for USB or similar (if one exists)?

I'm looking for a solution to either replace Windows on the DiskOnModule chip or boot into Windows and override this kiosk loading software. Does anybody know special keystrokes to override a Windows NT 4 boot process (F8 doesn't seem to work)?

Just wanted to get someone else's opinion before I say I'm SOL with this thin client. Any help or advice is appreciated.


See More: Thin client question

Report •

November 21, 2009 at 16:59:53
A thin client has little or no programs, Have you tried connecting
a regular hard drive. The Disk on Chip module might be
connected to another computer and tried there.

Report •

November 21, 2009 at 17:03:24
I can't connect a hard drive since the mobo has no place to hook up power. The thin client works but I'm just trying to find a way to get Linux on the DiskOnModule chip by either booting into Windows or booting some other way.

Report •

November 21, 2009 at 17:55:29
Could you put the disk on module in another computer?

Report •

Related Solutions

November 21, 2009 at 18:00:03
Yes and I tried it on two separate towers. They either don't recognize it or the BIOS doesn't see it as a drive so it ignores it. Windows and Linux don't recognize any devices either.

Report •

November 22, 2009 at 05:20:12
Original IDE had all 40 pins. The missing pin is only to prevent
inserting in the wrong direction. You need to look at the
documentation for the disk on chip. There might be a write
enable pin. The adapter is probably configured as master.

I don't know of your final objective. There are adapters to convert
compact flash cards to IDE. Supposedly there is a SD card
version also.

Report •

November 22, 2009 at 07:02:51
With regards to a write-enable pin, there is a small 3-pin connector at the top of the DiskOnModule with a little connector simply showing one white wire leading from one pin into the one next to it.

From what I could find online, I believe you may be right with not being able to use this without the write-enable pin. I take it that it's supposed to look something like this?

Report •

November 22, 2009 at 19:21:25
Get the drivers for DOC.

Playing to the angels
Les Paul (1915-2009)

Report •

November 22, 2009 at 19:31:45
There aren't any. :-(

Report •

Ask Question