Temporary Locked Folder in External HD

December 7, 2012 at 19:51:01
Specs: Windows 7
As far as I know, I have a temporary folder on my external HD that won't get deleted. When I try to it says I need administrative permissions (which I should have) and it won't delete. I've been looking around online to try to solve it. I've tried changing the security settings for the folder so I had full ownership, but it doesn't stay like that, I downloaded an unlocker that didn't work (possibly wrong one), and checked my HD for errors. I've unplugged it and plugged it back in after each time and I still can't get rid of it. It's folder name is like 751eadgfvhkl4578ad.

Please help, it's driving me friggin' crazy!

See More: Temporary Locked Folder in External HD

Report •

December 7, 2012 at 23:22:26
There are several utilities to delete stubborn folders or files, too bad you didn't say which one you already tried so as to avoid the same one being suggested by a helper.
Try this: http://www.vikitech.com/10191/lockh...

Report •

December 8, 2012 at 00:32:12
Personal i use unlocker or u can use linux live disc to delete any stubborn file(s).

You know the real meaning of peace only if you have been through the war.

Report •

December 8, 2012 at 16:34:42
I downloaded the unlocker and the folder is unlocked and all the files are accessible. However, there is still a locked folder as the icon and I still can't delete it. I can't unlock it through Lock Hunter and as said before, I have the permissions to the folder making me in full control, but I still can't get rid of it. When I go to delete it, the prompt says "You'll need to provide administrative permission to delete this folder." I hit continue. It keeps asking me to Try Again. My security settings are still messed up somehow and I don't know if maybe I'm doing those settings wrong.

Report •
Related Solutions

Ask Question