TeckNet Z4 issue problems

June 22, 2016 at 16:25:05
Specs: Windows 10
Bought a new pc, everything works except the mouse, the pointer appears on the screen but wont move if i click buttons/move the mouse.

Not sure if its a compatibility issue, as it was working just fine on my old computer.

The device manager says the mouse is recognized and working correctly.

I've also updated the drivers but it is already up to date with the drivers, tried also to disconnect and reconnect the use nano receiver from the usb hubs.

Not sure what else to do, any help would be appreciated.

See More: TeckNet Z4 issue problems

Report •

June 22, 2016 at 16:45:19
It's detecting the mouse since the pointer is showing and no problem is seen in device manager.

Is it a USB or PS/2 mouse? Is it connected via some USB/PS/2 adapter?

The first thing to do would be to try another mouse.

Report •

June 22, 2016 at 17:37:13
Is this a laptop?

Report •

June 22, 2016 at 18:37:44
I've had a new custom build pc, just delivered today and tried the mouse on it, everything else works fine including wired keyboard, as i said the mouse does show in device manager as working correctly, but theres no action/movement with the cursor when i click any buttons or move the mouse.

Its a usb wireless mouse which i use a nano receiver plugged into a usb port on the computer.

Going to try another mouse when i get home later, but just wanted to troubleshoot any ideas about it here first.

Also wondering if i should do a manual resync with the nano receiver for the new computer, however i dont have the manual anymore and cant remember how the manual resync was done, anyone know how to do this?

message edited by Askanison

Report •

Related Solutions

June 22, 2016 at 19:25:06
manual resync with the nano receiver

Report •

June 22, 2016 at 19:46:09
cheers mate, i also noticed on that manual that the mouse only works for windows os upto 8 by the looks of it (mines windows 10).

Will try manually resynching it and if that doesn't work will try another mouse.

Report •

June 23, 2016 at 14:11:08
yup looks like it was the wireless mouse playing up, i've ordered a new one.

Thanks for the help guys.

Report •

Ask Question