Strange power issue with laptop

May 16, 2019 at 07:29:25
Specs: Windows 10, 4G

My nice old Dell Vostro 3560 suddenly died. Won't charge or start with or without battery. Tried different chargers. Any ideas on how to bring it back to life?

When I plug my charger in, it turns it off! The light goes off at the end of the charger, for all different chargers.

This is very strange.

How can the laptop turn off the charger, which re-starts after I turn the power off and on again.

Any clues?

Thanks


See More: Strange power issue with laptop

Reply ↓  Report •

#1
May 16, 2019 at 08:25:26
For starters, plugging the charger into the computer just
turns off the light, not the charger. It does indicate that the
charger isn't working, but that is because of a problem in
the laptop.

The laptop must be either trying to draw too much power
or too little. Possibly corresponding to a short circuit or an
open circuit. Or a bad component such as a capacitor.

-- Jeff, in Minneapolis


Reply ↓  Report •

#2
May 16, 2019 at 10:11:23
Possibly laptop battery. Not working and loading the charger too much.

Always pop back and let us know the outcome - thanks


Reply ↓  Report •

#3
May 16, 2019 at 16:19:09
If possible, with the charger powered up but not connected to the laptop, put a DC voltmeter to the charger tips. Since it's essentially an open circuit connection the voltage you read should be a little higher than the charger's rated voltage output. But it might give you can idea on whether the problem is with the charger or the battery.

Reply ↓  Report •

Related Solutions

#4
May 17, 2019 at 01:40:33
Hi t8769, I suspect there could be more than one fault:

a) Battery (how old is it?)

and

b) Laptop charging Circuitry - as you advise it does NOT start with different Chargers.
Presume you tried them all with *AND* without Battery Installed.

Here in the UK, generally oem Laptop Batteries are inexpensive.
If the one you have is more than a year old, I would take a gamble
and buy one to see if it helps overcome the problem.

Can you charge the old Battery elsewhere, or borrow a known good one.

Any possibility the Filter is clogged with Dust / Fluff and needs clearing?

Good Luck - keep us posted.

message edited by Mike Newcomb


Reply ↓  Report •

Ask Question