Star NX-1000 USB to Parallel IEEE-1284 (Solved - dot-matrix)

May 6, 2017 at 09:35:04
Specs: Windows 7
In answer to Star NX-1000 USB to Parallel IEEE-1284.

I don't know if anyone is still looking for answers to this, but I just had the exact same issue: Connecting a Star NX-1000 to Win 7 Ultimate x64 using a USB->IEEE-1284 adapter.

What I had to do was select the EPSON LX Series 1 (80) drivers from the 'add hardware' wizard, after making sure that DIP switch 1-6 was set to 'on'. I also had to specify the port as USB03 - this may be different in each situation. The easiest way to know that you are selecting the right port is to go to 'Devices and Printers', and look at the properties of the "IEEE-1284 Controller" device, hardware tab, location. Mine shows "Port_#0005.Hub_#0003".

Now for the important part. In order to get this 1st-gen dot-matrix LPT printer to work with a USB adapter on a 64-bit machine, we have to 'trick' the system. This is accomplished by using it as a 'dummy' network shared printer on LPTx. This is easily done by using the NET USE command.

Share the printer, using a share-name easy to remember, such as "Printer".

Connect the shared printer as LPT1 with the following command-line instruction:

NET USE LPT1: \\[Computer-Name]\Printer /PERSISTENT:YES
Where [Computer-Name] is the name of the computer and Printer is the share name of the printer.

Now, whenever you want to print manually, select the printer from the network. Alternatively, you can use a batch script or manually enter the printer command sequence. Be sure to correctly specify the LPTx port as the printer 'name' when doing it via CLI.

Here's a link to the manual from the manufacturer for the NX-1000:
http://www.star-m.jp/eng/service/us...

message edited by 80sFan


See More: Star NX-1000 USB to Parallel IEEE-1284 (Solved - dot-matrix)

Report •

#1
May 6, 2017 at 10:22:17
It might help someone but I would be surprised if the original poster is still interested as it was November 2015.

Always pop back and let us know the outcome - thanks


Report •

#2
May 6, 2017 at 14:27:14
I figured the same, but these kinds of questions seem to be pretty persistent - I've even seen them for installing dot-matrix onto Windows10. Hopefully, the instructions will be of help to the next person trying to hook up an early-gen dot-matrix to a more 'current' OS.

Report •

#3
May 6, 2017 at 14:32:47
I have a Canon whatver model dot-matrix printer in the loft. Been there for a wee while, since I bought an Epson laser printer in '94. Might be an interesting experiment to see if I can get it work with my current Macs, and also win-XP and win-7...

Report •

Related Solutions

#4
May 6, 2017 at 15:16:33
The process should be pretty much the same - use a generic Canon driver if there isn't a specific one available, that's really the only difference that comes to mind. The major difficulty seems to be from 'modern' machines not having parallel ports, while the printers only work when addressed as LPT(x). If the printer has hardware configuration options, setting it to an Epson-compatible mode should solve the driver issue.

One thing that I didn't go into in my original post is the difference between the (80) and (136) Epson drivers is the width of the printer - (80) is 'standard', and (136) is 'wide'.

Good luck, and let us know if you are able to make things work!

message edited by 80sFan


Report •

#5
May 6, 2017 at 16:09:56
I'm fortunate to have a '98 Dell tower - came with '98 installed and has everything from dos 6x thru to XP installed... It has a parallel port of course; and I have a couple of D-lnk lan to parallel port adapters, so I can network parallel port devices... Just have to find time to play with it via the Dell and/or my more recent Macs (dual booting Mac OS and win-7 or XP).

message edited by trvlr


Report •

Ask Question