southbridge and Multi I/O

Toshiba / Satellite l300
January 20, 2010 at 23:52:21
Specs: Windows 7
Southbridge and multi I/O doesn`t work .I need to chamge all motherboard or other solution

See More: southbridge and Multi I/O

Report •

#1
January 21, 2010 at 00:06:12
If the southbridge is gone, i don`t think you can repair it......

Google is your friend

www.google.com

-----------------------

Keyboard not present,press F1 to continue...


Report •

#2
January 21, 2010 at 00:47:12
thank you , i tooth so ..now i need to replace the motherboard and how i know the problem is not appear again?

Report •

#3
January 21, 2010 at 01:29:46
Err....are you 100% sure that the southbridge is not working ? What actually happens ? Does the computer boot ?

As the southbridge controls the sound card, PCI-E, USB and other devices, try plugging in an USB stick in the back of the computer and see if it works....

About replacing the motherboard....I`ll ask again.....are you SURE that the southbridge is not working ?

Google is your friend

www.google.com

-----------------------

Keyboard not present,press F1 to continue...


Report •

Related Solutions

#4
January 21, 2010 at 05:34:57
It's weird southbridge not working and system is running. May be u didn't install chipset driver or audio and other devices are disabled in bios.

Report •

#5
January 21, 2010 at 11:32:32
Yup...that`s the same what I thought....a computer wound`t boot without a working southbridge.....

moathbro

What`s your motherboard model ?....

Google is your friend

www.google.com

-----------------------

Keyboard not present,press F1 to continue...


Report •

#6
January 21, 2010 at 13:15:32
doesn`t work nothing , not boot , not start up ..just dead....only the led`s from power and batery...i try to start and push the power button ...the led`s go off and on after few second
the service company just maked the diagnose and southbridge and multi I/O and dead.....

Report •

#7
January 22, 2010 at 03:19:56
Read Response # 1....

Google is your friend

www.google.com

-----------------------

Keyboard not present,press F1 to continue...


Report •

Ask Question