Solved Sound card giving problems

September 8, 2016 at 11:05:22
Specs: Win10, i3, 8gb
Hello. I game a lot on my pc. I have an i3 5th gen, 8gb ram and an Nvidia gtx 750. All good, but the motherboard. It has a 3 port stereo on board sound card. I have external creative speakers, which sound great. Even at very high volumes. But when I connect a headphone, the volume is extremely low. So I bought the Creative Soundblaster play 2 external USB sound card. Now I use my headphones, the hr volume is fine, but when the bass goes high, the sound drops at that moment. Like in a song, every bass beat the sound kinda gets a hiccup. I thought my headphones are bad, so tried em with my sennheiser earphones. They run great at mid volumes, but listen to some moderately high bass and the same problem. Is there any solution?

See More: Sound card giving problems

Report •

#1
September 8, 2016 at 11:17:59
✔ Best Answer
It sounds like it's running some sort of compressor/limiter to keep you from clipping the amplifier. Go into the sound properties of the card and see if you can find any effects options to turn it off.

Report •

#2
September 8, 2016 at 14:47:48
I'm curious - why would you buy an external USB "card" rather than disabling the onboard & adding a PCI or PCIe sound card?

Other than that, I agree with THX...check the Creative software settings.


Report •

#3
September 8, 2016 at 20:52:51
I checked the Creative tool. Just equalizer options. Lots of em. I tried disabling the equalizer. Still the same. I changed the USB port it was connected to. Still the same. What could be the problem? I really doubt creative would produce such s---ty quality.

Report •

Related Solutions

#4
September 8, 2016 at 21:13:13
Hey I got it. Thanks guys. I had to disable the Enhancements in the Win10 sound properties. That fixed it. Cheerio! :D

Report •

#5
September 9, 2016 at 07:36:03
So often those "features" screw things up - it's a pity they even exist. I had to do the same on a totally different system.

Always pop back and let us know the outcome - thanks


Report •

#6
September 9, 2016 at 08:18:43
Glad to hear you got it fixed. And thanks for posting the fix, this will be handy for others who have the same issues.

Report •

Ask Question