SOLVED USB ports not working after W7 upgrade

Acer / Aspire 5516
December 25, 2010 at 23:14:53
Specs: Windows 7, 1.6 ghz/2gb
I just upgraded from Vista to 7 and neither of my USB ports work. I can see they get power as my memory stick lights up. Normally the light glows then dims and glows, but now it just glows steady. Tried other devices and the ports are the problem. They worked fine the immediately before upgrading.

See More: SOLVED USB ports not working after W7 upgrade

Report •

December 25, 2010 at 23:51:20
It may be a driver issue. I know nothing about how Win7 manages these but Devicemanager or it's equivalent is the place to start looking.

Goin' Fishin' (Some day)

Report •

December 26, 2010 at 00:58:29
Found a working solution! I found a single comment on another thread to shut-down Windows, and completely remove power from the machine (battery, rocker switch on power supply, if there is one, and remove the plug) - wait thirty seconds, and plug it all back in and turn on. At a loss, I tried this, and lo and behold it worked. All my USB devices work now as normal.

Report •
Related Solutions

Ask Question