Slow DVD read speeds + laggy mouse

October 14, 2009 at 06:41:04
Specs: Windows XP Home, AMD phenom x2 3ghz/2Gb DDR2 800mhz
Hi all. Recently installed a new DVD drive in my current system and I've noticed when it's reading discs the read speed is slow, the advertised read speed is 16x for DVDs but it's definitely not that.

Another issue with it is that when it is reading my mouse cursor lags. Could this be something to do with the power supply?

Many thanks


See More: Slow DVD read speeds + laggy mouse

Report •

October 14, 2009 at 07:38:10
The max read speed varies depending on what type of DVD or CD disk you're reading.

If it's an IDE connected DVD drive capable of burning at 16X or greater speeds for DVD -R or DVD +R disks, it must be connected to an 80 wire data cable in order to reach it's max rated speeds. That also applies to any IDE hard drive capable of UDMA 66 speeds or greater.

Also, the mboard main chipset drivers have to have been loaded in order for hard drives and optical drives to reach their max rated speeds.

If you loaded Windows from a regular CD....

Whenever you load Windows from a regular Windows CD (or DVD) from scratch, after Setup is finished you must load the drivers for the mboard, particularly the main chipset drivers, in order for Windows to have the proper drivers for and information about your mboard hardware, including it's AGP or PCI-E, ACPI, USB 2.0 if it has it, and hard drive controller support. If you have a generic system and have the CD that came with the mboard, all the necessary drivers are on it. If you load drivers from the web, brand name system builders and mboard makers often DO NOT have the main chipset drivers listed in the downloads for your model - in that case you must go to the maker of the main chipset's web site, get the drivers, and load them.

Report •

October 14, 2009 at 12:52:57
Did a complete reformat earlier and still no luck with this problem, I've checked and changed IDE cables and also checked the HDD ones too. Yeh I did install all chipset drivers etc I know what I'm doing when it comes to that stuff.

My PSU is a 540w, I'm running a 3ghz dual core and a 9600GT gfx card. I'd just love to know why it's going so slow, my whole system is laggy when reading something from a disc, as I'm typing now I'm getting input lag. Could this be something to do with the PSU?

Also I've noticed that one of the IDE pins in the back of the DVD drive is pushed in slightly, could this be what's causing it?

Report •

October 14, 2009 at 16:23:26
Are the data cables all 80 wire ones?

Faulty PSs do not normally cause the symptoms you're getting.
Your PS has a lot more capacity than the minumum you need. You can check the current voltages in the bios Setup - if +3.3v, +5v, and +12v are within 10% of nominal, there's probably nothing wrong with the PS.

"one of the IDE pins in the back of the DVD drive is pushed in slightly"

What do you mean by slightly?

"....could this be what's causing it?"

All your symptoms? - extremely unlikely.

Rermove the AC power to the computer, disconnect the DVD drive's IDE connector (you may need to change a jumper setting on another drive on the same data cable when you do that) , restore the AC power, try the computer, see if you still have the other symptoms..

Examine the mboard to see if you have bad capacitors, and/or other findable signs of mboard damage .

This was the original bad capacitor problem - has some example pictures.
History of why the exploding capacitors and which mboard makers were affected:

What to look for, mboard symptoms, example pictures:
Home page that site
- what the problem is caused by
- he says there are STILL bad capacitors on more recent mboards.

Pictures of blown capacitors, other components, power supplies, Athlon cpu's, etc.:

Report •

Related Solutions

October 14, 2009 at 21:03:52
Go to Device Manager. Expand IDE ATA/ATAPI controllers. Right click on Primary IDE channel and select Properties> Advanced settings. What is the current transfer mode?

Repeat for Secondary IDE channel.

If you are not running in a DMA mode then you haven't properly installed the chipset drivers or you have defective cables.

Isolating (connect to the other controller, if available) the optical drive from your OS hard drive will improve performance too.

Report •

October 15, 2009 at 03:13:00
Thanks for the replies, my hard drive is SATA so it's not connected to the DVD drive. The data cable is an 80 wire one, could it be a faulty cable? I could try replacing that.

The pin that is pushed in slightly is because of me being an idiot and forcing the IDE cable in upside-down. I may have to open up the drive to see if I can push the pin back out if this is what's causing it.

The primary IDE channel is reporting that it's on ultra "DMA mode 6" a secondary IDE channel is listed as PIO mode as it's current transfer mode, I don't know what this device could be as I only have a DVD drive connected via IDE. Also the DVD jumper is set to master. It must be something to do with the DVD drive, I just tried to transfer some data from a disc to a flash drive and it's still doing it.

*is confused*

Report •

October 15, 2009 at 03:30:27
Ok just switched the IDE cable for another one and its still the same. Checked mobo and couldnt find any bad capacitators. Chipset drivers are installed and the DVD firmware was upgraded but it hasnt made a difference.

Report •

October 15, 2009 at 05:19:50
Remove the optical drive from Device Manager and reboot. If the transfer mode doesn't change to a DMA mode, probably mode 4, then the pin is probably the issue. Try PULLING the pin back out with pliers.

That said, the chip set drivers can also be the cause of the slow PIO mode.

Report •

October 15, 2009 at 07:36:14
How much is the pin pushed in? If it's not more than 1/4" the pin is probably connecting okay - in that case don't mess with it unless trying another IDE data cable doesn't help !

"Try PULLING the pin back out with pliers."

The pin may be hollow ! Be very carefuly not to squish it !

Assuming you have only the SATA hard drive and the IDE DVD drive....

"The primary IDE channel is reporting that it's on ultra "DMA mode 6" ..."

That's the SATA drive, running in IDE compatible mode
(ATA / UDMA 133)

"....a secondary IDE channel is listed as PIO mode as it's current transfer mode,..."

That's the DVD drive.
No IDE DVD burner drive can run any faster than Ultra DMA mode 4 (ATA / UDMA 66).
No drive should be running in PIO mode.

You probably have an IDE data cable problem, OR the pushed in pin is causing the problem.

If you fix the IDE data cable problem, if the mode doesn't go into Ultra DMA mode 4 automatically, try resetting it.
Choose DMA if avalable there, OK, then go back in and see if it's changed to Ultra DMA mode 4.

If it won't re-set to Ultra DMA 4 after correcting the IDE data cable problem, if the pushed in pin is not causing the problem, XP has added a line to the registry that prevents you from re-setting it to a mode higher than PIO.

You must remove that line.

Start up Regedit.
Start -> Run -> type: Regedit , press Enter

Make sure the highlighted entry on the left is at the begining of the "tree".

In the top menu choose Edit - Find
type: MasterIdDataChecksum
(this applies to any hard drive or CD or DVD drive connected as master)
(case of the letters - upper or lower - doesn't matter)
Click on Find Next.
Windows will search the Registry for the first instance. Your hard drive led will probably not light up. It may take a while.
When it finds the first instance of MasterIdDataChecksum
delete the "MasterIdDataChecksum" named value.
As in - RIGHT click on the highlighted entry, select Delete.
The entry will disappear and the highlight will go to another value -
DO NOT delete that value.

Press F3 to find the next instance of MasterIdDataChecksum
delete the "MasterIdDataChecksum" named value.

Keep pressing F3 to find all instances of MasterIdDataChecksum and delete the value.

When no more instances of MasterIdDataChecksum are found close the Regedit window.

If a cd or dvd drive or hard drive is connected as slave, and it is stuck in PIO mode and you cannot get it to go into a UDMA mode - do the same thing as above,
except search for: SlaveIdDataChecksum
(this applies to any hard drive or CD or DVD drive connected as slave)
(case of the letters - upper or lower - doesn't matter)

Reboot Windows.

Go here on the web and see how to confirm whether the hard or cd or dvd drive that was stuck in PIO mode before is now in a UDMA mode or not - if it is in PIO mode, change the device to "DMA if available", click OK and reopen the Properties tab and look again.

Report •

October 15, 2009 at 08:35:45
Tubesandwires you're the man!

I just deleted the checksum reg entries as you said and when I rebooted the secondary IDE channel (the DVD drive) was on ultra DMA mode 4 instead of PIO!

Doing a dvd read speed test in nero at the moment, it starts off slow and gradually increases the speed. Right now it's at 11x, I'm sure it won't be long now until it hits it's peak 16x for DVD.

Thank you thank you thank you! it's working as normal now. Feel free to close the thread, damn I hate windows :p thanks again!

Report •

October 15, 2009 at 10:53:26
We're glad to hear you solved your problem !

Your initial problem was probably caused by an iffy data cable connection. If the problem goes on long enough, XP (and 2000 and probably Vista and Windows 7) automatically makes that line or similar in the Registry without any notification and you must remove it.

Report •

Ask Question