Shuttle XPC desktop repair

July 23, 2010 at 03:34:11
Specs: Windows XP, 1gig
Hi all

This is my first post on this site so can I start off by saying hello to everyone and please be gentle!

Ok I have a bit of PC knowledge from messing about over the years but sure you guys will have a lot more!

I have bought Pc shuttle which I am trying to repair!

The system I bought as spare and repairs and is

Shuttle XPC — SN85G4
Athlon64 3000+
200GB Hard disk
1GB DDR 400
ATI 9800Pro

The system would post but that was it. Just a inservet system disk etc

Tried to install windows etc but nothing would go on just a black screen after you boot from cd.

So I have started to figure out what is up!

Tried a few different versions of windows 7 xp etc but nothing would boot.
Had a quick look in the BIOS and changed a few settings such as disabling BIOS caching and changing halt on none but nothing would get it to boot windows

I changed the setting to disable RAID and tried to run win 98 which it started to load (very slow) and got all the way to the blue screen where it check’s the free space, file system etc you know where it ticks all the boxes but it crashes out and resterts then it tries to run check disk but cant reapir so you have to FDISK again but I was happy as I had got something to half load..

I downloaded hirence boots cd and did some various hard disk test which it said there were bad sectors and read errors on the hard disk.
So I have swapped this out for an old 40gig drive. Ran the test again and there was no errors.

I noticed when the PC was posting but when it says detecting IDE it hangs for about 40seconds then finds the drives, this is with the CD and HD set on master but there on separate IDE cables.

I changed the HD to slave and the system post fine with no hangs! I thought this was little strange.

I tried to run a mem test from Hirens boot cd but it just crashes out with some funny symbols on the screen (Can you recommend a mem test utility to boot from)

I figured this mean’s there is a problem with the Ram or the Graphics card isn’t compatible. I swapped out the 1GB DDR 400 for some 1GB DDR 333mhz but still the test wouldn’t run.

Any how I have messed on and managed to get XP to Install but this took at least 5 hours !!
So there is something still wrong with it. could be old HD or the fact its slave etc

I tried windows last night at 1am ! and its supper slow etc

So im after some advice now on what to try next ?

I feared it was the Mother board but since I have managed to install on it can I rule this out ?

Could it be the PSU not giving the correct output?

I have a 120gig I can try but not sure how to fix the Master/Slave situation
I have a few diff versions of XP I could try.
Is there any programme I can run while I have xp installed that will detect any problems etc?

Now I am hoping you can help so please point me in the right direction lol

Thanks in Advance


See More: Shuttle XPC desktop repair

Report •

July 23, 2010 at 04:51:46
it is a old system but not a bad system.
Use memtest86 or memtest86+ to test ram (use latest version mem86 3.5, mem86+ 4.10)
before testing ram clean it first (use pencil eraser).
I suspect cpu is overheating, check cpu temp in bios.
Hdd and cd rom are connected in different channels right? I think clearing bios will help. Set hdd & cd rom to master (diff channels) the unplug power cord then remove battery for few seconds (board manual should xplain). Make sure ide cable is fine (no sharp bend).

Report •

July 23, 2010 at 04:58:22
hi thanks for the reply

i will download and run memtest 86 and let you know, nice tip on cleaning the RAM

I wil post the CPU temp but i dont think its over heating from what i seen on the BIOS.. what should it be 50c??
I suspect cpu is overheating, check cpu temp in bios.
Hdd and cd rom are connected on different channels but if i put the HD on master it will hang.. do i need to clear the CMOS ? i will take battery and power off for a few min


Report •

July 23, 2010 at 05:39:33
i experience the same issue and clearing bios was the answer.

Report •

Related Solutions

July 23, 2010 at 10:09:41
HI all just a update

have taken the battery out and left the sytem without power for 5min

power up and it said error on Cmos so i hit F1 to contiunie and now it wornt boot.

i have taken the CD drive out so there is only the HD connected but the thing still wont boot tried CS MASTER AND SLAVE but it just hangs with a black screen after post.

Started changing setting in the BIOS the only way it will boot is if i DISABLE "SIL3512A SATA RAID ROM" ???

i have tried the HD on CS and Master but unless its on SLAVE it wont boot and its the only drive connected to i IDE

Any ways loaded windows super slow installed all the driver etc and its still slow egg timer etc open task manager and the CPU is sitting 5% is soon as i move the task bar window the CPU goes to 100% for a second and then idles

i have ran the WD hardisk tool and it past all the S.M.A.R.T test so don't think its the HD

I am about to run MEMTEST and see what that says

Also checked for any blow CAPS and i cant see any leaks or swelling etc

Checked temps from BIOS

CPU V 1.53
RAM V 2.6V
AGP V 1.45V
3.3V VIN 3.34
+5V VIN 4.91
+12V VIN 11.71
- 12V VIN (-) 12.03
5V SBVIN 4.81V

Report •

July 23, 2010 at 10:54:13
Lots going on with me today. When I started writing this response there weren't all the ones above. I will leave it as written anyway. Take away what works for you.

Try to POST with minimal hardware. Best to remove the board from the case. Only have CPU/HS/fan, 1 stick of RAM, some sort of video, monitor, keyboard and PSU to board connections. No case to board connections. No other add in cards. No drives of any kind. No external hardware other than mentioned already.

Start the board by shorting the two power switch pins temporarily with a flat blade screw driver.

Board should POST to a screen indicating no boot device or similar. You should hear one beep. If that doesn't happen then pull the RAM and try again. You should get more beeps indicating a RAM error. If none of that happens then you have a bad CPU or board.

All assumes the PSU is good and of sufficient wattage.

If you can POST like that then try adding in the drive/s. One defective drive can hang the POST.

Report •

July 23, 2010 at 11:42:13
Try to check hdd transfer mode is set to dma and not pio. Go to device manager expand IDE ATA/ATAPI controllers then double click primary IDE channel then advanced settings, check current transfer mode (i assume hdd is connected via primary channel)

Report •

July 23, 2010 at 11:44:56
Thanks "onthehill"

this is where im at

i have managed to get the HD to MASTER and the cd to SLAVE but this is on one ide cable, the BLUE IDE channel on the borad! The white one is now empty, does this affect anything i could try the WHITE slot?

Ran mem test and found zero faults :)

so whats next ? how does the voltage look shal i change the PSU ?

Can i use a normal PSU i only have a 400WATT kicking about of a old ATX board will this be to much for a Micro ATX board?

I can try reinstall on a 120 gig i have also change the IDE channel and cable ?

failing this i will revert back to what you said and start from scratch



Report •

July 23, 2010 at 11:46:00

which is the primary channel the white port or blue on the Mobo ??

Report •

July 23, 2010 at 11:54:15
Which DMA its et to DMA 5 ?
enable write catch is ticked

Report •

July 23, 2010 at 12:26:06
The blue connector is IDE 0 (primary).

Do you have an optical drive in the system? If so, connect it as a Master on the secondary channel.

Disconnect the primary channel from the motherboard and pull the power from the drives.

Now try to boot to a Windows setup disk or any bootable disk you have. If sucessful then shutdown and try the same using the Primary channel. This will determine if the IDE controllers are functional.

After that you should only introduce ONE hard drive at a time so as to not complicate things. Western Digital IDE drives have two Master settings. One for Master alone (no other drive on same cable) or Master with Slave.

Report •

July 23, 2010 at 12:48:49
i Think i have cracked it

Removed USB front pannel

Put the HD as CS and on a diffrent IDE cable in the White (Second channel) and now its very quick swapped to Primary channel.

So i just need to figure out if it was the cable USB front or some confilct on the channels

will update soon

Report •

July 23, 2010 at 12:59:31
If the front USB ports were connected wrong or possibly to a firewire header that may have caused the system to hang. The header the USB was connected to may now be damaged.

Didn't I suggest you disconnect all that wiring?

Report •

July 23, 2010 at 13:23:56
Yes you did and thats where i got to mate
added back in the USB header. added the 120 drive and boots ok at the moment the only think that makes the system hang is enabling SATA in the BIOS im assuming beacuse its looking and not finding it crahses out ?

CD drive doing in next dude

Report •

July 23, 2010 at 13:58:11
Right got the system all working again but then i have broke it lol

had everything up and running just about to put case back on but thought id try the front usb so i pulled mouse out the back pushed it in the front and nothing! put it back in the rear usb still nothing !! restarted still nothing ! keyboard was working on USB did the same and got the same result

so now i dont have any USB back or front

whats going on this sytem is jinxed lol

sure its a easy fix

Report •

July 23, 2010 at 14:17:44
Disconnect the front USB from the headers and leave it off. As I stated above it may be wired wrong or even connected to a firewire header, they look the same.

Try to find a PDF of the manual to determine the correct pinout.

Report •

July 23, 2010 at 14:20:29
going to do it now mate

but they were all fine untill i unpulgged and re plugged in as if i blew a fuse or somet !!

Report •

July 23, 2010 at 14:28:46
Cleared Cmos and all is good

gonna call that a day.. PC all up and running

thanks very much to all that helpped thanks for baring with me lol

will be back again


Report •

July 23, 2010 at 15:04:58
yeah iam glad to hear the system is ok.

Report •

Ask Question