Select keys on an external keyboard stopped working

March 12, 2014 at 21:08:21
Specs: Windows 8.0, Pentium 2.40GHZ/6GB Ram
(by select I mean "some")

Hello, I use an I-Concepts floppy keyboard via USB on my Toshiba laptop (Satellite C55-A, WIn 8.0). Up until about 30 minutes ago, it worked fine. Then I walked away and came back to it, it and there are keys no longer working:

down arrow

Everything else seems fine.

I tried uninstalling the keyboard in the Device Manager, then reinstalling it after removing it from the computer (removed the USB plug), rebooted and put it back in. This didn't fix it.

I tried using a brand new identical keyboard, and got the exact same problems. So it has to be the computer, not the keyboard.

I've run virus scans and run them regularly, my CPU is clean. Does anyone have any suggestions? It's tough to get by without having the space key available (I am obviously typing form the laptop's' keyboard).

I also tried a different USB Port, no luck.

The Number Pad is also nonfunctional.

message edited by mdv88geo

See More: Select keys on an external keyboard stopped working

Report •

March 13, 2014 at 04:48:35
Have you verified in Control Panel> Region and Language, that you have the keyboard set correctly?

Report •

March 13, 2014 at 08:26:22
Yes, it is set correctly.

Report •
Related Solutions

Ask Question