Secondary SATA HDD freezes Win764bit

January 18, 2012 at 10:26:41
Specs: Windows 7 64-bit , i7 / 12gb
Typing this from my android phone, beware of spelling/grammar.


Mobo - Asus sabertooth x58
Windows 7 home basic 64 bit
Installed on a 64gb SSD
Bad drive - WD Caviar Black 640gb
Both connected via SATA 6 gbps

Ive been troubleshooting this one and off forum a few weeks, being cautious as to avoid losing my data. Finally isolated the problem to my secondary/storage drive. BIOS detects it, it spins and sounds good, but windows will not boot when it is connected. It hangs one the logo. Booting into safe mode gets as far as classpnp.sys and stops. Windows recovery console sees the drive but says the device is not ready or inaccessable.

When disconnected, windows boots no problem. When the drive is hot swapped, windows frrezes until I disconnect the drive.

I have had no problems with it since it was purchased and built with the rest of the computer over a year ago.

A few times trying to boot ive gotten stop error:

Stop 0x00000074 (0x0000000000000002, 0xfffff880053e8b20, 0x0000000000000002, 0xffffffffc000003a)

And once or twice its booted, but caused the entire system to be slow and the eventual crash.

Ive tried connecting to different sata port and power with no difference.

One other note is that I had created an Ntfs junction between my user profile and the secondary drive, but broke the junction as a troubleshooting step. Not sure if maybe that had something to do with it.

I really need some ideas as I desperately need to recover my data. I use forum video editing and some of the data is not backed up.

Thanks in advance.

See More: Secondary SATA HDD freezes Win764bit

Report •

January 18, 2012 at 10:56:50
Have you set the second hard drive to slave or master?

Report •

January 18, 2012 at 11:00:43
Its sata and configued AHCI. Ith worked over a year no issue.

Report •

January 18, 2012 at 11:51:40
Download the fitness tool to check the drive.

Boot to the fitness test with only the troublesome drive connected.

Slight possibility your power supply is not providing sufficient +12V. Boot into the BIOS screens and see what the values are. All actual readings should be within +-5% of the stated value for the 3.3V, 5V and 12V rails.

Have you tried a different data cable and power connector? Do not fold the data cable tightly.

Report •

Related Solutions

January 18, 2012 at 19:43:54
Boot to a CD with Western Digital hard drive tools or Seatools (from Seagate) and test the drive that way.
Boot to a Live Linux DVD with the drive connected, if the drive 'mounts' there, back up the data. This way you can be less paranoid about the data and be bolder on things you can try.
Try the drive in another computer and see if it works there.

You have to be a little bit crazy to keep you from going insane.

Report •

January 19, 2012 at 06:07:57
Check your Disk order within your boot order, it could be trying to boot to that drive which does not have an MBR on it.
I just added another storage drive for more back up space and the BIOS messed with the hard drive order so it was trying to boot to the wrong drive. The fix took less than a minute, it started and I was ready for partition/format.

You have to be a little bit crazy to keep you from going insane.

Report •

January 19, 2012 at 07:01:01

aja stated that hot swapping the drive locks up Windows. That wouldn't be related to the boot order. Sounds like the drive has mechanical issues.

aja, one thing comes to mind. You have SATA III ports. Do you also have SATA II ports? If so, try using one of them. Also, does the drive in question have a throttling jumper in place to force SATA I compatibility? Check the manual if you are not sure what that is.

I just checked the MBoard specs. No SATA II ports but you have Both Intel (black ports) and Marvel (grey ports) SATA controllers. Use the Intel ports for individual drives. You may not even have the Marvel drivers installed.

Report •

January 19, 2012 at 08:24:52
Booted w/ WD hdd utility and only problem drive. It takes a long time to boot to the cd then says "no drive found"

Tried connecting to both SATA3s and SATA2s and different power connections with no difference.

12v is normal in BIOS.

Next step probably LINUX. Can someone point me to reliable linux .iso that I can run from dvd. Not that familiar with linux.

Report •

January 19, 2012 at 09:11:11

Here's a distro you can run from a usb stick if ya want.

Report •

January 19, 2012 at 11:30:15
Only bother connecting to the black SATA ports. Verify the Intel SATA controllers are all enabled in the BIOS screens.

If the data lifeguard tools isn't seeing the hard drive then there isn't much you can do.

Does the hard drive feel and sound like it is spinning up?

Are you sure you have the hard drive connected with a working power cable and a good data cable?

Report •

January 19, 2012 at 13:18:14
I thought I very been pretty clear. Both SATA controllers are configured for ahci and ive tried both. Even tried configured for ide with the same results. The drive does spin smoothly and silently. BIOS detects it as well as POST with the correct size. The drive was working flawlessly on the SATA3 controller along with the main hdd for over a year.

Report •

January 19, 2012 at 14:06:02
"BIOS detects it as well as POST with the correct size." That doesn't make much sense. If the BIOS detects the drive then WD tools should also be able to detect the drive.

Which controller ports were you using for that year? Black or gray?

What does Windows Disk Management report for the working drive. Post all the info here.

Report •

January 19, 2012 at 17:47:11
Slow to update as I don't have alot of free time to work on this. Another frstration.

Thanks for all the replies some far. Will try some more ideas soon. Still hqvnt tried linux yet.

I read in another thread about putting the hdd in the freezer, but im not sure how I feel about that. Or if it even applies.

Report •

January 19, 2012 at 18:40:51
If the hard drive is rotating then the freezer trick will not help.

Does the computer take a longer time to POST when the 2nd hard drive is connected?

Are you sure you used the correct Western digital file to test the drive?

Report •

January 19, 2012 at 18:52:57
I am running out of ideas. I suggest you consider updating the BIOS version. If you look at the Asus site you will see there are numerous updates. Many refer to improving system stability. You should just be able to flash to the latest version. You may need to also download a utility.

Report •

Ask Question