Second HDD not showing up in BIOS

Dell Precision t5500 computer workstatio...
October 4, 2016 at 09:29:53
Specs: Windows , Dual 2.4G Quad Core/12RAM
Recently purchase a Dell T5500 to upgrade for photo/video editing; OS - Windows 10, running well with no problem. Went to add a 2nd HDD, removed the only 2 data cable on the MoBd (Optical Dr and OS HDD) in order to better access the data ports/cables better. Re-inserted the data cables and the 2nd HDD cable and the only thing that showed in BIOS or Disk Mgr was the OS HDD.

Replace all the data cable and still not showing up in BIOS. I have power to both the optical drive and 2nd hard; drawer opens and HDD is spinning.

I'm at a loss....all info found through google points to bad cable but that's been eliminated.

I have no optical drive or 2nd HDD....both are not showing up in Disk Mgmt or BIOS.

Any help would be appreciated.

See More: Second HDD not showing up in BIOS

Report •

October 4, 2016 at 11:20:26
Did you check the BIOS to make sure the SATA port is turned on for the second hard drive? Did you remember to connect both the SATA and power cables to the hard drive?

Report •

October 4, 2016 at 11:39:55
Yes sir, the drives are enabled but no drive is shown other than the OS drive. The cables are connected, I've checked and double check multiple times.

The T5500 has not been tested by Dell for Windows 10 therefore they are not showing updates to BIOS or anything thing else beyond W7 or W8.

There's much I don't understand but it seems odd that I lost the optical drive and no detection of the 2nd HDD at the same time from just re-arranging the data cables on the MoBrd.

Sure, there's a chance the MoBrd went bad at this point but the surrounding events (W10 upgrade w/no driver support by Dell only drivers provided by Microsoft) leads me to suspect something other than a bad MoBrd. What I do not know.

Thanks for the reply.

Report •

October 4, 2016 at 12:33:00
Did you unplug the computer while inside the case?

message edited by OtheHill

Report •

Related Solutions

October 4, 2016 at 12:44:04
Okay....I figured it out...everything's good, this problem is solved...!!!

I had a suspicion the problem was with the SATA controller. Dell had no updates for W10, I search around through google running numerous apps for driver updates. All of them wanted money, 19 to 39 bucks to complete the scan and to download drivers.

Then I ran across DevID Agent; ran it's scan and a number of missing drivers popped up. Clicked on the ATA - SATA Controller and did the download all at no cost.

Drivers updated complete but nothing changed....opened My PC and still no drives, optical or otherwise.

Did a re-start thinking it was needed, up pops....NO SATA DRIVE - SATA 1 AND 3....or words to that effect.

I remember I enabled all the SATA drives in BIOS even tho no drive was listed. Did the F2, and found the missing drives. Disabled the two empty SATA drives/controllers, applied, and exited.

The restart brought up the computer and everything was good.

I've been on this problem since last night, maybe a total of 8 hours.....all of which was trying to confirm my need for updated controllers and if so where are they?

I gotta thank DevID Agent....glad I ran across this service tool...!!

Only thing left to do is drop in the Radeon RX460 4G video card.'s some info I left out. When I lost the drives only one data port of the 5 ports of the MoBrd worked; the first black port from the blue port. After updating the controllers all the ports worked. This is not a re-built computer, it has the original Dell MoBrd, 0CRH6C, for the T5500.

Report •

October 4, 2016 at 12:46:07
Sorry to OtheHill....we had a cross post but thank you sir for taking the time to reply. I appreciate it.

Report •

October 4, 2016 at 21:07:46
The latest drivers for Windows 8 from Dell would have worked. We generally do not recommend getting drivers from anywhere except the manufacture. In your case it worked. I still would not recommend it though.

You have to be a little bit crazy to keep you from going insane.

Report •

October 4, 2016 at 21:33:50
Agree with Fingers. Many "driver finder" programs contain malware or spyware. As a precaution, I suggest you run a deep scan for infections & include JRT & AdwCleaner as part of your scans.

Report •

October 4, 2016 at 22:35:17
Yes, you're right, getting drivers from other than Dell is risky. Did multiple scans from various cleaners and they found nothing. In hindsight, the driver controller I updated most likely was a W8 version seeing how Dell isn't supporting the T5500 for W10.

It's odd that I'm the only one out here that had this driver problem after the W10 upgrades, at least that's how it seems to me. You can do a search and you'll find nothing on how a W8 controller diver worked for someone else having a similar problem, besides the fact that a lot models of different makes are also not supported for W10.

No matter....thanks for the advice. It's was pointed, cautious, and critical all taken seriously and understood.

Since my last post I've installed a Radeon RX460 4G video card to go along with my Dell 2715Q monitor. The RX460 is a nice entry level card putting out 3840x2160 through a DP to minDP cable provided with the monitor.

I'm not a gamer, I have little concern for benchmarks and other measurements of performance. My concern is whether the machine can play 4K video from a Pani Lumax FZ1000 at 30 to 60 fps. I had a HD6670 1G card in previous;y, 4K played fine but it had no DP 1.2 for 4K resolution. Thus the upgrade.

Thanks for all the suggestions, again I do appreciate it.

Report •

Ask Question