Sata Master HD with ATA Slave HD

Amd athelon / X64
January 4, 2009 at 21:15:47
Specs: Win XP Home SP1, AMD Athlon 64
Hi guys, I have a major problem and I have checked other
posts of similiar problems but i still cannot fix my
I have a MSI Kt3 Ultra2 Motherboard with an AMD Athlon
64 processor. I have a 160 gb SATA drive and a 32 gb IDE
Hard drive. I would like to make the SATA drive the master
drive with the OS and the IDE HD as a storage device. So,

First attempt:
- plugged sata HD into sata 1 slot.
- Plugged IDE HD into IDE slot 1 (i have 2 IDE slots). Also tried pugging IDE HD into IDE slot 2.
-tried putting jumper of IDE HD as master. Also tried no jumper (slave setting)

- Upon installation of WinXP at partition/format screen, it lists the 2 hard drives. But it always lists the IDE HD as
drive C: and the SATA as drive D:. When i select the Drive
D to install the windows on, it always starts formatting
the C: drive for some reason. I cant install the windows on
the D drive, unless i do it on the C drive first. I have even
attempted to pull out the IDE drive first and install
windows on the sata drive. Everything works perfect, but
then when i plug in the IDE drive, all of a sudden, it says
OS cannot boot error (i am assuming it is because it is
trying to boot from the IDE drive which does not have a
OS installed). Then when i go to windows installation
again, it changes the SATA drive to drive D: again and the
IDE hd becomes C:
I have gone into bios to change the boot sequence to:
1) floppy 2) CDROM 3) Hard Disk (I do not see a ssci
then under hard disk boot priority I chose the SATA drive
(Ch2 M.) to be number 1 and the ATA drive (Ch0 M.) to be
number 2.

Also, one time i got it to work , I had the OS installed on
the SATA but it still detected the SATA as drive D: and the
IDE drive as drive C:
and everytime i turned on the computer it would say
boot.ini file error. loading c: windows
other than that problem, it worked OK.
But its annoying because It said that everytime, even
though windows was only installed on the D drive. I even
tried to repair the boot.ini file to no avail.

New update:
-Discovered, that when i changed the boot sequence to: HD before CDROM, the SATA drive becomes C drive and windows loads perfectly.
But once I boot CD before HD, OS error shows up again. It seems that If I boot from one IDE (CDROM) before SATA, the other IDE (IDE HD) will also boot before the SATA.

Is there a workaround ?


See More: Sata Master HD with ATA Slave HD

Report •

January 4, 2009 at 23:30:41
OK NEw update:
- found out that although in partition/format screen when
I choose the SATA drive, it still formats the IDE drive FIRST
before it formats the SATA drive and then installs the OS
on the SATA drive.
- The SATA drive is now labelled as C: and the other drive
is labelled as F:

- I would like to change the name of the IDE HD to D:
instead of F. Is this possible? I already changed the dvd
drive to G so that D is now availalbe.
However when i go into disk management in windows, it
labels the SATA drive as Boot and the IDE hd as System.
and It will not let me change the IDE hd name nor format
it. It says I can not format a System drive. What does it
mean System? I thought the IDE hd would just be treated
as an external hd?

Report •

January 5, 2009 at 00:31:25
Ok UPdate 3:
Now everytime I turn on the computer it says:
disk boot failure, insert system disk and press enter
The computer will not boot unless the windows CD is in
the cd drive.
So I rebooted with my windows CD and went to repair
windows. When i went to the repair screen, I see that The
SATA drive is again labelled as D: and the IDE is labelled
as C:
also, the ntuser and boot.ini files are all on the otherwise
empty C drive instead of on the D drive, which is why D
drive cannot boot.

In my opinion i think the main problem is the bios is still
booting the IDE drive before the SATA drive. But i have no
idea how to fix this

Report •

January 5, 2009 at 07:11:13

First let me give you a tip. All your responses after the original post can be edited. So you can add to a response if you wish.

Now to try and help with your problem.

In the BIOS screens you should find a setting in addition to the normal boot order to choose which hard drive to boot to.

If setting that for the SATA doesn't work you may need to change which SATA port you are connecting to. Usually the lowest numbered port is the one you should use.

In addition to the above information you need to be aware that SATA drivers need to be installed or you need to set the BIOS to have the SATA drive run in an IDE compatibility mode.

Installing the SATA drivers is the more desirable method. When you first started the Windows install you should have seen a screen instructing you to hit F6 if you needed to install any SCSI or third party drivers. At that time you need to hit F6 and provide the drivers on a floppy disk.

If you don't have a floppy drive you have three choices. First one is to install a floppy drive. Second one is to slipstream the drivers into your original WinXP CD files. Third one is to use the IDE compatibility mode. That will degrade the potential performance gain from SATA II. Not a big hit though. I will not explain slip streaming at this point. If interested ask about it.

At this point there is no easy fix to rectify your problem. You will need to reinstall Windows. If you have set to boot to the SATA first and still have problems then you could simply disconnect the IDE drive temporarily.

If you disconnect the IDE and the SATA isn't setup correctly then you will get a message that no hard drive is accessable.

I think I covered everything.

FYI, the SATA and IDE are not connected in any way.

Report •

Related Solutions

January 5, 2009 at 16:09:42
Sorry actually my mother board is the MSI K8N Neo4 fx
I have noticed that under the bios standard CMOS features it lists:
IDE primary master: IDE HD
IDE secondary: dvd
IDE third master: SATA

Under HD boot priority I have set the SATA drive to boot before the IDE HD as previosuly mentioned.

Under bios integrated peripherals it has the choices of
IDE Devices config:
SATA devices config:

-under the ide devices config, onchipIDE channel 0 and 1 are enabled and SATA1/2 and SATA 3/4 are enabled
-under sata devices config, raid is disabled.

I have pressed f6 and used the floppy disk included with the motherboard. and then I run into the same exact problem. I formated both drives but it still labels the IDE drive as C: I installed windows onto the D: SATA drive but it always writes the boot.ini files to the C: IDE drive for some reason.

-if you read my previous lengthy description, I have also tried to first unplug the IDE drive and then install on the SATA drive it works fine until i plug the IDE drive back in, and then it runs into OS error and when i go into windows partition/setup it calls the IDE drive as C: again.

Report •

January 5, 2009 at 16:47:59
Format the IDE drive and then disconnect the drive and only have the SATA drive connected. Install WinXP to the SATA drive performing a full install, including format.

You state that you had the SATA working but was labeled as D:. Did you have an external drive, flash drive, or a memory card installed during the install process?

Is the SATA hard drive a SATA I or SATA II?

Your motherboard only supports SATA I drives. What exact hard drive model is the SATA?

Do you have the SATA drive connected to SATA I port? If your hard drive is a SATA II model there may be a jumper on the back to throttle to SATA I speeds.

I didn't read your entire manual but many motherboards only allow booting from some of the SATA ports and the others are for data.

As far as which hard drive is the system drive, if the IDE drive is clean (formatted) and disconnected I can't see how any boot files can be written to it. When I say disconnect I mean the IDE cable and power cable. Wouldn't hurt to take the IDE drive completely out of the boot order either.

Report •

January 5, 2009 at 17:59:54
st3160827as barracuda 7200.7 Is my hard drive.
I dont know if it is sata 1 or 2.
When i remove the IDE drive an then install the windows on the SATA drive, everything works perfect and it is labelled C:
However when i then plug in the ide hard drive and then turn the computer on, it says OS error or system boot error insert system disk or something like that. As I said before, whenever the IDE is plugged in, it ALWAYS boots to that hD first for some reason. So it wont work even if i set everything up right on the SATA first.

In regards to formatting the IDE drive and then disconnecting before the boot files are written on it, This is impossible to do in windows setup because when i click install windows, it auto formats the IDE drive first and then formats and Installs windows on the SATA drive, when this occurs the boot records have all ready been written on the IDE drive. There is no option to format the drive without installation of windows.

As I said before, i think the main problem is that whenever u plug in the ide drive, it is detected before the SATA drive and thus, no matter what u install first, it will always load the IDE drive first regardless of where the boot record is written

Also, as i mentioned before, I think its quite strange that if CDROM is booted after the hard drive, everything works great! the boot record is written on the SATA drive. It seems once the CDROM ide is booted first, the IDE HD also boots before the SATA, even though i have set the sequence for the IDE hd to boot after the SATA HD

BTW, why is the SATA HD listed is IDE 3 master in bios? Also, i did not notice any difference when i install the ssci/raid drivers vs not installing them.

BTW when i press f6 it says:

Setup could not determine the type of one or more mass storage devices installed in your system. S=specify additional device. I choose S and then i put the floppy disk in and then it says select the SCSI adapter u want from the list. I choose VIA RAID Controller (windowsxp).
There is no option for SATA just VIA RAID

Report •

January 5, 2009 at 18:27:42
So, right now you have WinXP installed on the SATA drive? Disconnect the IDE and boot to WinXP. Go to Disk Management and see what the disk type is.

You didn't say if you have the SATA drive connected to SATA 1 port.

I am not finding that model on the Seagate site but I think it is a SATA II drive. The first number is 3 then the capacity 160 then some other numbers.

Look on the back of the drive for a SATA I jumper. Below is an excerpt form the Seagate site.

A Note on Jumpers and Cabling
Serial ATA interface disk drives are designed for easy installation. It is not necessary to set any jumpers, terminators, or other settings on this drive for proper operation. The jumper block adjacent to the SATA interface connector on SATA 150MB/s drives is for factory use only. The jumper block adjacent to the SATA interface connector on SATA 300MB/s drives can be used to force the drive into SATA 150MB/s mode for use with older SATA controllers that only work with SATA 150MB/s drives.

I am not sure if that will help, if available, but it can't hurt.

Report •

January 5, 2009 at 19:18:34
I think it is sata I.
Go to the seagate website and on the top right hand corner type in st3160827as and search it, u will find the manual.
I have both drives connected right now. As long as the HD is booting before the CDROM in bios, I can login to windows. Right now, the SATA drive is C: and is SYSTEM.
The IDE HD is listed as F: ACTIVE.
I am not sure what u mean when u ask me to check disk type? how do u do that.

Yes the sata is plugged into sata 1. It is odd though that the order of the ports on the motherboard go SATA 2, SATA1, SATA 3, SATA 4 from top to bottom.

So i guess i am still having the same problem, right now the boot records are located on the SATA but once i put CDROM to boot before HD, it will attempt to boot from the IDE HD and then it will say NTDLR missing (because the boot records are on the SATA and not the IDE HD)

Report •

January 6, 2009 at 05:51:15
Go to Disk Management in Windows and look a the information for each drive. The drive will say healthy and the type should be basic. One of the drives will also be marked (system).

Report •

January 6, 2009 at 13:05:22
when CDROM is placed after HD in boot priority, SATA hd is
listed as C:(system) healthy and IDE is listed as F: (active)
When CDROM is placed before HD in boot priority, SATA hd
is listed as D: (boot) and IDE is listed as C: (system)

Report •

January 6, 2009 at 13:23:04
If you disconnect the IDE drive what does Disk management then say?

Report •

January 6, 2009 at 16:26:16
it says Healthy (system) C:

Report •

January 6, 2009 at 17:13:04
But is it a Basic healthy (system) C:?

Was the current installation of WinXP on the SAT installed with the IDE disconnected?

If so, I would connect the IDE and then format it. See how that works.

FYI, I think what is happening is this. I recently remembered about some motherboards that acted like yours is acting. Seems the controllers wanted RAID setups. If you want to play some more and what I just suggested doesn't work then try setting the BIOS for RAID on SATA I&2 and see how that works.

Report •

January 6, 2009 at 17:43:56
yea, it is basic healthy C and yes ide was disconnected.
connecting the IDE will cause the IDE to boot first and thus
come up with an error because NTDLR is missing.
always boots up from IDE first before sata unless cdrom is
placed after HD under boot priority.
hmm i guess i will try raid?
but i am thinking its going to be super slow cause the IDE hd
is old and slow, thats why i wanted to use it as storage

Report •

January 6, 2009 at 17:46:31
No, you don't actually create a RAID array. You just set the boot to a RAID O or 1 array using SATA ports 1&2. Nothing to do with the IDE drive.

Report •

Ask Question