SATA HDD recognized by BIOS but hangs Windows

Wd 500gb caviar re2 green power sata ii...
March 28, 2011 at 16:40:06
Specs: Windows 7, Athlon 64/4GB RAM
Hi, I have a major issue that I've been trying to fix for some time. My internal SATA drive stopped working a while back and I haven't been able to recover the information on it. I desperately need the information, so reformatting is not an option at this point. At the moment I am trying to get the drive recognized by something so I can attempt data recovery myself.

The SATA is a secondary drive, but is the only SATA drive attached. Windows is loaded on an IDE drive, which works fine.

The SATA hard drive acts strange when plugged in. My BIOS recognizes the SATA drive, but only intermittently. Sometimes it does, sometimes it does not. Any attempt at starting Windows 7 with the Hard drive attached (and recognized by BIOS) freezes Windows on the loading screen. When BIOS doesn't recognize it or it is unplugged, Windows starts, but obviously there is no trace of the drive anywhere, not in device manager or disk management.

I bought a USB external enclosure for the drive to see if it would work that way, but when I plug it in, Windows recognizes and then immediately unrecognizes the drive over and over again until I unplug it.

I also tried a boot CD and ran mini XP. It seemed to freeze at the loading screen for that as well, but it eventually loaded. Alas, the hard drive was not there.

Shaking the HDD produces no noise. I don't think there is anything loose inside, but there might be a possibility something is stuck, or the drive is just dead, to my dismay.

I understand I don't have a lot of options seeing as how I can't even load Windows with the drive plugged in anymore, but I wanted to check just in case someone had any idea what was going on. This is a last ditch effort before I take this in to data recovery.

Thank you for any assistance you may be able to give me.

The drive is a Western Digital 500GB Caviar Green Power Internal SATA HDD. I am running Windows 7 64 bit. 750w power supply. CPU is an Athlon 64. 4 GB RAM.

See More: SATA HDD recognized by BIOS but hangs Windows

Report •

March 28, 2011 at 17:06:18
Try testdisk live cd.

"The era of big government is over," said Clinton 1996

Report •

March 28, 2011 at 18:43:57
Did this drive work normally for any length of time? How is the SATA drive setup in the BIOS? Do you have AHCI as an option?

There may be an option in the BIOS to lengthen the seek time for the hard drives. If it exists set to maximum, which may be 5 seconds.

I would suggest you run a fitness test on it and you should. However, it is more important to try and recover your data first.

Report •

March 28, 2011 at 18:49:52
Thank you so much for the suggestion. It didn't fix the issue, but it did help me narrow things down the slightest bit.

I just tried a Knoppix live CD with testdisk at your recommendation, but it doesn't recognize my drive either unfortunately, whether it is attached by the SATA cable or by external enclosure.

It should be noted that it took much longer for Knoppix to load with the drive plugged in via SATA cable. I am thinking that my computer is attempting to start the drive, but eventually fails (even though BIOS recognized it beforehand) and then starts Knoppix and the drive just isn't there.

I also plugged the drive back in it's enclosure and started windows... it is showing up under USB devices now as a USB mass storage device, but with error code 10, "This device cannot start".

Report •

Related Solutions

March 28, 2011 at 19:00:49
Thank you OtheHill :3

This drive had been working with no issues for about 3 years.

When it stopped working, I never really heard any clicking noises or whatnot, so I was relieved.. but then just couldn't get it recognized ever again.

I didn't have AHCI as an option originally, but my motherboard manufacturer (Biostar) has posted drivers for AHCI since then. Perhaps I should give that a try?

In BIOS, all of my SATA options are enabled. At the moment, RAID controllers are disabled, but I have tried both settings. I never set up a RAID array beforehand. There is a SATA spectrum spread option (which i had heard enabling can sometimes cause problems) which I also had disabled but is now back on.

I don't see a seek option for the Hard Drives but I will delve a bit deeper and see if I can find anything else. I should note that sometimes during windows startup with the drive plugged in, it takes a really long time (about 2-3 minutes) but windows will eventually start... I think it happens because it is trying to seek the drive but eventually fails.

My motherboard is a Biostar n61pb-m2s (MCP6P M2+) and is using Phoenix Award BIOS.

Report •

March 28, 2011 at 21:30:33
Newer boards have so many drive connectors that the BIOS options had to be expanded. In addition to the normal boot order where you select hard drive, there is a second option in a later screen that you select WHICH hard drive to boot to first.

When you introduce a new hard drive the BIOS will automatically set that drive as the first hard drive in the boot order. You need to change that selection, if that is happening.

SATA drives are hot swappable so you could try connecting the power cable only, and booting. If you get into Windows then connect the data cable.

Below is a link that gives some reasons for a code 10 error.

I suspect the drive is not spinning up fast enough. If that is the case then there are some possibilities. First one is the previous paragraph. Another is the freezer trick. Wrap the drive in a small cloth and place in a ziplock bag with all air squeezed out. Place in the freezer for an hour or so. When removing you must work fast to connect and attempt data recovery. This can work multiple times. I suspect this may work because you stated the BIOS sees the drive intermittently. If the circuit board was fried it would never show. The fact it is not clicking is a good thing. That can be a head problem. You need a plan of what and how to dump the data. Another internal hard drive would probably be the fastest.

Report •

March 28, 2011 at 22:07:25
Hey OtheHill I used the "freezer" option the other day on a customers pc. A friend told me to try it. I thought he was so full of it. The computer was brought to me and the customer told me that he had called the dell tech line and they said it sounded like the drive was bad. Sure enough it seemed to me to be bad. I put in a new drive and installed his OS and drivers all was great. He called me from work and asked about retrieving data. I said I normally don't do much of that but I would try and if I could not he could always take the drive somewhere to get the data off of it. After removing it from the freezer an quickly connecting it I was so shocked at seeing it work. He only had a bit over 2gbs of data to swap over so it took no time at all. I left it run for several hours with both drives out of curiosity and the old drive never failed until I shut down the system for a few minutes after that it was a no go. Still I was so shocked that it worked. Who thinks " Hey it's broke what the heck let's throw it in the freezer and see what happens?"


Report •

March 29, 2011 at 12:34:27

NOT knoppix.

"The era of big government is over," said Clinton 1996

Report •

March 29, 2011 at 14:05:13
On the page you show, it states Testdisk is available on Knoppix as well as many other Live CDs. If not Knoppix, then what else?

I ran testdisk from the command line and it didn't find my drive.

Report •

March 29, 2011 at 14:07:43
Thanks OtheHill :3

I will try both methods that you suggested. It does seem to me like the drive is taking too long to spin up as well. I do have another external drive with 1TB available so I should be able to transfer the files that way if either method works.

Report •

March 29, 2011 at 15:30:04
If you use the freezer method the drive could stop at any time. I suggest you try freeing up some internal drive space temporarily so you can get faster transfer. That is, unless you don't have that much to get off. USB is much slower than internal. Could use a network drive if you have a home network.

If you go with the external and the problem drive quits you can repeat a necessary.

Use copy instead of cut. If the drive or your computer die while you have files cut you stand a good chance of losing them.

One last thing. You are not sure the drive isn't corrupted. I suggest you download recuva and install it. recuva can usually see files on a hard drive with a corrupted file system. Recuva runs under windows. Get it at the link below.

Report •

March 30, 2011 at 14:00:47
Hummm, I said don't use knoppix. You say knoppix doesn't work. Hummmm. What could that mean?

"The era of big government is over," said Clinton 1996

Report •

April 18, 2011 at 00:21:30
I had a similar problem with an external Lacie 750G usb Sata hard drive.
One day the drive would not load up in windows XP, and would be INCREDIBLY slow to load up on my old linux box (barely able to browse a few directories).

Of course I got pissed and wanted my data, so I pried off the shiny casing and took out the bare drive and tried to boot it up with my main desktop system.
The bios found the drive just fine but XP would hang after initial logo screen.

I thought I was really screwed at this point. As last resort I pulled it out of my desktop machine and put it back together. Now I brought it over to my laptop which is running Linux Mint 10 and plugged it in USB... got the same REALLY slow access, but it seemed to barely mount the drive. I could only view the root of the drive and NO folders... now here is the key: I right clicked within the root folder using file manager and selected "Open in Terminal..." which of course opened up a command line interface to the hard drive I couldn't get using anything else I tried. I typed the command "dir" and could see the folders I wanted to save. Found a tutorial on how to copy files via command line in linux and saved everything I thought i lost on my laptop.... yay!

Report •

Ask Question