Click here for important information about

SATA Drive not detected

Micro-star international K8n neo4-f moth...
July 23, 2010 at 04:55:04
Specs: Vista 32
SATA drive not detected in BIOS.
- new leads (power & signal tried, no change)
- Drvie worked previosly with GigaByte MB so PSU OK
- current board bought this week from owner who ran 2 SATA drives OK
- Jumpered to SATA 1, no change
- Rip hair out.........sorry, too short

See More: SATA Drive not detected

July 23, 2010 at 06:08:31
"Drive worked previously with GigaByte MB so PSU OK"
what happens to giggbyte mb?
"so PSU OK" i didn't understand.
Make sure sata is enabled (bios) and try to swap data cable.

Report •

July 23, 2010 at 07:57:25
Operated OK with previous motherboard in chassis, so PSU was powerful enough. (+12V @ 25A)

Drive & cables have been tested in another PC and function fine.

Gigabyte MB goosed, wont even boot to BIOS, old age and constant running for nearly 8 years (overclocked)

Yes SATA is enabled, BIOS v1.D which is the most recent for this board

Report •

July 23, 2010 at 08:07:23
When the board went out perhaps it took the PCB on the SATA drive with it.

I suggest booting to a drive fitness test for the brand of SATA drive.

Also, there MAY be a setting in the BIOS to delay detection for the drives. If you find such a setting then increase to maximum time.

Are the controllers on the new board SATA II?

Is the hard drive in question SATA II?

Report •

Related Solutions

July 23, 2010 at 10:52:27
SATA drive confirmed good.

Have tried wwith jumpers configured for SATA I & SATA II, no joy.................

Report •

July 23, 2010 at 11:19:34
How was the drive confirmed a good? In another machine?

So the drive in question does NOT show in the POST screens?

Report •

July 23, 2010 at 11:24:37
Proved working in another machine and drive does not show in Bios or POST

Report •

July 23, 2010 at 11:39:26
Then either the SATA controller is defective or disabled, the cable is bad, or you don't have power to the drive.

Did you check the BIOS to verify the SATA controller/s is/are all enabled? Remove all jumpers from the back of the drive.

Shuttle is out of business and I haven't tried to find specs on that board to know if it supports SATA II or not.

There were some motherboards when SATA was first introduced that only did RAID and wouldn't run single SATA drives.

Even if that isn't the case the BIOS settings may be set for RAID, which you don't want.

How many SATA ports are on the board? Are there two different color ports? If so, you may have both a normal SATA controller and a SATA RAID controller.

Try a different SATA port if available. If the ports are numbered, use the lowest number. Verify power is working. Do not tightly fold the data cable. Make sure cables are fully seated.

Report •

Ask Question