Sata 3 Controller issues on Dell

Dell Xps 420 desktop computer ( core 2 q...
March 16, 2014 at 08:51:11
Specs: Windows 7, quad core 2.4 ghz
I have a Dell Xps 420 Desktop I have windows 7 64 bit on it..

I have a WD Blue Sata II 500G HDD as the main HD

I purchased a WD Caviar Black Sata III 1TB. HDD now heres the problem:

I had a previous problem that i fixed by using a jumper to throttle down the speed since my motherboard sata controllers were too old to fully be compatible with a sata 3 drive.

so I bought a sata III controller in an attempt to boot to the drive at the best possible speed(6gb/s) and remove the jumper i use to throttle it down with.

when i try i keep getting blue screen error before i make it to my desktop loading

The only way i can get it working as if its a drive that is not bootable( only for data). Then it does work

I read online somewhere that it wont work for bootable drives..on premade desktops.

is this true or is there a way to get it working?

message edited by matvangogh

See More: Sata 3 Controller issues on Dell

Report •

March 16, 2014 at 10:00:42
I assume you installed a PCI based controller card? Post the model of the controller card.

Report •

March 16, 2014 at 10:07:54
yes PCI -express

Model: SI-PEX40061

message edited by matvangogh

Report •

March 16, 2014 at 11:04:32
That card appears to be what you needed.

I read the brief installation instructions on the SYBA site. They say nothing about how to set the BIOS for boot purposes. In the past, PCI based controller cards are usually set as SCSI or RAID. You don't want RAID.

Boot into the BIOS (setup) and see what options are available.

If you want to boot to the new hard drive you probably should connect the new hard drive and disconnect the 500GB. Boot to the Dell Windows 7 DVD and install Windows. Then you could connect the old drive and it should be accessible but may not be bootable.

Report •

Related Solutions

March 16, 2014 at 11:09:00
i was able to get the WD Sata 3 drive working- but ONLY as a backup drive that cannot be booted. meanwhile i have to use the WD 500gb older sata drive as boot..

i want to use my newer faster drive..

How can i use sata 3 drives on my system and boot with them?

Report •

March 16, 2014 at 11:23:17
You need to set the BIOS to boot from the controller card as mentioned above. Check your options in the manual or in the actual BIOS (setup).

The instructions do not mention the BIOS at all. Newer BIOS versions (EUFI) may change how the add in card interfaces with the boot order. See the link to understand EUFI type BIOSes.

I think your issue is simply one of setting up the boot order to boot to the PCIe card BEFORE booting to the old hard drives. Your boot order should reflect CD first, then possibly some USB device, then the PCIe card, then the legacy hard drives.

Report •

March 16, 2014 at 11:31:33
i tried disconnecting the older drive to my motherboard sata controller

i connected the newer one to the sata 3 controller. i chose in the BIOS settings either Raid or on 'RAID Autodetect / ATA' mode.

neither raid settting works

the controller does work as a backup but i didnt but it as a backup drive. i bought the sata 3 as my main bootable drive..

i had a previous problem that i used a jumper to throttle it down. but when i try the sata 3 controller( while removing the jumper) it doesnt work i get blue screen error before getting into windows

is there anything on here i need to update?

i also read on a blog somewhere where they discussed this problem and mentioned a new BIOS modification a07 with raid support

message edited by matvangogh

Report •

March 16, 2014 at 15:08:02
Did you review the boot order in the BIOS?

Did you install both of the drivers for that card?

message edited by OtheHill

Report •

March 16, 2014 at 16:35:28
There should be two places that the card should show up. First you need to set the card as Bootable on one screen and then you will be offered either the card or the drive as possible in the boot order (usually on another screen).
If these are not possible in your BIOS, you MAY need to do a BIOS Update BUT only of Dell bothered to offer this option as part of a BIOS update. Read carefully all BIOS updates after the version you have to see if any offer this support. If not then do NOT try the update. Here is the reason: Updating a BIOS can be a risky process because if there is any glitch or power issues, you may end up with a system that is not bootable at all any may or may not be ever repairable (except by possibly Dell at their factory or by replacing the motherboard). The use of a UPS or battery back up is strongly recommended during BIOS updates for this reason but only f the update specifically addresses your issue.

You have to be a little bit crazy to keep you from going insane.

message edited by Fingers

Report •

March 16, 2014 at 16:53:28
this is odd i just installed this bios modification for my xps 420

before when i tried using my new sata 3 WD drive it wouldnt work unless i used the jumper to throttle the speed down..

then i could use the drive repeatedly

Before that, I had to use the jumper The new drive could work but only intermittently. between several reboots.. most of the time , the computer would not detect the drive and then boot to the next disk n the Bios boot order( which was my old one)

now after 10 reboots it APPEARS to be working without the jumper or the Sata 3 controller i bought. interesting.

Dell doesnt have an official bios update after the a07 but i found one modified from this blog.

i am going to keep a close eye on this and see if it truly is working or will it stop again.

Thanks for your help. if theres more trouble i reply back..

message edited by matvangogh

Report •

March 16, 2014 at 19:54:14
im still having that intermittent problem. i had to put the jumper back to throttle down which is slowing the read write speeed

my 2nd WD sata 3 drive already has an windows 7 OS on it. but it wont let me bott using the controller. what am i missing here?

message edited by matvangogh

Report •

March 17, 2014 at 07:37:06
OK, I read your Dell manual.

Connect the original hard drive to SATA0.

Connect the CD drive to SATA3.

Page 180 of the manual covers SETUP options. The PCIe card should be identified there.

Page 185 shows you can disable fast boot. I suggest you do so. At least until you solve these problems.

Page 186 covers the boot menu. You get to the boot menu by continuously tapping F12 as soon as you start the computer.

Page 187 lists ALL the boot devices. The controller card should be listed there and you should set it to be the boot device. If two hard drives are connected to the controller card I assume you should see a choice for which to boot to.

Be sure to save changes when exiting setup.

BTW, it appears that model came with Vista installed. Did you get a later version, or did you upgrade?

Report •

March 17, 2014 at 08:01:59
i have 2 dvd -rom drives one of them is on sata 3 i believe

i had the original drive connected to sata 0 all the time

i will try to disable fast boot but it seems like it takes forever to boot up my computer( kind of impractical

i tap F2 to get the thew boot menu. as i said im on BIOS A07 now( i updated it a long time ago. and now i did it again with a newere modified one i mentioned above

and yes I am on windows 7 64 bit i bought it years ago. I hated vista.

heres the deal i want to have both drives i could boot from IF i switch the boot order in the BIOS Boot order list from 1 or the other. Even thought i have RAID ON setting in the BIOS( since Raid/autodetect ata mode doesnt work with this at all) IM not actually using a real raid configuation

My goal is to be able to use BOTH drives to boot ( one at a time if i want to and the other as a backup)

but for most of the time I want to use the newer Sata III 1TB to boot with by moving it up the list if i so desire.

BUT i want to be able to use my older drive to boot as an option IF i ever have any problems( errors, or if the sata 3 drive crashes in the future) I want to use my older one as a back up bootable drive

then i want the other drive to be detected and usuable for data.

Just so you understand?

both WD Sata 3 1tb and and my older WD 500G blue sata has working windows 7 64 bit copies. i want to keep it that way. When 1 is being used at the OS, i will use the other as data backup.and vice versa.

I did this before in the past with a smaller HDD and my original. but now i have a larger one that is supposed to be faster yet still reliable.

and also the sata 3 controller is reading that it IS in fact detected when i turn my computer on*( while the screen is black) It is also showing the model mumber of my sata 3 1tb drive and the speed will appear . So it looks connected to the new controller..

While it starts to load windows( windows animated logo sign comes up but before it gets to my desktop, i get a blues creen,.I cannot read what it says because it comes and goes too fast.)

I will disable fast boot and try my sata 3 drive in the controller again and see if it helps. ill get back to you all soon

message edited by matvangogh

Report •

March 17, 2014 at 08:25:02
I did exactly what you said. I tried disabling Fast boot. i got the same blew screen error. It doesnt work.
I can use the drive fine but it can only be used as a backup drive for data- NOT to boot the OS with. i have to use my older drive for that..

right now the only way i can boot with either drive of my choosing it to not use the new sata 3 controller, use a jumper on the new drive to throttle it down and plug it into my motherboard controllers.

what i dont get is why the sata 3 controller came with a cd-rom for drivers and tools, yet the only way to boot with it is to have the drive connected in the FIRST PLACE which i cant do with the controller since it wont let me boot on a drive using this new controller!

and it doesnt seem like i need it because it autodetects a drive using the controller but the problem is when i boot up with it. 3 seconds into showing the windows animated logo i get a momentary blue screen. i cant see what it says.

message edited by matvangogh

Report •

March 17, 2014 at 11:56:09
Way back above I mentioned EUFI BIOSes. What these are is a BIOS that allows the operating system more control over the hardware. IF you have that type of BIOS then Windows configures the hardware.

Did you look for and adjust the settings I mentioned above in #11.

I suggested you disable fast boot so you could see what hardware is being configured. I suspect the Controller card is being configured by Windows 7, not the BIOS. I pointed to the section in the BIOS (setup) screens to configure the controller card.

After you fix this problem you can enable fast boot again.

Set the BIOS to AHCI, not RAID. Reread #11 above.

After you are booted into Windows on the old hard drive, install the drivers for the card and the controller by running the setup on the CD. After completion, reboot and see what happens.

Report •

March 17, 2014 at 12:14:35
theres only 2 settings i found in my bios -in sata operation category:

Raid ON or RAID Autodetect / ATA mode.

i can only use Raid on it seems. I dont know why there is no AHCI
its possible it was on a previous version of BIOS that i updated a long time ago when i got my computer

i updated it again recently to that xps 420 bios rom 8.5 ich10 w/ raid

message edited by matvangogh

Report •

March 17, 2014 at 14:58:47
Do you have a manual?

All the settings I referred to above are culled from the manual for the XPS 420.

Did you find ANY of the settings I mentioned?

Report •

March 23, 2014 at 09:53:27
i cant find the ahci in the bios. WHy is my bios not the same? i have a dell xps 420

was this changed by the A07 bios update?

Report •

March 24, 2014 at 07:01:51
Post the service tag number on the case.

Report •

March 30, 2014 at 08:26:48
my service tag is:


Report •

March 30, 2014 at 09:53:35
The service tag is not getting me what I wanted. Try running Speccy to get the full specs on your computer.

I am looking for a motherboard model. The newest MB chipset driver for your model is for Vista and dated 2008. Intel should have something newer that may help with your problem. We need more info first. Get Speccy from the link below.

Report •

Ask Question