sandisk flash drive problems

Sandisk 4gb cruzer micro u3 usb2.0 flash...
May 28, 2010 at 11:15:55
Specs: Windows XP
I use a sandisk flash drive to store pictures. My first one filled up, so I tried to use a 2nd one, exact same, and it won't open up. The first one used the K drive but when I look in "My Computer", no K drive shows up and the drives that do show up say 'empty, insert disk", or something to that effect. What is wrong?

See More: sandisk flash drive problems

May 28, 2010 at 12:47:15
Are there files on the second one or is it brand new?

I support the 'Everybody Draw Mohammed Day'. A religion doesn't deny my freedom.

Report •

May 28, 2010 at 14:03:10
Assuming you have the flash drive plugged into a USB port it can actually work with, if the data on the flash drive is damaged it may not show up in My Computer or Windows Explorer. If it shows up in Device Manager and in Disk Management, that problem can usually be fixed.

Troubleshooting USB device problems including for flash drives, external drives, memory cards.
See Response 1:

The (logical) drive letter assigned to a drive you have plugged into a USB port is not necessarily the same every time. Windows assigns the first available drive letter alphabetically to it according to which drive letters are available at the time you plug in the drive. That drive letter is retained as long as that drive is still plugged in, but it may be different the next time you plug it in.
you plug in a flash drive, #1 - say it's assigned K
you plug in another flash drive, #2 - say it's assigned L

If you unplug flash drive #1 without unplugging flash drive #2, flash drive #2 will still be assigned L, as long as it's still plugged in when Windows is running.
If you then unplug flash drive #2 and then plug it back in again, while Windows is running, it will be assigned K, not L.

Report •

May 28, 2010 at 15:46:44
Yes, I have one folder of pictures. I tried putting both scan disks in 2 different ports, took the 2nd one out and put it back in and no luck. When I put 1st one in, the selection window of what I would like to do comes up under "K" - when I put 2nd in, no window of what I would like to do comes up and when I look in "my computer", only E and F drives are showing and when I click on them, it says "please insert disk into drive "E" or "F". My computer is about 4 years old, could that be the reason? I do believe the 2nd Sandisk is the same as the 1st???????

Report •

Related Solutions

May 29, 2010 at 14:33:43
Have you tried it in another computer?

Report •

May 29, 2010 at 16:06:20
Look for the flash drive in Disk Management in WinXP. The drive may not be partitioned & formatted yet.

Report •

July 30, 2010 at 11:52:38
I got a problem too :/

ive bought a 4gb USB stick about 3 years ago and now i try and plug it in again, the light shows up but U3 doesnt come up and its not in my computers and it says ive filled the USB stick up when ive only got 2 files in it :/

any help? ^o)

thankyouu xx

Report •

July 30, 2010 at 12:22:32

See Response 2, especially the info at the link I specified.

Rarely, not all the ports on the back of a desktop case may be able to supply 500ma each.

If you have a desktop computer, Note that I answered a Topic on this site recently where a guy had an external drive, which does require the full 500ma, connected to a port on the back of a desktop case - it would not work properly when a webcam was in the port next to it, but it worked fine when the webcam was unplugged. Ports on the back of a desktop case often have two ports connected to the same USB controller module that are ports one above the other - you could try connecting the cable to one of those and leaving the other un-used.

Report •

Ask Question