safely remove 1 & 2TB External USB HDD from dock not working

Dell / Studio xps 7100
October 6, 2013 at 10:19:56
Specs: Windows 7, 2.8/3.0
Recently, safely removing my external hard drives does not work. I can't even view Devices and Printers. I tried My Computer and eject. It works for only my 8G flash drives. For my drives of 1T or 2T capacity ( on docks), it failed. Please help.

See More: safely remove 1 & 2TB External USB HDD from dock not working

Report •


#1
October 6, 2013 at 12:48:14
How is the external connected to the computer?

Post your computer specs or model number.


Report •

#2
October 6, 2013 at 13:59:41
My computer is Dell Studio XPS and the drives are connected through a UPS dock. Thanks.

Report •

#3
October 6, 2013 at 14:07:03
Sorry, It is a USB dock.

Report •

Related Solutions

#4
October 6, 2013 at 15:14:12
So the drives connect to the dock, or directly to the laptop?

If this is a recent change, try restoring back to an earlier time/ date, when it was working. You may need to re-install some Windows updates after that.


Report •

#5
October 6, 2013 at 15:47:47
It is connected directly to my desktop through a hard drivve dock. I tried restoring to an earlier date. Still not working. Thanks.

Report •

#6
October 6, 2013 at 18:22:28
So you have a desktop computer? The series you posted has both types.

Recap, you state you have a dock. Is the link below representative of what you mean?

http://www.newegg.com/Product/Produ...

If so, look in Windows device Manager to see if the docking station shows there. Also look for the hard drive in Windows Disk Management. If it shows there, post all the information listed for it there.


Report •

#7
October 6, 2013 at 19:55:40
If you cannot safely remove the drive, it means some program's holding onto it. I'd suspect your anti-virus.

How To Ask Questions The Smart Way


Report •

#8
October 6, 2013 at 21:14:34
Hi, Othehill
My dock is BlacX. In Disc Management, it shows Healthy ( primary Partition).

Razor2.3,

I don't think it is the anti-virus. When I click the Safely Remove icon, there is no response at all.

Thanks.


Report •

#9
October 7, 2013 at 06:03:05
As Razor mentioned, if there is current activity on the hard drive it can't be disconnected until that activity is completed.

Did these drives previously work as expected when using the safely remove icon?


Report •

#10
October 7, 2013 at 06:07:06
What gives you "no response?"

How To Ask Questions The Smart Way


Report •

#11
October 7, 2013 at 07:51:53
Yes, about a month ago when I click the Safely Remove icon, it always says something like "Safe to remove" or "some program is using this drive, close the program". Now when I click the icon, nothing happened.

Report •

#12
October 7, 2013 at 07:53:05
By the way, I can not open the Devices and Printers either.

Report •

#13
October 7, 2013 at 15:09:54
Have you run a complete AV scan?

refer back to #4 above for another option.


Report •

#14
October 8, 2013 at 16:19:54
Not yet. I will try and find time to do so. Thanks.

Report •

#15
October 15, 2013 at 14:29:40
I ran a AV scan. no virus found. thanks.

Report •

Ask Question