Rom Write Protected

Ecs (elitegroup computers... /
July 16, 2010 at 00:05:34
Specs: Windows 7 86x, phenom x4 9850 / 3gb ram
Ok i have an ECS geforce 6100pm m2 v2 and
iv being trying to update by bios because i
recently installed a quad core processor and
the bios needs to be updated to enable its full
use along side this reason is the reason that
my bios is completely to say.. a pile of
sh@t ^.^.

It says my rom is write protected iv read
everything in the manual about jumpers
nothing mentioned in there, and i have also
gone through the bios in and out of every menu
on there with no look.

does anyone have any ideas?

See More: Rom Write Protected

Report •

July 16, 2010 at 01:40:52
sorry about the typo in the title cant seem to change it :s

and a quick side note my current bios version is 12/13/2007

Report •

July 16, 2010 at 07:12:58
How are you trying to update this BIOS?

Where are you getting both the application to do the update and the code to do it from?

Are you sure that the update is actually designed for your BIOS and you are being prevented from doing something that will kill the motherboard as can so easily happen.

If the BIOS is, as you insist, load of s**t, a BIOS update isn't going to change that. It ill still be the same BIOS as before with few of minor alterations.


Report •

July 16, 2010 at 13:23:01
this bios is rubbish because of the bugs and errors

the utility and bios is from the ECS manufacturers website

and as for the version I think so ? I cant be 100%

if you could help would be great im not too experienced in the

this is the site im getting updates/utilities from:
under motherboards AM2 geforce 6100pm m2 v2

thanks for your time.

Report •

Related Solutions

July 16, 2010 at 22:57:22
Check the manual. Some motherboards have a write-protect jumper for the bios.

Now that's what I call a sticky situation

Report •

July 17, 2010 at 03:10:26
i did say in my original post, there's no jumper and there is no
bios setting and im stuck.

Report •

July 17, 2010 at 07:48:28
Oh yeah, I keep forgetting, I need to read the posts before responding.

Now that's what I call a sticky situation

Report •

July 17, 2010 at 10:18:16
There may just be a setting in the BIOS screens that needs to be changed to allow you to flash the BIOS.

If you are not 100% sure you have the correct file DO NOT flash it unless you want to kill the board.

As far as the BIOS being lousy why don't you give some examples of why you think that way.

ECS boards are not considered to be top end but there are worse brands out there.

If your issue is simply a matter of not having options available then that is the difference between a budget board and an enthusiast board. Also, you may not know how to unlock settings. Manuals are usually pretty sparse in that regard.

Report •

July 17, 2010 at 12:07:26
I have gone through every menu screen in the bios and the
reason i want to update the bios is because the current
version has an issue or two with my new quad core

any ways i don't think i have the right version bios, on the
other hand i have no idea where to find it if the one from the
manufacturers website is incorrect.

can anyone point me in the right direction? Or ensure that i am looking in the right place?

board: geforce 6100pm-m2 (v2.0)
manufacturer: ECS
current version date: 12/13/2007

Report •

July 17, 2010 at 13:16:59
The link below is for the latest downloads for that exact model and version. Page 35 of your manual seems to indicate that your board should either have a jumper for BIOS flash prevention OR the following.

2. If your motherboard has an item called Firmware Write Protect in Advanced BIOS features, disable it. (Firmware Write Protect prevents BIOS from being overwritten.

Report •

July 18, 2010 at 10:28:22
No such setting is in the bios, and there is no such jumper i have gone over the motherboard with a fine tooth comb. In addition i have tried all three BIOS versions available for download at the ECS website. I guess i am just stuck with an unflashable motherboard for now :(.

Report •

July 18, 2010 at 10:57:59
If there is something that is keeping you from flashing it won't matter which file you use.

How are you trying to flash. Give a detailed description of your procedure and what happens when.

If there are no lockouts then you may be doing something wrong.

Flashing from a floppy usually requires you to prepare a floppy disk with two files. Then you boot to the floppy disk by setting the boot order for the floppy first. Then you need to type the path to the correct file to start the flash process.

Report •

July 18, 2010 at 11:52:15
I have used a USB pen drive to try through DOS with an automated AUTOEXEC.bat file to do the procedure for me with both the utility and the BIN file on the drive, it finds both and begins to flash then throws up this error:

Flash rom write protected

I have also used the in windows utility for the award BIOS i have followed a tutorial and when i press update after selecting the BIN file, it tells me:

Erase failure maybe hardware protected

As i have said already there is no jumper and no setting anywhere within the bios for write protection. So i am absolutely stuck to what the problem actually is :(.

Report •

July 18, 2010 at 12:03:18
Is it possible that the message is erroneous and the problem is booting to the USB flash drive is not supported at the ROM level?

I do see the word maybe in that message. Sounds like whatever is going on may not have an appropriate message to display for it.

Your best bet would be to install a floppy drive and flash from it. This is one case where I believe an internal floppy drive is necessary. I still include a floppy on all my builds.

Report •

July 18, 2010 at 12:18:49
I can try installing a Floppy drive but bother the windows utility and booting from an external source give practically the same error. My guess is that if i use a floppy drive i will get:

Flash ROM write protected

any other thoughts on this ?

Report •

July 18, 2010 at 12:23:57
I gave my thoughts in #13. When you are entering the area of the BIOS that you are, your script may not be working as expected. The manual expressly speaks to using a floppy disk. This board is a modern unit. The writers know that boot to USB is supported but they don't suggest you can use it for flashing the BIOS.

Some excerpts from your manual that you may have missed.

Some options lead to pop-up dialog boxes that prompt you to verify that you wish to
execute that option. Other options lead to dialog boxes that prompt you for information.
Some options (marked with a triangle 􀁦) lead to submenus that enable you to change
the values for the option. Use the cursor arrow keys to scroll through the items in the
In this manual, default values are enclosed in parenthesis. Submenu items are denoted
by a triangle 􀁦.

Security Option [Setup]

Report •

July 18, 2010 at 12:35:28
The second option in Security option is system. I don't see how that's relevant and however i shall change the setting and try again at this point in time you feel i have tried everything i can an im beyond desperate any suggestions are welcome and thank you othehill for your help.

Report •

July 18, 2010 at 13:06:40
I don't see what you can when you are in the BIOS screens. I just put it out there for you to review again.

You seem to be convinced you should be able to boot from the USB drive. Perhaps you are right but you have the drive prepared wrong or have the wrong files.

Did you download

You need to extract that zip file and then follow the instructions on how to prepare the floppy (flash).

If flashing from the boot you need two files on the media. AWARD flash and the Bin file.

There is also a Windows flash option included.

Your problem might be that the flash file wants to backup the existing BIOS file and it can't write to the USB flash drive. The workaround would be to use a floppy or flash from within Windows.

Report •

Ask Question