right click slow xp sp2

Intel / Awrdacpi
August 25, 2009 at 11:43:50
Specs: Microsoft Windows XP Professional, 1.799 GHz / 503 MB
hii friends... i have got big problem... from past 1 month... right click is very slow.... i have to put pressure on the right button to get clicked.... its a new one... working fine in other computer's.... whats the issue ??
i tried shell-ex view by disabling contex menu handlers but it didnt work,,,, its as usual...

please help.... i even formated my pc... but same problems came back again

help plzz

See More: right click slow xp sp2

Report •

August 25, 2009 at 19:20:49
"...i have to put pressure on the right button to get clicked.... its a new one... working fine in other computer's.... "

That doesn't make sense. If it works fine on other computers, your putting pressure on it has got nothing to do with your problem.

Is it PS/2 or USB connected?

If it's USB connected, USB devices may not work correctly when they're connected to certain USB ports, e.g. ports in a hub or on the front of a desktop case.
See response 3 in this:

Are you using drivers for it that Windows installed automatically, or did you load specific drivers?

Does it do this every time, all the time, or just sometimes, such as when you first start up the computer for a while?

If it only does it sometimes, is your hard drive activity led on when it does that?

Have you tried popping up Task Manager when it does this to see if something is using a lot of cpu activity?
(hold down Alt and Ctrl, press Del, let go of the keys. Click on the Processes tab if that page isn't shown automatically. Look at the percentage numbers for the CPU usage except for System Idle or similar.)

Report •

August 26, 2009 at 10:07:53
mine is sony usb mouse...

but is that an issue ??

bcoz sometimes it works smooth and suddenly it becomes rough....

plz plz plz help me........

Report •

August 26, 2009 at 10:43:56
You have only answered one of my questions.
Answer the rest of them.

And answer these:

- did you look at my USB port info?

- did you try plugging the mouse in a different port if that info indicates it may not work properly in the port you had it plugged into?

"Manufacturer/Model: Intel / Awrdacpi"

"Awrdacpi" - what the heck is that?

A mboard that has an Intel main chipset isn't necessary made by Intel - most mboards that have them were NOT made by Intel.

- what's the make and model of your brand name computer, or if you have a generic system, the make and model of your desktop mboard?

For either, sometimes the make and model is shown on a graphical scree while you're booting. If that goes by too fast, usually you can press the Pause key on your keyboard to stop booting at that point, read and copy down that info, then press any key but pause to continue booting.

For a brand name computer system, the more specific model, and often the model part number, is often on a label on the outside of the computer case somewhere, or you can go to the web site of the brand and determine that from a code on a label on the case, or sometimes the model can be auto detected when you access the site with the computer you want to determine the model of.

For a generic desktop system, the model of the mboard and sometimes the make is usually printed in larger characters on the surface of the mboard - often between the slots or in the middle of the mboard.
e.g. Remove the left side of a tower case as seen when you're looking at the front of the computer, examine the mboard.

- Whenever you load Windows from a regular Windows CD (or DVD) from scratch, after Setup is finished you must load the drivers for the mboard, particularly the main chipset drivers, in order for Windows to have the proper drivers for and information about your mboard hardware, including it's AGP or PCI-E, ACPI, USB 2.0 if it has it, and hard drive controller support. If you have a generic system and have the CD that came with the mboard, all the necessary drivers are on it. If you load drivers from the web, brand name system builders and mboard makers often DO NOT have the main chipset drivers listed in the downloads for your model - in that case you must go to the maker of the main chipset's web site, get the drivers, and load them.

Did you do that?
If you didn't, DO THAT!

Report •

Related Solutions

August 26, 2009 at 12:31:21

Report •

August 26, 2009 at 12:54:49

i didnt had motherboard cd...so i installed the display driver and sound driver manually from the site........

and whenever i look @ the process usage by clicking on ctrl+alt+Del... it says 5% to 10%...

i am just gone crazy... i formatted now again... but bloody same problem...

is the usb mouse giving me problems ???

can any of u operate my pc and check the problems as i dont know much abt these and i have just injured my hand by pressing hardly the right button :(

its random.. suddenly it works properly and suddenly it stops :(

thanks for the reply guys... plz help

Report •

August 26, 2009 at 13:04:48
What processes are using the cycles? List them here.

Report •

August 26, 2009 at 13:28:14
svchost.exe { 1-local service , 2-network service ,2-system }
system idle process

cpu usage currently - 4%
pf usage - 190mb

Report •

August 26, 2009 at 14:08:25
Which of those has a percentage next to it? If the current CPU usage is 4% that is well within the normal range.

Look in Device Manager to see if all hardware is working correctly.

You may just have the computer all crapped us with who knows what.

Download and run Ccleaner slim and Malwarebytes. Run both the cleaner and registry modlues on Ccleaner. Get them at the links below.



Report •

August 26, 2009 at 14:25:45
"i didnt had motherboard cd...so i installed the display driver and sound driver manually from the site........"

You have to load the main chipset drivers too. Some main chipsets will NOT run the drives as fast as the chipset is capable of until AFTER you load the main chipset drivers - Windows will be pokey without them - your mouse right click will be pokey without them.

Tell us your brand and model, and we can tell you which chipset driversyou need to load.

Report •

August 27, 2009 at 01:00:22
well i installed motherboard cd... still same bulls--- :(

some one posted on this site by using reg scanner and says it helps


check this site but when i scanned i didnt had that value key '' starting from HKCR ''




Report •

August 27, 2009 at 08:53:44
The more questions you answer, the more likely we'll be able to help you solve your problem.

"...i have got big problem... from past 1 month..."

After what did this first start to happen?
What event happened about a month ago?
A power failure?
Your power supply failed and you replaced it?
You vacuumed the inside of your desktop case?

Why haven't you stated which make and model you have?

We have no idea how old your mboard is and what main chipset it has from the info you have provided.

It sounds like you have a desktop computer, but many people hate the touchpad on laptops and plug in a mouse instead, and some laptops come with a drivers CD they might call a mboard CD.

If you have an Intel main chipset, some 8xx chipsets can't run the hard and optical drives at their full speed until you have loaded the IAA - Intel Application Accelerator.
That's often not included on the mboard CD or drivers CD.

(If the IAA has already been loaded, Intel Application Accelerator is listed in the first Programs list you see in XP.)

Go here:
Desktop Chipsets ( or Laptop Chipsets, whichever applies)
Choose the chipset series
If the IAA is listed for your chipset, download it and load it.

The IAA must be loaded after the main chipset drivers have been loaded. Intel calls the main chipset drivers download the INF Update Utility. If you're not absolutely sure the main chipset drivers have been loaded, they are at the same place, whether or not the IAA is listed - it does no harm to download the INF Update Utility and load that even if the main chipset drivers have already been installed.
If your mboard has onboard video, the latest available Intel video drivers are also there. In some cases for older 8xx main chipsets, if you load those video drivers rather than ones that were on the mboard CD, you will see an icon in your taskbar that looks like a monitor, and with that you will be able to choose higher resolutions than you could with the older video drivers, and higher than you can in Display Properties - Settings.

According to your info, you have re-loaded Windows twice.
In that case, if the RIGHT click doesn't work properly when you have merely just finished Setup, or you have just finished Setup and have loaded at least the main chipset drivers, your problem cannot be caused by any Windows software setting being wrong because default settings should always work fine.

Does it do this every time, all the time, or just sometimes, such as when you first start up the computer and for a while after that?

If it only does it sometimes, is your hard drive activity led on when it does that?

If the RIGHT click eventually works normally, after you have waited for the hard drive led to go out, there is nothing wrong with your mouse of the USB port you have it plugged into, or the USB circuits on the mboard. Your problem in that case is you're impatient and RIGHT click wasn't working normally because something was using too much of the CPU time.

If RIGHT click never works normally, even when when you wait until the hard drive activity led is not lit up, either you're plugging it into a USB port it can't work properly when plugged into, or you have another hardware problem.

Did you look at my USB port info? (See response 1)

Did you try plugging the mouse in a different port if that info indicates it may not work properly in the port you had it plugged into?

If this is a desktop computer.......
A failing power supply that is not putting out enough of what is supposed to be +5v will cause problems with USB devices.
Go into your mboard's bios Setup. Most bioses can show you the current voltage readings somewhere in Setup - e.g. Hardware Monitor. The +5v reading must be within 10% of 5.0 volts - and the +12v and +3.3v reading must also be within 10% of the nomunal value - if any of them aren't within 10%, you MUST replace the power supply

It's unlikely, but possible, your USB circuits are damaged - a PS/2 mouse may work fine.

Do you have or can you borrow a PS/2 mouse to try?

Some mice are "combo" mice - they can be used with either a USB port, or if you use a simple USB to PS/2 adapter that came with it when it was new, they can also be used with a PS/2 port. If it ain't a combo mouse, a simple USB to PS/2 adapter won't work with it. The labelling on the mouse may make it obvious it's a "combo" mouse - otherwise you can look up it's specsby searching with it's model number.

If it is a"combo" mouse, a simple USB to PS/2 adapter for a keyboard, often colored purple, will often NOT work with a"combo" mouse, and a simple USB to PS/2 adapter for a mouse, often colored green, will often NOT work with a"combo" keyboard, because the necessary wiring isn't there in the simple adapter.

If it's a desktop computer, some mboards develop this problem over time...

Open up your case and examine the mboard to see if you have bad capacitors, and/or other findable signs of mboard damage .

This was the original bad capacitor problem - has some example pictures.
History of why the exploding capacitors and which mboard makers were affected:

What to look for, mboard symptoms, example pictures:
Home page that site
- what the problem is caused by
- he says there are STILL bad capacitors on more recent mboards.

Pictures of blown capacitors, other components - power supplies, Athlon cpu's, etc.:

Report •

August 28, 2009 at 07:46:15
Thanks my Dear Friends....

Love u all....

My query solved... changed the mouse... its working fine... but when usb mouse comes... the same nusiance happens :

Report •

August 28, 2009 at 08:15:00
We're glad to hear you have solved the problem!

If you had the USB mouse plugged into a USB port it should work fine in, then I've seen a few cases where, for a desktop computer, a problem with a USB device working properly was caused by an IRQ sharing problem.
See the info about that in the latter part of Response 3 in this:

I have one older model of Logitech USB optical mouse that conflicts with certain other USB devices when both are connected - I've never figured out what causes that. When both conflicting USB devices are connected, either the mouse or the other device works properly, not both of them. It's a"combo" mouse and always works fine when I use it's USB to PS/2 simple adapter to connect it to a PS/2 port.

If your mboard has an Intel 8xx main chipset, read and check out the info I supplied about that in response 11.

I would STILL like to know what the make and model of your mboard is.

Report •

September 1, 2009 at 09:55:51
With all due respect to the immense amount of input that was given here, why did nobody address the fact that mouse buttons can and do fail?

Through use, the actual buttons inside that the outer shell parts push on wear out and require more and more force to actuate until eventually not working at all. Citations: two Microsoft USB mice I was given, one IBM 2-button PS/2 mouse, ebay Hong-Kong-special USB optical mouse, a different IBM 2-button PS/2 mouse (logitech internals), recent no-name PS/2 "browser mouse". If I have run across this many mice with faulty buttons, logic dictates there are a heck of a lot of mice with faulty buttons out there...

If the problem was fixed by using a different mouse, then the problem is the mouse, and that mouse should be returned/exchanged if it still has warranty coverage.


Report •

September 1, 2009 at 11:36:19

I have NEVER come across a malfunctioning mouse that produced the symptoms namanthecool had.
It sounds like the right button's switch was working fine - he said the mouse works fine on all other computers - the problem was the behavior of what happened when he clicked on it was not normal.

Sometimes mouse buttons may stick or break, but I have NEVER come across a mouse that the switch for the button had failed on, or even one that broke. Did you test the switch itself with an ohm meter?
If you truly have, use or buy better mice!

If a mouse is actually malfunctioning, when the mouse is corded, the problem is almost always the cord has been damaged.
If the mouse (or keyboard) is corded, it's quite common for one or more wires to get broken inside the cord, usually right where the cord enters the mouse (or keyboard) , or rarely on the other end near it's connector. It usually happens after the mouse (or keyboard) has been used a lot, but it can happen after anytime the cord has been yanked on.
If a wire is broken but it's insulation is still intact, if the wire ends are touching, the connection is intermittant rather than reliable and the mouse may behave as if it's being controlled by something out of your control - e.g. the cursor wanders all over the screen. When you wiggle or re-position the cord near where it enters the mouse (or keyboard), it MAY work properly when in a certain position, not work or not work properly when it's in another position.

The mouse MAY work fine when the cord problem has been fixed, or the circuits in the mouse may have been damaged and that won't get it working properly.
As I have told you I have some ancient Microsoft combo Serial/PS/2 mice I'm still using. I have at times transferrered a good cord from one to another, and when I did that the formerly malfunctioning mouse worked fine.

If liquid has been spilled on a mouse (or keyboard) when it's powered, or it's powered after that without cleaning it up properly, that MAY damage it's circuits

"If the problem was fixed by using a different mouse, then the problem is the mouse..."

Possibly but not necessarily.
If it didn't work properly on ANY computer, of course, it's malfunctioning.
He says the mouse works fine on all other computers.
He has no reason to return it on warranty and get it replaced even if he could because it's not "broken" - it does work on all other computers. If it's a "combo" mouse it probably will work fine on this computer, if he uses the USB to PS/2 adapter it came with, or another compatible one.
Either of the possible causes in response 13 could apply.
The USB circuits on his mboard could be damaged, but that's extremely rare.

Report •

September 2, 2009 at 09:04:58

"Never" is something I find hard to believe; I'll take it then that you've never noticed such a problem. These things, in my (admittedly somewhat limited) experience are intermittent, but match what the OP said quite a bit.

Agreed on the possibility of a cord issue, but in my case these are buttons which develop a distinctly different feel as the buttons internally wear out (they still make contact, but the point where contact is made changes, lower down into the switch to a point that the exterior "button" cannot press it easily). I may still have one of those Microsoft mice somewhere; I'd give it to you to see if you didn't live on the opposite end of the country. I know I ripped the other one apart to harvest parts.

Perhaps I missed something (I found it kind of difficult to follow the OP because of grammar/form issues) but it seemed the OP used a different USB mouse with positive results, despite the "possibly bad" mouse working properly on other computers. This, to me, still says the mouse is the culprit, but there are other weird factors that play in like maybe the motherboard providing too little current...though that's extremely unlikely and all mouse functions should be malfunctioning if that were the case.

I wasn't meaning to suggest the ONLY possibility is a faulty mouse, only that it seemed likely to me it was (and in most cases the easiest thing to do would be exchange it if possible and see if another of the same model behaves the same; if so, suspect software or drivers; if not software or drivers then suspect motherboard)

Report •

September 2, 2009 at 11:18:50
I didn't state it was impossible, but I am trying to point out it's extremely unlikely, and for a corded mouse, the actual problem is almost always the cord in my personal experience.
Of course, most people don't open up the cord's sheath to take a look, and most people who do and do find that problem don't bother to repair the cord (a tedious thing to do with those tiny wires), or don't have another compatible cord to try swapping.
Way back when quality mice were relatively expensive you could order replacement cords from some manufacturers but as far as I know they aren't available these days. There is an exception to that I know of for some cord connected touchpad mice, however - you can order replacement cords from some places that sell Cirque products.
e.g. If you send these guys an email about which Cirque product(s) you need the cord for, you can buy the cords from them:
The cords are inexpensive - however, the minimum shipping charge is about $15.

"I have NEVER come across a malfunctioning mouse that produced the symptoms namanthecool had. "

As in, myself personally with any mouse I've had or used that was someone else's, or in anything I have come across on the web.

"Sometimes mouse buttons may stick or break, but I have NEVER come across a mouse that the switch for the button had failed on, or even one that broke."

As in, all the mice I've taken apart have tiny tough micro switches of one sort or another under where the buttons are on the board inside the mouse, not the resistive contact blob type you may find in cheap keyboards or remote controls that are prone to physical wear which can render them unreliable.

" ....if not software or drivers then suspect motherboard).

Mice are supposed to work fine with the drivers built into Windows, so almost always those drivers not the problem, unless something about them has been corrupted, and in that case it's easy to re-load them. Some mice come with software that enable additional features, but the mouse should work fine without installing that.
As far as USB mice are concerned, if all other USB devices work fine, assuming all devices are plugged into USB ports the device can actually work properly in when connected to, and for a desktop system, there is no IRQ sharing problem regarding the USB controller related devices, then there's probably nothing wrong with the USB circuits on the mboard, and the power supply is probably producing the proper accurate +5v, plus or minus up to 10%.
If a USB mouse doesn't work fine on a sytem yet works fine on other computers, then the problem is probably the rather rare (probable resources conflict) problem like I encountered with that one Logitech model I mentioned.

Report •

Ask Question