Retrieve files from external hard drive lost while upgrading

April 26, 2016 at 06:47:09
Specs: Windows 7
Hi there, When l was upgrading my laptop, l used an external hard drive which l had my picture & video files. Somehow l cant find my file due to the recovery format on my EHD. l was searching some solutions to get them back on the net and this company l cant remember the name now they scanned my EHD and found some of my lost files and said they can find more but l have to pay them. l have a feeling that they might of blocked or barred my files if so is there a way to retrieve my EHD files?? If yes HOW?? please HELP!!Thank you.

message edited by Painteman

See More: Retrieve files from external hard drive lost while upgrading

Report •

April 26, 2016 at 07:11:02
Connect the external hard drive and go to Windows Disk Management. Does the external drive show a listing there? If so, List the following:

Volume-Layout-Type-File System-Status

Report •

April 26, 2016 at 08:01:26
You could try recovering them yourself with this free recovery program.

Report •

April 26, 2016 at 21:15:29
l tried recuva, it only found about 30 picture files which it should of found around min. 1500 pic files.

Report •

Related Solutions

April 26, 2016 at 22:27:01
Disc management shows 32.00 MG FAT32 Healty (Active, Primary Partition) and the next box shows 899.51 GB Unallocated. Does this mean all the files (Pix & videos) are still in the EHD?? l tried open the files it says with some numbers ''pg We cant open this file.. But there are a few pictures files that l can open them. lm not sure what to do next..

Report •

April 27, 2016 at 01:13:04
How did you upgrade your laptop?
What is the external HDD part in the upgrade procedure?

Report •

April 27, 2016 at 03:38:29
l just accepted the windows upgrade 10 by laptop (microsoft uprade) and l did connect the EHD to back up my files. When finished upgrading l couldnt find any files (pi & videos) on the EHD says Recovery files.. l hope this helps you to help me.

Report •

April 27, 2016 at 04:16:52
Bad choice to let it use your EHD. Didn't you get a warning that is will use/delete files on the EHD? I'm afraid all is lost except for what recuva found.

Report •

April 27, 2016 at 07:52:37
Unallocated means the partition has been deleted. You may be able to repair that with one of the utilities linked below.

The second link below is totally free but a little harder to use.

Report •

April 27, 2016 at 23:20:32
Other recovery software you might want to try:

Report •

April 28, 2016 at 03:43:49
No l didnt get a warning at all. Im still new to this internet stuff and still learning. The worse thing is The EHD belongs to my wife and not happy that lost all those our kids baby pix & videos.Anyway lm really appreciated for your help Thank you very much..

Report •

April 28, 2016 at 18:33:47
l used testdisk7 data recover software. recovered almost evey file but when viewing the files, it says ""WINDOW PHOTO VIEWER CAN'T DISPLAY THIS PICTURE BECAUSE THE FILE IS EMPTY''
And also WinRar; diagnostic message there are a few files says 1st birthday zip; The archive is corrupt. What should l do?

message edited by Painteman

Report •

April 28, 2016 at 19:04:19
You recovered all the filenames and perhaps some pieces of the files that are still intact.

A file is not stored on disk as one piece. Is if broken up in equal parts and most likely scattered all over the disk. Your upgrade has overwritten many of the pieces making up the original files.

Report •

April 28, 2016 at 22:20:06
Did you read the help files for Testdisk? Testdisk may be able to repair the partition as well as recover files. Did you try to do that?

Report •

April 30, 2016 at 04:31:32
Yes have retrieved some of the files :) there is a window and lots of zip files in there which WinRar diagnostic message says TestDisk cant open Zip files . l dont know how to change them into WinRar files ;( on the window where these Zip files are says

Close Break operation copy to clipboard

what should l do? can l change these zip files into WinRar files??

Report •

April 30, 2016 at 17:39:02
Just download a different unzipper. I use 7 zip. Get it at the link below.

Report •

May 1, 2016 at 07:17:05
Thank you very much for your help OtheHill, l will try this and see if it works :)

Report •

May 1, 2016 at 23:16:20
Hi there again, l retrieved most of my files but most of the files which say rebuilt, l assume that they were the ones that's been repaired, somehow media player cant show it it says ''Windows media viewer cant open this picture because either Photo viewer doesnt support this format or you dont have the latest updates for photo viewer''. l checked the files format its JPG format so is the window media photo viewer but somehow it doesnt show the files.Now lm stuck here again what should l do??

Report •

May 2, 2016 at 05:45:17
May just be a file association issue. Follow the instructions in the first reply in the link below to see what program is actually trying to open the files.

You can also right click on one of the jpg files and see which program is set as the default.

Perhaps a different program for jpg files. See the link below. Note #5 reply in that link infranview is widely recognized but is only one of many options.

Report •

May 2, 2016 at 21:53:52
l downloaded Irfanview & tried to view files but it says ''Cant read the file header
unknown file format,empty/damaged file or file not found''

Tried finding some solutions there on FAQ with no success....Would that be no files even thou it says ''rebuilt''??

And l really thank everybody here helping me with my ''Recovering lost file'' issue


Report •

May 3, 2016 at 05:51:15
Right click any of those files and choose Properties. What size are the files? What is reported in the Attributes area?

Report •

May 3, 2016 at 17:54:23
l checked a few images it all say size 20 bytes (20 bytes) size on disk 4.00 KB (4.096 bytes) Attributes A

l tried irfanview once says about the image before viewing,, rebuilt.2013-05-29_16-33-40_494 type JPG file size 1 KB but when try viewing it says cant read the file header,unknown file format empty/ damaged file orfile not found..

message edited by Painteman

Report •

May 3, 2016 at 21:54:18
20 bytes is the size of the file name only. There is no data there. 4.00KB is the cluster size for FAT32.

If you can, go back to testdisk and try repairing the partition instead of recovering files. Seems as though all you retrieved were the file names, not the contents.

Report •

May 4, 2016 at 02:09:18
Yes you are right about it. l did my best to figure out how to repair files on testdisk but
l just couldnt do it ;( it just didnt give me the option of repairing, always recovering option.

l really got annoyed, what can l do to get option of repairing files on testdisk??

ps: My knowledge is limited about computing and as well as my English with technical words.l really am sorry for the hassle and appreciated you are still with me.

Report •

May 4, 2016 at 10:04:30
Lets recap exactly what you have going on right now. If I understand correctly you upgraded the internal hard drive in your laptop to Windows 10.

How did that affect the external hard drive?

Were the lost files on BOTH the internal and external drives originally?

Did you create a backup of your Windows 10 installation?

Do you know if the external drive was one single partition before any of this happened?

When using recuva does recuva allow you to scan the external drive at all?

Report •

May 4, 2016 at 22:58:42
This eternal hard drive belongs to my wife, l wanted to upgrade my laptop windows 8 to windows 10. So as for a back up l used her EHD.

l wish l didnt..When the windows process finished l wanted to get all my files, but there was nothing there on the EHD but the Recovery files. Remind you that was my first time upgrading windows,

l didnt know that l should of unplugged the EHD after transferring my files to it
and now l know ..

l didnt know that EHD was a single partition at all.

l tried Recuva and l recover some of my files but not all of them like testdisk did.
But after testdisk recovery l used recuva again and it did recover all the files this time, still saying rebuilt but no luck with opening the files once again

l downloaded easeUs data recovery soft ware, it did scan and found all of the files but most of them were saying rebuilt images and didnt open any files saying rebuilt, but some of files were still ok to open.

l actually today thought of scanning my wife's laptop's internal hard drive because
originally all the files were there before she transferred all the kids baby images & vids
but ever since that happened, l upgraded her laptop's windows twice but l will try it
anyway l got nothing to lose after all..

ps; when try viewing it says cant read the file header,unknown file format empty/ damaged file or file not found..

thank you!

Report •

May 5, 2016 at 11:19:29
When using either Testdisk or Recuva do you KNOW if the utility is looking at BOTH partitions on the external hard drive? I don't think recuva can scan the unallocated portion of that drive. I may be wrong about that.

Did you try Easeus partition recovery as linked in #8 above?

Should have stated this before, but DO NOT write any more files to the external drive.

If there were originally more than ONE partition on the external drive you would have seen multiple drive letters when viewing the information in Windows Disk Management.

What happens when you connect the external drive to your wife's computer and try to view the files? Depending on how they were originally saved there they may not have been accessible to you even if you hadn't overwritten anything, assuming that is what happened.

If you have another external hard drive you could copy the partitions off the external in question and then try some options that could be destructive. That way you would have a backup of the files should things not work.


What I should have asked above is this. Did the external come with preloaded backup software on it. What is the brand and complete model of the external?

Last question for now. Do you know what files YOU wrote to that external prior to performing the upgrade to Windows 10?

message edited by OtheHill

Report •

May 6, 2016 at 20:16:33
When connect EHD to wife's laptop it says, local disk (G) 31.9 GB free of 31.9 GB.
But this is 1 TB SeaGate Backup Plus Portable drive Model number: SRD0SP0,
when open EHD it says This Folder is empty.

l wrote all the family pictures & vids,music files, movies and some soft wares.

l scanned my wife's laptop's hard drive and found around 122.000 files and saved them on the Drive G as CAB files . l have to view every single one of them to separate the files that we lost. ( l know lm in a BIG trouble :) )

A few CAB files l can open them but most of the files opening like BLOCK MAP (block hash) what should l do to open the BMAP files??

l downloaded easeUs data recovery soft ware. it did scan and found all of the files but most of them were saying rebuilt images and didnt open any files saying rebuilt, but some of files were still ok to open.

Report •

May 7, 2016 at 13:01:19
According the the Seagate link below that drive came with NTFS for Mac pre-formatted.

The 32GB partiton that is formatted and active is a FAT32 partition. So, did you repartition the drive at some point? I am trying to figure out how you ended up where you currently are with a 32 GB FAT 32 partition and the remainder UN-allocated.

I think you may have deleted all partitions (probably only one there) and then created the FAT32 partition, which Windows would only allow to be 32GB in size. That is by Windows design.

If you don't need the 32GB files you could delete that partition and then create one partition using all available space then try using testdisk to reconstruct the partition, which should have been formatted NTFS.

The problem with doing that is there is no going back to what you have.

If this were my problem, I would get another hard drive, either external or internal and clone the current external drive. Then use that drive to experiment.

Another suggestion is to try posting on the Seagate help site. You could link to this thread or start explaining all over.

Sorry I am not solving your problem. In the future you should ALWAYS maintain at LEAST two verified copies of any files that are irreplaceable.

I am not giving up trying to help. BTW, I did remove the best answer indication so others might join in here. I am a Moderator on this site.

The software that Seagate pre-installed is not something I know anything about. Backup programs usually use compression of some sort to conserve storage space. That is usually done so there is no duplication of data but I don't know what Seagate does. That could be the reason you can't seem to recover files with content.

Report •

May 12, 2016 at 02:20:24
l am scanning my wife's laptop"s Driver C with Testdisk PhotoRec 7 zip.
Originally all the files were there.

Looks like its digging out all the files ( with lots of S**) lol :) ) and very slow process too.

lm not sure how long it will take and what files l will find.
l will let you know how it went hopefully next couple days and fingers cross for the good news :) ..

Thank you again..

Report •

Ask Question