Resources for PS/2 56SX?

Dell / Inspiron 630m
January 29, 2009 at 18:22:01
Specs: Windows XP Pro SP3, P-M 1.73, 2GB 667

I had posted on a classifieds website looking for 'vintage IBM compatible' stuff for cheap/free, preferably an AT or XT full system, and found something rather interesting...

a Personal System/2 56SX (8556-045)!

Currently has Win95 on it, which runs miserably slow as it has 4mb RAM. I have a few questions:

1. RAM. All I know definitively is it takes 72 pin SIMM. Any more specific details I should know?

2. BIOS. Where is it? From what I gather it's on the hard drive, but I don't know how to invoke it. How do I access it?

3. Boot disks of any kind: can anyone link me to disk images please? As far as I can tell it had a "startup" and "reference" disk, the exact uses of which I do not know.

I would hope it's obvious that I don't plan to actually USE this machine for anything, I just want a functioning older system around because I find them cool.

If it happens that the BIOS is stored on the hard drive, I'd like to image this drive ASAP. Anyone have any ideas for a network-capable floppy-bootable imaging program?


See More: Resources for PS/2 56SX?

Report •

January 29, 2009 at 20:07:21
The BIOS is setup by the setup floppy. The reference disks are the driver floppies. These are needed for DOS setup. The system boots with a standard floppy disk system. If this is a microchannel machine you will has trouble finding cards that will fit. I believe you still can download disks from ibm. The hard disk may be ESDI. It's probably not a good system to play with. The most incompatible of the ibm's.

Report •

January 29, 2009 at 20:23:20
Oh I'm well aware of it's proprietary nature; in fact that's why I wanted it. Generally I enjoy a challenge :)

With VGA graphics onboard, PS/2 kb and mouse, and the ethernet card which is in it, I shouldn't need anything else to even get it online and "usable", though again I don't expect to be using it.

Currently looking for the description file for the Ethernet card

SMC Ethercard PLUS/A (MCA, TP/AUX)(WD8013EW/A)
as reported in Win95...win95 seems to have it fully installed. No IE though so I can't verify it'll connect.

I'm wondering what all would be involved in getting WfW 3.11 on here and online? Keyword online; I could easily get it installed it seems.

Report •

January 29, 2009 at 21:14:39

model 56

Used to be all online at IBM. Lenovo might have that info. It used to be posted. Might have to access it with ibm access.

Get on the forums at ibm maybe. There ought to be some ibm'ers that might have access to the correct doc's and software.

Are you sure the number is correct?

Wonder if that was an AIX unit?

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

Related Solutions

January 29, 2009 at 22:33:45
That's one of their microchannel (MCA) models. You'll need the reference disk to setup the hardware. Microchannel hardware needed ADF files for setup. The basic ones were on the reference disk. For added hardware you'd have to locate the correct file. You might check here:

It looks like that model can handle up to 16 meg RAM. With 4 slots that would be up to 4 meg per slot. Some of those older IBMs were fussy about the RAM they'd take. Regular 4 meg sticks may or may not work. You'd just have to try them and see. It would have to be non-EDO memory and may need to be parity.

There shouldn't be any bios/setup info on the hard drive.

Report •

January 30, 2009 at 02:03:57
In addition to the above the memory requirements may be very strict. If memory serves me correctly 72 pin simms came in various speeds. 70ns & 80ns come to mind. There may have been other speeds. You may need one of the other. I think if the machine was designed for 70ns the 80 may work but not the other way around. All need to be the same speed and of course simms need to be installed in matching pairs.

Report •

January 30, 2009 at 03:38:58
Jefro: very useful link, thanks :) I'll rummage through there looking for anything relevant to me a bit later on.

Indeed, the number is correct, if you mean the model number. From what I've been able to determine the 56 had a 486, but the 56SX had a 386SX. Win95 detects this machine as having a 486...but judging from the pin count on the CPU (with integrated heatsink stuck on top) it looks like a 386 to me.

I'll try the IBM forums...certainly worth a shot.

AIX? Quickly googled it and it looks like a unix-based OS. As far as I can tell that OS is designed for PPC which would make it incompatible, wouldn't it?

DAVE, I went fishing on the hard drive and it seems the folder on C: for the SMC drivers HAS ADF FILES IN IT! I'll throw them on a floppy, boot to the reference disk and insert this as prompted, and see where it goes. Definitely keeping that folder backed up; it might be impossible to ever get back if I lose it.

This machine has, oddly enough, 3 RAM slots, one of which is occupied. It currently has 4MB RAM. I think I read that some PS/2s have RAM integrated onboard...not sure if this one does or not. I guess the test would be taking out the current RAM and seeing what happens.

I do, somewhere, have some of those ugly IBM 4mb sticks which I believe are parity and non-EDO...the ones with the two giant chips on one side, perhaps you'll know what I mean.

Correct on the BIOS point also; I used FDISK to view partitions and there is only the one, taking up 100%. It seems though an image of the "Reference Diskette" is stored in ROM/NVRAM somewhere because if I adjust hardware config it will boot to it, with no disk in the drive.

OtheHill, I did read somewhere about the speed being rather specific; hopefully whatever I have will work in it.

I'll post back about my adventures in proprietary world, bahahaha.


As an aside, a couple years ago I volunteered for a place that was building up older P1-P2 systems out of a pile of assorted junk for donation to low income families. I had significantly lower tech knowledge (and appreciation for it as a hobby). One particularly memorable system had these "very long expansion slots" with cards with "big blue plastic ends"...which would be MCA bus. It was a model of PS/2, with a black case. I tore out the hard drive and floppy drive (floppy is proprietary, it turns out), and then junked the computer. Now, after a couple years of having them tucked away on a shelf, the hard drive is in one of my Macs and the floppy drive replaced the dead one in my new PS/2.

Report •

January 31, 2009 at 17:04:06
I found two matched 8mb sticks of 70ns parity 72pin SIMM RAM, with IBM stickers on them, which I believe also came out of the PS/2 I destroyed in the past.

When added with the original 4mb, it detects 16mb RAM and gives an error. When alone in the machine, it detects 16mb and disables one for addressing purposes. Doesn't look like it wants more than 16mb RAM :(

I got a hold of floppy images for Win95. They're DMF format so I have to write on my other computer; my floppy for the laptop won't write DMF. Win95 is installing currently (the old install was quite messy so I'd rather just clean it up).

As it happens, I didn't know the CPU was built into the motherboard until closer inspection. That would make the proprietary expansion card on the board what?...the 486SLC UPGRADE CARD! The coprocessor socket on that card is not occupied, I'm wondering if I can pop a 387 in it or if it has to be a 487?

Report •

January 31, 2009 at 17:51:33
You should have a 386SX unless something's been changed along the way. You would use a 387sx coprocessor with it; should be the only coprocessor in a PLCC package. Others, I believe are packaged in PGA.

Dave hit it. It'll handle 16Mb RAM max.

Looks like you've found some pretty good stuff to get that thing working...2 days ago, I thought you'd really stepped in it. IBM support is nonexistant and most of the old ps/2 sites no longer work.

Good luck,


Report •

January 31, 2009 at 19:44:16
The 486SLC may be an IBM licensed chip. It is similar to the 386SX in architecture. Does not have coprocessor.

Report •

January 31, 2009 at 23:21:38
SkipCox, there is apparently a 486 in my machine. It's on a card which goes into a socket on the motherboard. Windows 95 is reading the CPU as "80486" and when I googled the FRU off the card it came up as a 486SLC upgrade card.

I've definitely noticed the poor online support/enthusiast community for these machines, and I can definitely see why. I've discovered even the VGA monitor connector is has a blocked pin for IBM monitors only. In a sense I'd expect these unique machines to have a great enthusiast community given their...well, weirdness.

Opinion question: do I have a fairly rare PS/2? From what I can tell the 56SX isn't exactly a popular model to find.

wizard-fred, it appears the SLC is indeed IBM's version of the 486 indeed. The upgrade card DOES have an empty socket on it though; I'm curious to know what for.

Report •

February 1, 2009 at 06:23:30
Maybe the co-processor?

Report •

February 1, 2009 at 07:43:25
I was basing my question on what wizard-fred had said, sorry for not clarifying.

I really wanna say the socket looks like it'll fit a 387...and from what I can gather online, the copro for a 486SLC actually is a 387...the question is, should I pull the 387 off the board in the closet and test it or not?

Report •

February 1, 2009 at 08:50:33

Mine doesn't POST with this style screen, it's only a solid black screen with memory counter. Any idea how to get it to look like that? Doesn't seem to be in the reference disk settings.

Report •

February 1, 2009 at 10:33:05
Just for a historical FYI, the 486SLC was used in the "Make-it 486" chip which would upgrade a 286 computer to a 486 (actually more of a quasi-486). I actually have one of those in an old 286 (just sitting back somewhere). There was a little DOS program you ran on boot-up to start the 1kb internal cache on the 486SLC. I suppose your IBM computer has this in it's firmware, but there was a BIG difference in processor speed between that internal cache being enabled or disabled. This is a slow chip, I believe you will enjoy using this computer much better if you set it up with DOS and Win3.1 (WfW) instead of Win95.

Report •

February 1, 2009 at 15:36:03
pyrolytic, I'm surprised to hear it was used for 286 -> 486 conversions; I'd expect the architecture to flat out not support it. Interesting! RE: the enabling software, I'm actually not sure. It sure doesn't run like a 486, that's for sure.

I dumped Win95, it was just too slow. Went to...tada...OS/2 2.1. So far I seem to like it, it runs alright and has Windows emulation.
(my video of my machine, it's rather poor but oh well)

Report •

February 1, 2009 at 17:16:27
It's a little DOS program called CACHE486.EXE (but it is called different things by different manufactuers who sold these upgrade modules) and it just runs for a second and flips some switches in the processor which enables the internal cache and then exits, leaving a little note on the DOS screen. I don't know why it's like that but supposedly there was something about the 486SLC design which required this after power up. I suppose the BIOS on your computer must do this. Here is a link about these kind of upgrades based on the 486SLC:
Now, these are 386 to 486 upgrades (which really didn't make much sense because a good 40MHz 386DX would actually outperform the 486SLC) described on this page, but they use this same little program during startup.

What is meant by "486" in this processor is that it will correctly process the 486 opcodes. It's really a 16-bit processor, like a 486SX. On the old Dell 286 computer I have with this upgrade and the cache enabled the performance is comparable to a 25MHz 486SX.

Report •

February 1, 2009 at 22:32:54
IBM did make their own chips. The leads didn't always match. Wish I had a better memory. My guess is the board was made in Austin about 92??

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

February 3, 2009 at 09:05:36
pyrolitic, you seem to have a point about performance, though what I'm experiencing is a bit odd...

I removed the upgrade board, let it run auto configuration, then it was running slightly faster than it did with the upgrade board installed. Weird huh? Startup of OS/2 took about the same, running programs takes less time, and shutting down takes less time.

jefro, I'm not sure of the date on the upgrade board, it's not there. There is a sticker which has been removed (the sticky stuff is still there but sticker is long gone). It's a "61G2093" 486SLC2 card.

The whole system was assembled Sept 4 '91.

I took some fairly bad webcam photos of it (digital camera is acting up), I'll get em online and link to them soon.

Report •

February 3, 2009 at 11:54:10
You should take a closer look at the previous link I posted, there are links on that page where you can get ahold of copies of these little cache enabling programs for the 486SLC. It may be a little hassle because it looked like the links downloaded these floppy image files which would require you to first write the file to a floppy in order to get to the cache enabling program. But, anyway, if you got it and also get some kind of processor speed utility then you could experiment to see if it helps. I can tell you from experience that the 486SLC processing speed is greatly enhanced by this cache enabling (like 2-3x), so you want to make sure this cache is being enabled.

Report •

February 3, 2009 at 14:52:52
Sept 4 '91. Darn I was close!

I might have actually seen that board at some point in it's life.

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

February 3, 2009 at 18:11:24
pyrolitic, the links on that site are dead. I did however google the filename and seem to have found it.

Floppy images are no issue for me. I bought an external floppy for laptop exclusively for working with the older stuff. We'll see if that 720k disk image wants to work with my drive though...if not, time to power up the desktop pc.

jefro, you wouldn't by chance be the person who actually gave me this computer, would you? lol...your name, the person who gave me the computer's name is Jeff, and he worked at IBM apparently.

Report •

February 3, 2009 at 20:03:59

Pics ahoy! Again they're miserable webcam quality but it's the best I can do for now. The focus knob works really well for close ups, as shown with the text on the 386 CPU. Unfortunately there just isn't a very good setting for further away shots.

pyrolitic, if you navigate to the /screen_img album (click on left side of main photobucket album), you'll find that the cache is enabled thanks to you :)

I am seeing NO performance increase though, it runs faster as a 386. I don't get it. Oh well, it's technically a better machine as a 486SLC so I'll leave it this way.

Report •

February 3, 2009 at 20:16:41
I doubt an image written for a 720K disk will work on a 1.44 formatted disk. However, you can cover over the 1.44 sensor hole on a 1.44 disk with tape and format it as 720K.

The sensor hole is not the write-enable hole which usually has a slide cover.

You can probably format it as 720 even without covering over the hole but often that disk subsequently won't work in a 1.44 drive.

With XP you may need to format it from command prompt as I think XP only supports 1.44 floppy format.

Report •

February 3, 2009 at 20:57:20
DAVE, I actually found a 720k disk. It has never worked before, cyclic redundancy check failures every time, yet it worked this time. The disk image is self-extracting and self-writing so no worries with writing it.

As mentioned in the previous post I did get the software onto the PS/2 and it did install :)

thanks for the insight however, and the hole-blocking method may come in handy when the 720k disk finally bites it.

Report •

February 4, 2009 at 04:57:12
We used to buy single sided floppies and punch a notch in them to make them double sided.

Report •

February 4, 2009 at 10:47:21
Lol, that works? I'm surprised, I'd think single sided disks were physically different inside.

Does anyone know how to get the POST screen to look like other IBMs of the 90s? My goal is the black background with blue IBM logo but when mine POSTs it's a solid black screen with memory counter only.

Report •

February 4, 2009 at 14:08:46
Sometimes you would get one that wouldn't work. No different than the yeild for CPU chips. If things are working well the yield is higher than needed and things are branded at a lower speed/capacity.

The only problem was punching the material out in the right place.

Report •

February 4, 2009 at 16:22:02
I remember doing that with 5 1/4 single sided disks so I could use both sides in my commodore 1541 disk drive. I'd bought a special punch that would cut the notch in the side of the disk.

As far as the IBM logo, see if you can find a bios upgrade for that model. The IBM upgrades sometimes had an option to change the posting screen.

Report •

February 4, 2009 at 17:20:24
DAVE, my understanding of the BIOS on this machine is fairly limited. Here is my GUESS of how it works, based on what I do know:

I know there is a small partition on the hard drive for configuration info. FDISK will not show it, but it is there. This partition holds a copy of the reference diskette.

I believe that there is an NVRAM BIOS somewhere on the system board. I believe it has configurable software switches, but the reference diskette/partition have to make those switches (there is no "press xxx for setup" prompt and the common key combos don't do anything).

I have the only copies of the reference and diagnostic diskettes online...I looked extensively. All but one link I tried were dead.

The reference and diagnostic disks do not contain any settings relating to this, unless the logo only appears when there is a password set, as I haven't tried with a password set yet.

Any ideas? I have no clue on earth where to find a BIOS update for a machine like this...I'd even guess that because of it's age the chip might not be flashable. Opinions?

Report •

February 4, 2009 at 19:21:49
I could be wrong but I don't think there's any hidden partition on the hard drive. Even if there was, fdisk would show it as a non-dos partition. They're 'hidden' only because they're non-dos and as such, dos ignores them. You should be able to run fdisk to check. If all the available space is used as a dos partition there can't be any others.

If fdisk does show a non-dos partition it should be accessible either through bios setup, a separate keystroke when posting or with the reference disk.

Report •

February 4, 2009 at 20:29:52
partitioning utilities reflect only one partition, currently HPFS for my OS/2 install.

However, when I wiped and reloaded the system software, as it is called, it, in its own words, rewrote the data to the hard drive partition. I believe this partition is probably hidden due to some kind of drive emulation where the drive space, excluding that system partition, appears to be the whole physical disk. Then again I could be way off on that, but I know there is software stored in a "partition".

Report •

February 18, 2009 at 16:44:20
I've hit a roadblock...seems (most likely explanation) that I've static shocked the motherboard to death. It would be my first time having a static incident in years of messing with computer hardware so, statistically, it was bound to happen any day.

I may have a hookup for a new system board really cheap...if that's the case, you definitely haven't seen the end of me and my PS/2 :)

Report •

Ask Question