Solved Replaced CMOS battery Dell Desktop won't boot

Dell Dimension 8400 desktop
February 9, 2010 at 12:43:47
Specs: Windows XP
After replacing the dying battery on the mother board, my Dell Dimension 8400 won't boot. Battery right side up. OS=Win XP. After the POST, I get a blue screen with the message "STOP: 0x0000007B (...)" This code means Inaccessible Boot Device, according to MS Win XP Knowledge Base. About a month ago I replaced the dead internal hard drive (160 GB, SATA interface) with a replacement drive (320 GB SATA), and successfully reinstalled WinXP and other software incl. MS Office. Perhaps, during the minute when there was no battery in the motherboard, some information (in the registry? in the BIOS? I don't know) reverted to a factory default state, and as a result, the system cannot find the boot sector of the hard drive. Do you have advice for fixing this problem? I hope I don't have to reformat the drive and reinstall WinXP and everything else. Thank you for your help.

edited by moderator: Post moved from Windows XP Forum

See More: Replaced CMOS battery Dell Desktop wont boot

Report •

February 9, 2010 at 12:59:29
Might look at the bios settings pages. They went back to factory. Be sure you have the settings you need.

It isn't easy but it is suggested to copy all the settings before you change the battery.

Playing to the angels
Les Paul (1915-2009)

Report •

February 9, 2010 at 13:31:13
What prompted you to change the battery? After the change, did you enter the BIOS & correct all the settings? I have a Dimension 8400 on my bench right now, the BIOS menu is minimal (typical of most OEM systems). You should be able to easily figure out the proper settings.

Report •

February 9, 2010 at 13:43:44
✔ Best Answer
"....Desktop won't boot"

That's inappropriate.
You can't boot all the way into Windows is your problem.

I'm assumimg there is only one Windows installation on the computer. If that's not your case, tell us.

Your mboard is booting fine. The cmos battery doesn't even have to be installed for the mboard to be able to boot. There's nothing in the default bios settings that were loaded when you removed the battery that prevented the hard drive from booting.

"STOP: 0x0000007B (...)" This code means Inaccessible Boot Device,"

That's a message that can only be generated by Windows itself. You would not be getting that message if the hard drive was not trying to load Windows.

That indicates the bios has found a bootable hard drive, and that hard drive has Windows on it, and Windows has tried to start to load.

You can get that error you're getting if there is a ram problem.

A common thing that can happen with ram, even ram that worked fine previously, is the ram has, or has developed, a poor connection in it's slot(s).
This usually happens a long time after the ram was installed, but it can happen with new ram, or after moving the computer case from one place to another, and I've had even new modules that needed to have their contacts cleaned.

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

For a brand name computer, see the Owner's or User's manual if you need to - how to remove or replace the ram is usually in that - it may already be in your installed programs. If you can't get into Windows, it may be on a disk that came with the computer, or you can go online and look at it or download it - it's in the downloads for your specific model.

You can get that error you're getting if any drive's data cable has a problem.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

You can get that error you're getting if the hard drive is failing, and files are corrupted or missing on the hard drive because of that.

Check your hard drive with the manufacturer's diagnostics.
See the latter part of response 1 in this:

(thanks to Dan Penny for this link:)
Hard Drive Diagnostics Tools and Utilities

If you don't have a floppy drive, you can get a CD image diagnostic utility from most hard drive manufacturer's web sites, but obviously you would need to make a burned CD, preferably a CD-R for best compatibilty, on another computer if you need to.

If the hard drive itself tests okay, any data problems found can be fixed, one way or another.

Report •

Related Solutions

February 9, 2010 at 13:51:44
Thank you jefro & jam.
Jefro, how do I look at and change the BIOS settings? By pressing F2 during POST? I have done that, and checked that the boot device scan order is reasonable (internal hard drive first). I did not record BIOS settings pre-battery-replacement.

Jam, I changed the battery because I had been getting "system battery is low and needs to be replaced" warnings at boot-up. After the replacement, after getting the blue screen several times, I entered the system setup (is that the same as the BIOS?) via F2 during POST. Everything looks OK but I'm not sure I would recognize something that was not OK.

Thank you.

Report •

February 9, 2010 at 13:56:06
Thank you Tubesand wires. You have provided a lot of ideas and I will try them out.

Report •

February 9, 2010 at 14:35:10
Is it possible that you have a sata drive that was set to ach. (is that what it is called?) Basically using a sata in eide mode. There is a bios setting for that.

For the most part a bios battery should not affect the actual OS ever. It only affects hardware. That is what we need to decide if some issue with bios or some oddity that has no relation to the battery.

Playing to the angels
Les Paul (1915-2009)

Report •

February 9, 2010 at 18:35:18
Jefro, you are correct. In the System BIOS pages, I changed the integrated hard drive controller setting from RAID/AHCI (the factory default) to RAID/ATA. That cured the problem.
Thanks to all for your suggestions. This is my first time using this web site. I am very impressed with the speed and quality of the responses!

Report •

February 9, 2010 at 19:43:10
"In the System BIOS pages, I changed the integrated hard drive controller setting from RAID/AHCI (the factory default) to RAID/ATA. That cured the problem."

Update -

We're glad to hear you got your system working again.

Good going jefro .


(original, except for a few typo corrections and a few added words)

Your hard drive should boot with that set either way, unless you (or someone) never installed the SATA controller drivers for your motherboard in Windows after the last time Windows was installed. (RAID is an optional feature - most people don't use it.)
Those drivers are available on the Dell site in the downloads for your model.
If the SATA controller drivers have not been installed, there is probably an unknown device or a device with a problem in Device Manager.
e.g. RIGHT click on my Computer - Properties - Hardware - Device Manager.
If the SATA controller drivers were installed properly, the controller is listed as a SCSI device there.

The only thing that setting commonly affects otherwise, is, if you install Windows from a regular CD, XP has no built in support for recognizing most if not all SATA controllers - Setup won't find the SATA controller and SATA drives unless.......
- that setting is set to RAID/ATA (generically - ATA is IDE compatible mode) in the bios.
- or - you provide a floppy disk with the SATA drivers on it during Setup, after pressing F6 very early in the loading of the files from the CD when you see "Press F6 to load...."

RAID/ATA (generically - ATA is IDE compatible mode) has a max burst data transfer speed of 133 megabytes per second.

RAID/AHCI (generically - AHCI is SATA mode) has a max burst data transfer speed of 150 or 300 megabytes per second, depending on the particular mboard and hard drive.

However, those ratings are a marketing gimmic - they can only be achieved continuously for short periods of time, a few minutes at most, the time depending on the size of the memory cache on the hard drive's board - most of the time the hard drives are transferring data at a much slower max sustained (continous) rate e.g. under 100 mbps for recent drives, slower for older ones, or slower.

Report •

February 11, 2010 at 16:21:26
Thank you TubesandWires. I will keep that in mind.

Report •

Ask Question