remove write protection on usb mass storage d

Generic usb storage / 32 gb usb mass storage de...
December 1, 2010 at 14:03:47
Specs: Windows 7 PRO x64, Intel core 2 duo E7200/ Kingston KVR 1333 DDR3 2x2 GB-Corsair 1333 DDR3 2X2 GB
Windows 7 Pro x64 os
platform Build
CPU Intel core 2 E7200 1066 FSB
HD WD 500GB 5400RPM
Ram Kingston KVR 1333 DDR3 2x2GB
Corsair 1333 DDR3 2x2GB
PS Master Cooler 850W silent pro m
Video XFX Radeon HD 5750
USB Generic 32GB
Generic USB drive 32Gb. Drive is new. stored several programs onto drive the transfer was successful. I tried to copy some of the information back to another drive and that was successful. Removed drive and stored it for about a week then put the drive back int the usb port and tried to copy information onto the drive and recieved an error message that the drive was write protected and it could not be written to. I then tried to copy files from the drive to my hard drive and recieved the same message. The message is as follows

"disk F: is write protected remove write protection or change disks"

Can anyone explain or solve this problem?

See More: remove write protection on usb mass storage d

Report •

December 1, 2010 at 14:40:25
If this is a thumb drive, look on the side of the housing and see if there is a little slide bar. If there is slide it in the opposite direction.

Report •

December 1, 2010 at 18:08:45
Check this out:

Refers to XP but might get you started in the right direction for WIN7

Goin' Fishin' (Some day)

Report •

December 2, 2010 at 10:34:55
There is no switch on this drive

Report •

Related Solutions

December 2, 2010 at 13:01:34
You will get that error message if the hard drive has a fat 32 partition and the file you are copying is over 4 gigs in size.

Report •

December 10, 2010 at 03:23:39
None of the files on this drive are anythink close to 4 GB in size. have followed all suggestions listed in the forum and have not had any success.

Report •

Ask Question