raid 5 data lost? or only the configs recover

August 18, 2011 at 07:22:02
Specs: Windows 7
i have a raid 5 setup, here is what happened, it has this config, drive 00 online, 01 ready, 02 online, 04 online.01 has failed and went back to ready so i was to replace 01, but i accidentally replaced 02 without verifying the scsi id correctly, powered the machine and went in to raid utility, thought i replaced 01, so i tried to force 04 to go offline since it was supposed to be the hotspare. when i finally noticed i made a mistake with the IDs, i replaced 01 now and went back into raid utility, but now this is what is showing 00 ready 01 ready 02 ready 04 hotspare. and no logical drives are detected, i did not do anything other than scan and detect i did not do any rebuilds yet. my question is can i still recover the raid 5 setup to the original state which is 00 online 01 ready 02 online 04 online? and is the data still there? if so how can i recover it back? please help! raid is perc 4, system is dell poweredge 600sc, windows 2003 server standard edition, OS is also part of the raid. thanks in advance

See More: raid 5 data lost? or only the configs recover

Report •

August 18, 2011 at 13:09:16
The only hope would be to return it to the way it was when it broke and see if it is still bad in the same manner. Yep, you can only fix those raid arrays one way.

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.

Report •

August 21, 2011 at 09:46:47
hi jefro, thanks for the reply, but when i put everything back, it stays the same, 00 ready, 01 ready, 02 ready, 04 hotspare. so does this mean that the raid 5 has been totally destroyed and not recoverable?

Report •

August 22, 2011 at 00:29:27
hi jefro, i managed to revive the data by putting in the old drives and doing an easy config, put it back to the original raid settings., great!, so i put in the correct replacement drive on the correct slot and it did a rebuild after failing 04, once it was completed it worked and booted ok. now here is the problem again. this is a dell machine, and I only have an HP 36gb spare and the owner wants to replace 00 also, so i replaced 00 using the hp hdd, and failed 00, 04 kicked in but i stopped the rebuilding on 04, by failing it and 00 being a new drive and i made it a hotspare kicked in, so after rebuiling 00, it wont complete the post saying drive mismatch, so i configured it again using easy config, now it goes pass that error, but windows giving ntldr corrupted error, so i fixed that, now it is giving me lsass.exe error. x2e1 error, What should i do? is this fixable or do a reinstall? i am currently trying to revive it by going into directory service repair mode but it is taking too long to load under applying computer settings.

please help!

Report •
Related Solutions

Ask Question