PV-SD4090 Panasonic camera is not detected by Win7 64-bit

January 23, 2012 at 08:13:16
Specs: Windows 7 64
My Panasonic camera is not detected on my Win7 64-bit PC. It has plug-and-played fine with Win98, Win2000, WinXP, and Vista. I realize that I need a 64-bit driver and am looking for a source. Any help will be appreciated.
This camera is base on the LS-120 Superdisk and is Extremely Tough. The 1.3 MP images suit my outdoor work as a natural gas engineer since I do not have to downsample for email or web posting. Any help will be appreciated.

See More: PV-SD4090 Panasonic camera is not detected by Win7 64-bit

Report •

#1
January 23, 2012 at 08:29:15
What model is the camera? Does it use a removable memory card? if it does, a work around for now could be to get a card reader that works with Win 7 64bit.

Report •

#2
January 23, 2012 at 09:22:15
It may be time to upgrade your camera. Just lower the MP setting & there should be no need to "downsample" your photos.

Report •

#3
January 23, 2012 at 10:44:15
Check with Panasonic. A 15 year old design probably would not be supported. Have you tried 32 bit Win 7?

Report •

Related Solutions

#4
January 23, 2012 at 13:42:01

Report •

#5
January 23, 2012 at 14:04:24
Thanks, everybody. I was aware that 64-bit driver was what I need, and Panasonic has not replied to my request. The camera has been great, and its steel body has been a lifesaver in the field, multiple ways. But, all good things come to an end, unfortunately.

Report •

#6
January 15, 2013 at 12:45:20
Don't forget, if you run Win7 Pro (32 or 64) you can run the Windows Virtual Machine in XP mode and install everything that way. Yeah you have to run in XP Mode to do everything but you can still use your cam :)
I just did that with my system and it worked great!

Report •

#7
January 15, 2013 at 12:47:22
If you are running Win7 Pro (32 or 64) you can install the Windows Virtual Machine and run a window in XP Mode. From there you just select the device from the USB menu and install as usual. I just did that with my camera and it worked like a charm. Search on how install the WVM and XP Mode if you are running Pro.

Hope that helps!


Report •

Ask Question