PS/2 Laptop keyboard driver issue.

June 19, 2016 at 09:37:05
Specs: Windows 10 / 8.1
My friend has an Acer Aspire V3-371 netbook, that has suddenly stopped keyboard function.
The PS/2 Keyboard Driver in device manager shows an error (not starting error 10).
However the keyboard functions still operate (eg. Fn+F6 to disable mouse pad)
The odd part is when i added an external usb keyboard it would function fine to allow password entry to log into windows, but then displayed the same non-functions as the supplied keyboard.
A factory reset now allows the USB Keyboard to work fine.
I have tried:
uninstall/ re-install driver
different generic windows supplied drivers
factory reset
registry i8042prt start value change
deleting and re-supplied kbdclass.sys i8042prt.sys kbdhid.sys driver files.
and of course run malware and virus scans.

I'm flummoxed, any help?

message edited by CLambshank

See More: PS/2 Laptop keyboard driver issue.

Report •

June 19, 2016 at 12:14:45
Maybe this will help:

Doing the best I can here... And remember, there's always more than one path to success. :)

message edited by Jennifer SUMN

Report •

June 19, 2016 at 14:42:57
Thanks for replying, I have tried everything on that page and still no change.

Report •

June 19, 2016 at 15:45:14
Lets see if I can find a clue in these logs.

Please download Farbar Recovery Scan Tool and save it onto your Desktop. If your default download location is not the Desktop, drag it out of it's location onto the Desktop.
If we have to run Farbar more than once, refer this SS.
Note: You need to run the version compatible with your system. If you are not sure which version applies to your system download both of them and try to run them. Only one of them will run on your system, that will be the right version.
Double-click to run it. When the tool opens click Yes to disclaimer.
Press Scan button.
It will make a log (FRST.txt) on the Desktop.
The first time the tool is run, it makes also another log (Addition.txt)
The logs are large, upload them using Zippy ( No account/registration needed ) or upload to a site of your choosing. Give us the links please.
Instructions on how to use ZippyShare.

Report •

Related Solutions

June 20, 2016 at 07:53:15
Hi, thanks for looking, hope this sheds some light.

Report •

June 20, 2016 at 18:18:39
Here is the next step, reboot & test after running this, too see if you still have your problem.

Copy & Paste the text in Blue below & save it into Notepad on your Desktop & name it fixlist.txt
NOTE: It is important that Notepad is used. The fix will not work if Word or some other program is used.
NOTE: It is important that both files, FRST64 and fixlist.txt are in the same location or the fix will not work.
NOTICE: This script was written specifically for this user, for use on that particular machine. Running this on another machine may cause damage to your operating system.

Task: {321409B3-332E-4780-BBE1-7E9E238C3F58} - \Microsoft\Windows\Setup\gwx\refreshgwxcontent -> No File <==== ATTENTION
Task: {550B07A5-355A-4749-A585-0496515A71A6} - \Microsoft\Windows\Setup\gwx\launchtrayprocess -> No File <==== ATTENTION
Task: {70F4A582-14A1-4106-8F55-99990CFF22D0} - \Microsoft\Windows\Setup\gwx\refreshgwxconfig -> No File <==== ATTENTION
Task: {806BF2BA-F393-4D6E-A7EC-AFCE1CEA3182} - \Microsoft\Windows\Setup\gwx\refreshgwxconfigandcontent -> No File <==== ATTENTION
SearchScopes: HKLM -> {AA9A4890-4262-4441-8977-E2FFCBFB706C} URL = hxxp://{searchTerms}
SearchScopes: HKLM-x32 -> {AA9A4890-4262-4441-8977-E2FFCBFB706C} URL = hxxp://{searchTerms}
SearchScopes: HKU\S-1-5-21-3249670520-753672921-331263008-1001 -> DefaultScope {4C5BCE36-8F60-47AB-B3F2-F8FE8F7B22FB} URL =
SearchScopes: HKU\S-1-5-21-3249670520-753672921-331263008-1001 -> {4C5BCE36-8F60-47AB-B3F2-F8FE8F7B22FB} URL =
SearchScopes: HKU\S-1-5-21-3249670520-753672921-331263008-1001 -> {AA9A4890-4262-4441-8977-E2FFCBFB706C} URL = hxxp://{searchTerms}
FF Plugin:,version=10 -> C:\Program Files\mcafee\msc\npMcSnFFPl64.dll [No File]
FF Plugin-x32:,version=10 -> C:\Program Files (x86)\McAfee\msc\npMcSnFFPl.dll [No File]
FF Plugin-x32: -> C:\Program Files (x86)\McAfee\SiteAdvisor\npmcffplg32.dll [No File]
FF HKLM-x32\...\Firefox\Extensions: [{4ED1F68A-5463-4931-9384-8FFF5ED91D92}] - C:\Program Files (x86)\McAfee\SiteAdvisor => not found
FF HKLM-x32\...\Thunderbird\Extensions: [] - C:\Program Files\McAfee\MSK => not found
CHR HKLM-x32\...\Chrome\Extension: [fheoggkfdfchfphceeifdbepaooicaho] - C:\Program Files (x86)\McAfee\SiteAdvisor\McChPlg.crx <not found>
2016-06-18 23:33 - 2016-06-18 23:33 - 0000000 ____H () C:\ProgramData\DP45977C.lfl

Open FRST64 and press the Fix button just once and wait.
If for some reason the tool needs a restart, please make sure you let the system restart normally. After that, let the tool complete its run.
When finished FRST will generate a log on the Desktop (Fixlog.txt). Please Copy & Paste the contents into your reply.

message edited by Johnw

Report •

June 25, 2016 at 05:56:19

Hi, forgive my slow reply but as I stated it's not my computer and I have limited access to it.
I tried the fix you sent but no change.
Curiously since I last used the machine the original problem with the USB keyboard has returned. (works for log-in, then not once in windows)

Any help is as always greatly appreciated.

Report •

June 25, 2016 at 06:04:03
Ok, next step.

Make sure ALL your Regional and Language Options settings are Ok. They will be something similar to this, the main point being, you should have at least 3 places to make sure you have your country displayed.

Windows 10: Change or Add Another Language or Region.

If after doing your Region settings & testing, you still have the problem.

Run - Windows Repair

Disable your antivirus program before running Windows Repair.
How to Temporarily Disable your Anti-virus

Start at Step 1 ( very important ) do all the steps until you get to the final step ( Repairs ) Reboot when finished.
Right click on the exe & click on > Run as administrator.

Report •

June 25, 2016 at 12:07:05
Ok, I have tried all the methods listed and still no change.

Is there anything else i can try?

Report •

June 25, 2016 at 16:04:32
Check the bios, some BIOSes have a setting to enable/disable ps2 ports. You can set this to enable, disable or auto.

Report •

June 29, 2016 at 06:17:29
I have checked and it does not, my friend has taken it to a computer repair shop (without me knowing) and they have said that it is a keyboard hardware issue and will need replacing (£££), but I fail to see how that can be? (I'm concerned they are going to rip her off) Any thoughts?

Report •

June 29, 2016 at 06:34:52
Press F8 during boot and restore the good configuration settings.

Report •

Ask Question