Solved PS2 keyboard working in Linux and not in Windows

March 27, 2015 at 15:09:33
Specs: Windows 7
I need to access the BIOS to allow booting from CD but I cannot because my PS2 keyboard is not recognized. Still, if I use a Linux bootable CD the same keyboard is perfectly functioning. So:
* The PS2 port works
* The keyboard works
Why the hell it is not recognized at startup so that any possible F2/Del/F6/F11 keys do not work to letting me access the BIOS settings?
How do I get the keyboard being recognized by the BIOS?

See More: PS2 keyboard working in Linux and not in Windows

Report •

✔ Best Answer
March 27, 2015 at 23:59:13
Even though the keyboard seems to be good because it works with linux you might try another one. Also try a USB keyboard.

March 27, 2015 at 15:41:38
As a long shot maybe discharging the motherboard will fix this - I had trouble once after using a Linux Live CD:
Turn off computer, disconnect power, remove main battery if a laptop. Before re-assembling hold the Power Off/On button down for at least 20 seconds.

Otherwise, from what I've read this little batch file could sort it in Windows:
I've peered inside it and it is harmless, just sets a service. Apparently you can hit this trouble after previously using a USB keyboard.

The problem of-course is how the heck you run a batch file without a keyboard. If you can get to the batch file obviously a couple of mouse clicks should do it but UAC could be an issue. Maybe the keyboard will work in Safe Mode and allow you to run it.

Always pop back and let us know the outcome - thanks

message edited by Derek

Report •

March 27, 2015 at 21:24:43
You say it works when linux is loaded. Does it work when your windows 7 loads?

Are you sure you're pressing the correct keys to get into bios setup and pressing them at the right time?

You also might clearing the cmos. Assuming it's a desktop, disconnect the power cable, open the case and locate the 'clear cmos' jumper on the motherboard. Jumper it to the 'clear' position for a few seconds and then back to 'standby'. Close the case, reconnect the power cord and try again.

Report •

March 27, 2015 at 23:22:16
Dear Derek, Dear Daveincaps,
Thanks so much for your help. A bit of background is due:
* I'm not a hardware expert. I am more a "hobby programmer" for what it means. I never opened and seriously looked into a box up to now.
* The box: it is a AMD quadcore bought for few money on ebay for number crunching activities. Self made by the seller (List of component quite incomplete) and delivered "without OS", i.e. an unregistered copy of Windows 7. Successfully run (to my full satisfaction) for 1.5 years under Linux Mint 16.
* Catastrophe: two days ago while running a windows program (MT4, which was running successfully already a couple of times before) under wine 1.4 I have a crash. Result is unbootable machine. Partition table corrupted, no fstab or mtab left over, no grub.cfg not possible to run grub-install. All these information collected by booting Linux from DVD. If you want to see the report of boot-repair (and how bad is the situation of the disk: where no trace of an intact Linux is left!) look at {Thanks... to the wine people for the little mess...}
* I would like to scratch install Windows 7 (commercial official installation DVD) reformat the whole, repartition etc. I don't manage because (strange enough) I'm able to boot from Linux install DVD's but not from Windows. Probably "interference" by existing old Windows. And when I start up with DVD inside, the system asks me to "press a key for booting from CD"... But, as you know, at that stage the keyboard is NOT recognized.

Now to the questions:
* it is not a laptop
* the PS2 keyboard works just if I start linux by using the Mint Installation DVD. If I let the system load the old windows (which takes ages, because probably the system is corrupted as well) I DON'T get the keyboard recognized under Windows. "Not recognized under windows", still nastier, means that I can toggle num lock on the number keypad on and off (led lights up), but no keystroke is e.g. recognized within a text editor (that I can start with the mouse - a usb one).

My plan now is to look carefully within the box and try to locate the CMOS reset jumper (I found a video on youtube how it should look like). I have already seen that, for removing the battery I have to unscrew the whole machine, basically, because it is located under the components of the graphic card and basically inaccessible. So I will keep it for later.

Second I will try with the batch file suggested by Derek, if I manage to start it under windows without keyboard. I will let you know.

Again many thanks!

Report •

Related Solutions

March 27, 2015 at 23:59:13
✔ Best Answer
Even though the keyboard seems to be good because it works with linux you might try another one. Also try a USB keyboard.

Report •

March 28, 2015 at 00:04:32
This is also a very good tip! I'll try to find one.

Report •

March 28, 2015 at 04:45:43
It would be helpful to know the make/model of the motherboard.

The OS has nothing to do with BIOS. The fact that pressing the appropriate key (probably Del if it's a retail board) doesn't grant access to the BIOS means that you have a hardware problem. It could be the keyboard or possibly the PS/2 port. Make sure the plug is fully inserted. You might wanna try unplugging & replugging a few times to clean the contact pins. Otherwise, try another keyboard as suggested.

EDIT: once you have the board model number, go to the manufacturer's website & download the manual. There should be a diagram showing the location of the clear CMOS jumper & instructions on how to use it (power supply must be switched off or unplugged).

message edited by riider

Report •

March 28, 2015 at 07:09:39
Dear Friends,

Thank you so much for being so proactive in helping people! Concerning the "pure" keyboard problem I must now select as best answer the last tip by Daveincaps. I spent a bit of time getting to the office and back for taking home the USB keyboard, and this was the magic, in my case.
I scratch re-installed Windows 7 and now I am able again to access the BIOS with a single nice F2 stroke on the nice PS2 keyboard, without any gymn suggested elsewhere (press all keys, make strange things...).

The only "little" remaining problem is that... with fresh (and not online yet) Windows, the computer is still not working properly. Something never seen before. 15 minutes for booting windows and 15 minutes for shutting down. I'm sorry, because, before the wineHQ incident (and I cannot really really realize how such a piece of s...oftware was able to crash things such as a low level...) the machine was quite well performing (I was making data mining with R and Numpy on "big data" sets).

Now, as I can access the BIOS, here all the details requested by riider:
ASRock BIOS version N68C-S P1.20
When started up there is this series of messages, the last one is nasty:
Ultra DMA Mode-6, S.M.A.R.T. Capable and Status OK
Ultra DMA Mode-5
SATAII_3: WDC WD5000AAV-00ZTB0 01.01B01
Ultra DMA Mode-6, S.M.A.R.T. Capable but Command Failed

Now: as I am very far from this "low level things" if you can give some more suggestion I will be very thankful. This is now OOT here, so if needed I open another thread.

In particular should I reset the BIOS to the default settings?
There is something called "Overlock Mode": should I make anything there?
Should I make an update? Is the ASRockInstantFlash the way to make it?
There is a setting called "Performance Setup Default". Should I use it?

If you are so nice to get me on the right path, it would be great!

Report •

March 28, 2015 at 08:50:59
Here's a link to your board info:

"I am able again to access the BIOS with a single nice F2 stroke"

F2 seems a tad unusual for a retail board, but according to the manual either F2 or Del will get you there:

"You may run the BIOS SETUP UTILITY when you start up the computer. Please press <F2> or <Del> during the Power-On-Self-Test (POST) to enter the BIOS SETUP UTILITY"

When you installed Win7, did you select "custom (advanced)", delete ALL existing partitions, & then create one (or more) new ones? Did you have the 500GB HDD connected during the installation? Based on what you posted above - "S.M.A.R.T. Capable but Command Failed" - my guess is the 500GB HDD has a problem. Try disconnecting it & see what happens.

As for the BIOS settings, defaults are just a starting point (or a fallback point if you screw up). Performance Setup Defaults may work better but IMO, no single-click option will ever be 100% correct. It's generally best to run thru each & every setting & select the best choice based on your hardware configuration.

Updating the BIOS probably isn't necessary. Looking at the link above in the Downloads section, there have been 3 updates - versions 1.10, 1.20, 1.30. Do you know which version you currently have? I'm a proponent for running the latest & greatest version, but others will tell you "if it ain't broke, don't fix it".

Report •

March 28, 2015 at 12:40:40
Dear riider,
dear friends.
Again thank you so much to all your so precious suggestions. Riider: my BIOS version is 1.20. But, to say the truth, while I received your message I was already making something else. I re-started again from the Windows install. disk, and run the "system repair" tool. You never know exactly what those things are doing... But then, at restart, a disk check was popping up. After the disk check... well, the wonder! Actually I had to go in the admin tools and finish up the partition table, because several virtual disks were not yet mounted (strange). But now they are also there. Even the 500GB. For this one I reopened the box and replugged it. I think that yesterday, while looking for the BIOS battery, I probably moved the cables and unplug it without noticing. Again a checkdisk at startup, and here it is. I had to reformat the former Linux partition by hand, actually, but now it is there for my "big data".
Therefore I have no reason, now, as you also say, for tweaking around with the BIOS anymore.

I think this is now a divorce from the "first love" for me. After what happened, and seeing how performing is this new Windows 7 Ultimate install, after all these pains, this could be a definitive farewall to Linux.

Thank you again!

message edited by fsprea

Report •

March 28, 2015 at 14:03:24
Good to hear you got it sorted and thanks for popping back to let us know.

message edited by Derek

Report •

Ask Question