Problems with flashing the BIOS

Msi (motherboard) / Kt4v ms-6712 ver:10a
June 4, 2009 at 14:43:19
Specs: Windows Vista

I think my Bios has become corrupt as my hard drive is no longer being read and the CPU speed figure has decreased during start up but it halts and cannot find my hard drive.

I have done and checked all of the sensible things to try in the example link below.

Here are the details of my main board.

ms-6712 ver:10a
AMD Processor 2.09 GHZ
Originally buit by TIME

To resolve this I have a couple of ideas but could use some advice please:)

I cannot find the exact flash tool from the manufacturer website. I wonder if anyone else can. I could use the flash utility from a usb stick as I'm sure the BIOS is reading USB.

Or on the manufacturer website there is a live update tool but I wont be able to get to that without an operating system running.

liveupdate381 (MSI Live Update 3 Version:v3)

Does any of the windows run as on operating system live from a CD like Linux is able to as I could use this update tool that way. I don't think windows can do that but I havent tried it. (I have XP, Vista , 98,that I can boot the PC with)

Any ideas appreciated,

Many Thanks, Ben

See More: Problems with flashing the BIOS

Report •

June 4, 2009 at 14:50:54
You don't need to flash the BIOS at all. Boot into the BIOS screens and see if the date is wrong. If so, change the CMOS battery on the motherboard. Look at the link below to learn how.

After you change the battery with the computer unplugged then the first time you boot you will need to enter the BIOS screens and reset some of the values as required.

Below is a link to the Microstar international site. Your exact model is not listed.

Report •

June 6, 2009 at 12:04:26
Many thanks for your reply!

My BIOS did have the time and date of factory settings but it may be possible that I did that.

Before I mailed my first post I had removed the wire cable from the power supply to the motherboard and removed the battery, left it off for a while and put everything back the way it was in the hope of resolving my problem.

I can reset the date, turn the machine off and remove the plug from the power, leave it off and when I come back the BIOS retains the recent date that I set.

I can order a battery if you still think that might be the problem: (Panasonic cr2032 +3v)

On boot I get "primary IDE master not installed" and the same for slave. It detects the secondary IDE master DVDrom and it detects the floppy drive.

It reads the memory correctly but I think it reads the processor speed incorrectly at 1250MHZ (AMD Athlon)

The current BIOS at boot up reads A6712 VMS v1.8 021003

The machine had been running Vista for several days and I had installed a personal firewall on it:

All seemed well that day and I shut down as normal and the following day I had the issue where it did not detect my hard drive.

Report •

June 6, 2009 at 12:38:26
Your CMOS battery appears to be OK.

Your BIOS settings are now all set to defaults, except for whatever ones you reset (date/time).

I provided a link to the motherboard site. You can download the manual in PDF format if you don't have it.

Evidently your motherboard requires you to set the values in the BIOS for many items, including the processor FSB & frequency multiplier.

Read the manual to learn how to set those values correctly.

As far as the hard drive not being detected there could be any number of reasons for that. The drive may have died. The cables may have worked loose. The IDE drive controller may be disabled or it has died. You should have TWO IDE drive controllers. There are settings in the BIOS to enable the IDE controllers.

You may need to change the settings for the drive in the BIOS.

Watch the POST screens at start up to verify the drives are identified by model and FULL capacity.

You should be able to tell if your hard drive is spinning by touch and sound.

Report •

Related Solutions

June 6, 2009 at 12:41:12
most of the time, when the drive is not detected, its not the bios, its a bad drive. Could try putting the DVD, on the primary, just to confirm, the ide & cable is ok.


Report •

June 6, 2009 at 14:13:19
There is a windows live cd called BartPE but it's a bugger to add new software to in my experience. Best thing you can do is get your hands on another hard drive from a friend or someone. Test to see if your hard drive boots on another machine. Replace the Data cable. I like larry215's suggestion of trying another ide port on the mainboard. The easiest way to fix a computer is to throw any opinions that go something like "It is definitely not my hard drive". Try it on a known working machine to make sure. Best of luck.

Report •

Ask Question