Problems Booting to Sata Raid0 with ATA drive

Dell / Dell dxp061...
June 24, 2009 at 02:49:25
Specs: Microsoft Windows XP Professional, 2.128 GHz / 3069 MB
Hello to all!

My system uses two SATA hd's set to RAID 0. I also have a Promise Ultra133tx PCI card installed because my motherboard has no IDE ports. If I connect an ATA harddrive to one of the IDE ports, my system will not boot, even if I select raid drive from boot select menu, and regardless which jumper configuration I have on the ATA harddrive. In the "Raid Operation" menu in my BIOS, I can select "autodetect", or the other option (sorry, can't remember the name now, something Sata Operation, etc, etc). Neither options enable me to boot to XP. The second option (the one whose name I can't remember) says that it will automatically boot to Sata or Raid if drives are signed, etc, etc. Don't know if my drives are signed.

Any help would be greatly appreciated. Thanks!

See More: Problems Booting to Sata Raid0 with ATA drive

Report •

June 24, 2009 at 14:28:34

Remove sata to start. Use promise bios to setup drive if needed, see docs.

Two things are going on. One is that the ide adapter if good even has to work with bios. Bios should but not always work with add on cards. Might have to check irq and such or even move card to other slot.

As to bios it may have an odd way to tell you what is what. It might think the adapter is a raid or scsi or see it as ide. Have to play around.

To be sure xp would most likely need drivers with F6.

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

June 24, 2009 at 16:27:04
Has this system ever worked when setup as you are describing it?

Report •

June 24, 2009 at 16:39:56
Thanks to both of you for your replies.

No, the system has never worked when set up as described, which is a little disappointing to say the least, considering the purpose of the Ultra 133tx is to add more drives to a system.

Report •

Related Solutions

June 24, 2009 at 17:27:58
So, where do you want to install WinXP? On the IDE drive or the RAID 0 array?

Report •

June 24, 2009 at 17:50:44
XP is already installed on the raid array. I just want to connect an old ATA drive I have for storage space. There doesn't seem to be any way to access the Ultra bios. I went over the ultra manual, they make not mention of it. There may be something in the Promise forums, but I'm being lazy.

Report •

June 24, 2009 at 18:00:11
The ATA drive has an OS on it, which could be causing a conflict, but I don't see why, since I disabled it in the boot sequence.

Report •

June 24, 2009 at 18:00:58
Generally controller cards are configured as SCSI devices. So try setting the first boot device as SCSI.

Report •

June 24, 2009 at 20:24:47
Why would I want to do that? My OS is NOT on the ATA drive, it's on my raid. I want to boot to my OS on the raid array, and then have windows discover new hardware.

Report •

Ask Question