Primary IDE channel failure

October 23, 2010 at 18:23:50
Specs: Ubuntu 10.04, Pentium III 667MHz/512Mb
I was working on my computer, opening a file, when it locked up - no response, I had to shut it down by holding in the power button. When I turned it back on, it wouldn't boot.

I had the hard drive by itself on the primary IDE channel, and a DVD-RW and Zip drive on the secondary.

Investigation found that the hard drive wasn't recognized by the BIOS. I tried substituting another hard drive; same result. I substituted the DVD-RW drive; same result. I put the original hard drive on the secondary IDE as master, replacing the DVD-RW. It was recognized by the BIOS, but the computer wouldn't boot from the drive until I disabled the primary IDE channel in the BIOS setup.

As this was a working machine at the time of failure, jumpers and bios settings seem an unlikely cause. I ran a virus scan on the file I was opening when the computer shut down; it said the file was clean - but I don't feel like running it again until I figure out what happened to my primary IDE channel. The computer OS is Ubuntu 10.04.

Suggestions, please!

See More: Primary IDE channel failure

Report •

October 23, 2010 at 18:38:05
I have seen primary IDE channels fail just as you describe. I can't speculate why that would happen.

Did you eliminate the data cable as the defective part by using a known good cable on the primary channel?

I don't think it would help but you could try clearing the CMOS and then trying the primary channel again.

Report •
Related Solutions

Ask Question