Primary drive 0 not found

January 2, 2012 at 19:44:11
Specs: Windows XP
I've got a Dell Dimension 4600 with two HDs. Everything worked for several years till it had been unplugged for two months. Then, when booting up, the following messages appeared:

Primary drive 0 not found
Primary drive 1 not found
Strike the F1 key to continue, F2 to run the setup utility.

I hit F1 to continue and Windows XP comes up but the second HD no longer appears.

Thinking something was wrong with the second drive, I pulled it and put it in an external enclosure. I attached this external HD to another PC via USB and found all files/folders are visible/accessible. So, it's not the HD.

Since it had been unplugged for two months I suspected the battery but the date/time in the BIOS is correct.

I've Googled the error message but I haven't found a situation where
a. The PC does boot to Windows ok and,
b. The secondary drive checks out ok.

I've seen some reports of unplugging the cable and plugging it back in but if it boots to XP, how could the cable be bad or loose?

Hope someone has an idea.

See More: Primary drive 0 not found

Report •

January 2, 2012 at 19:54:12
The message simply means the BIOS isn't seeing any hard drives.

If you had 2 IDE hard drives connected to the same cable then if 1 of them when bad it would stop both from being configured. The data or power cables may have worked loose.

Did you also test the primary (disk 0) drive?

Report •

January 2, 2012 at 20:00:49
Thanks for your response. It occured while I edited my original post.

No, I didn't test the primary disk. If it's booting to XP (the primary disk) and all appears to be well, wouldn't that indicate the primary disk is ok?

Or, if the BIOS didn't see the primary drive, wouldn't it fail to boot into XP when I hit f1?

What did happen is that the secondary disk was no longer visible -- but in an external enclosure, it's fine.

Now, with the secondary HD removed, I still get those messages but it boots into XP.

Report •

January 3, 2012 at 06:28:36
Did you make ANY hardware changes just prior to this message appearing?

I assume both drives are IDE type and were both connected to the same cable.

You need to boot into the BIOS (setup) and reset some values there. Date, time, boot order, etc. While in the BIOS, verify that all the drives are being configured. You also have a CD drive, which may also be IDE type. Verify that drive is also being configured and is functioning.

If the date is wrong when entering the BIOS screens you need to replace the CMOS battery. That is the silver nickel sized battery mounted on the motherboard. Be sure the computer is unplugged before changing.

Report •

Related Solutions

January 3, 2012 at 07:10:56
Thank you.

No, there were no hardware changes. The date/time was correct. The BIOS settings for the HD are set to Auto. Currently, the secondary drive is in an external enclosure, but I will re-insert and recheck the BIOS this evening.

Report •

January 3, 2012 at 08:58:36
Try clearing the BIOS by using the cmos jumper or by removing the battery. Be sure the computer is unplugged. You will need to reset values afterward.

Report •

Ask Question