Power Supply causing crashes?

Kingwin Mach 1 1000w power supply
August 8, 2010 at 08:09:46
Specs: Windows XP
Okay, I'm a computer hobbyist and a gamer, and I've been having an ongoing problem with my computer for almost a year now.

Crashes. Specifically, very sudden crashes. I'm doing something, and all of a sudden everything stops, no input has any effect, sound stops, or loops a very small sample, and I have to hard shut down the computer. I have been replacing parts little by little for over a year now, and I can't seem to correctly diagnose the issue.

AMD Phenom 955 x4 (3rd Processor)
Nvidia 8800GTX (Haven't changed yet)
Biostar TA790GXB3 (3rd Motherboard)
2 Gigs of off-brand DDR3 RAM, but it's tested good again and again. I also have 2 Gigs of G.Skill, which test good as well, but if I load up more than two gigs, in any motherboard, I get more crashes.
I've got a Kingwin 1000W PSU.

I think the PSU is the problem. From the software end, I've installed both Win7 64bit and WinXP 64bit on three different HDD's, and the crashed remain constant. After the initial install, there is occasionally a brief reprieve, maybe two to three weeks, and that's only been with windows7 installs. Then the problem occurs again. Can I safely assume the problem is the power supply?

See More: Power Supply causing crashes?

Report •

August 8, 2010 at 08:18:49
"Can I safely assume the problem is the power supply?"


Report •

August 8, 2010 at 08:53:04
What does it crash in ?
If it's only in a game or games, not when you're using Windows otherwise, games do NOT work properly on all computers.

"Nvidia 8800GTX (Haven't changed yet)"

It's a lot more likely your problem could be caused by a defective video card, or apoor connection of the card in it's slot, rather than a defective mboard or cpu.
Try removing the card, wiping off it's contacts, don't touch the contacts with your fingers, installing the card, and making sure it's all the way down in it's slot and is fastened down securely - some PCI-E X16 mboard slots have a clip or sliding piece that will lock down the inner end of the card so that can't move upwards.

Your power supply has a lot more capacity than you need. Any power supply can malfunction, but you haven't mentioned anything that points to that, and if you had that problem, you would likely have crashes a lot more often than you're having. Check the current voltages in the bios Setup for what is supposed to be +3.3v, +5v, and +12v - if any of those are not within 10% of the nominal vale, you must replace the PS.
Otherwise, the only way to rule out a PS problem for sure is to try another known good PS that has enough capacity with your system for a while. If you can borrow a used PS from another computer you have or a friend has, try that.

The minimum recommended PS capacity for a system with a single 8800GTX video chipset on a card is 450 watts.

Your problem could be caused by overheating of the CPU or video chipset. Have you checked the CPU fan and heat sink, and video fan if that applies and video heat sink, to see if they have accumulated mung - dust, lint, etc. - on them , and whether the fan is spinning ?
If they DO have mung on them, clean them off, but DO NOT use a vacuum cleaner to do that.

Your problem could be caused by a ram problem that isn't always present.

Not all ram that you think should work will work properly with your mboard.
You are supposed to use your mboard model on a ram manufacturer's or ram distributor's web site to look up which modules are listed for your mboard model - if the modules you are using are not listed, there's no guarantee they will work properly with your mboard. Those web sites have a ram configurator or similar.

If you have brand name ram, it is usually easy to look up whether it's ID string (part number) is in a list of compatible modules found by using your mboard or brand name system model number.
If the ram is generic, that may be difficult or impossible.

I know from previous experience looking up G Skil ram that G Skil does NOT list modules for a lot more mboard models than in other ram configurators, and from Topics I answered in here that sometimes when more than one G Skil module is installed, they will only work properly 100% of the time in some mboards if you custom set the ram timing numbers in the bios to SLOWER settings - higher numbers.

A common thing that can happen with ram, even ram that worked fine previously, is the ram has, or has developed, a poor connection in it's slot(s).

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

Some ram manufacturer's modules do not strictly adhere to the JEDEC standards that most mboards bioses use to determine ram settings.
In that case, the ram settings in the bios Setup that the bios has automatically chosen may not be correct.
Check the ram settings in your bios - the ram voltage, and the ram timing numbers - those should be the same as for the specs for the modules themselves. Often the ram voltage and timing numbers are printed on the label on the modules.

If the voltage setting or timings settings in the bios are different from the specs for the ram, change them in the bios. The timing numbers must be as close as you can get to the same, or slower timings (higher numbers = slower) - you won't notice the difference the slower settings make.

If you have a mix of different modules
- don't mix ram that different voltages are specified for - the bios will force the ram to use the lowest voltage, if "by spd" or similar is used (default settings) - ram that a higher voltage is specified for is more likely to not work properly in that situation.
- the bios settings must be those for the slowest timing settings of all the modules, or slower (higher numbers = slower).

If your ram passes a ram test, it's working fine, even if you can't determine whether it's listed for your mboard or system model anywhere

If you do a ram test, do that AFTER having tried cleaning the contacts and making sure the ram is seated properly - otherwise any errors found may be FALSE.
If the ram is incompatible with the chipset, or on more recent computers, incompatible with the memory controller built into the cpu, it will likely FAIL a ram test - that is NOT a true indication of the ram being faulty - there is probably nothing wrong with it, and it will pass the test if installed in a mboard it is compatible with.
NOTE: Sometimes incompatible modules (or matched pairs) won't work properly when more than one is installed, but will pass when by itself.

If you want to try a memory diagnostic utility that takes a lot less time to run a full pass than memtest86 does, this one is pretty good - Microsoft's
Windows Memory Diagnostic:
It can be toggled (press T) to do a standard or a more comprehensive set of tests - use the default 6 test one first - if it passes one pass of that, use the latter one. A few of the tests in the latter set are intentionally slower.
If you don't have a floppy drive, see the Quick Start Information at that Microsoft link for how to make a bootable CD of the Windows Memory Diagnostic (you need Windiag.iso - you don't necessarily need to use the program they mention to add it to the CD).

Report •

August 8, 2010 at 09:38:11
Ram is good, I've run the memtest as well as the windows test on both sets. I have not checked compatibility yet; I shall get on that as soon as I've finished updating the other machine. I am not mixing modules of RAM, that's why I only have the 2gb in at the moment. CPU and GPU fans (and in the case of the GPU, absurdly large collection of pipes and heatsinks and a little bitty fan) have just been exposed to the last half of a can of compressed air, and I've run isopropyl alc across the connectors for the ram and the video card, just to ensure it's clean. I've removed all connections in the machine, hit 'em with the compressed air, and reconnected them. Now I suppose I shall wait and see, and be back in a few weeks if it hasn't fixed the issue. Thank you, Tubesandwires.

Report •

Related Solutions

August 8, 2010 at 11:51:12
You're welcome to use our help.

Compare the specs of the two sets of ram modules. If the rated voltages for them are different, that's a common reason mixed sets of ram modules malfunction.

Report •

August 8, 2010 at 14:27:18
And, after a format, reinstall, and driver update, it's just locked up again. I just ran the windows memory diagnostic again, and it came back clean. Fan is still turning on my graphics card and everything else, on the restart my CPU temp read 32C. Unless I'm mistaken, that's not all that hot.

Report •

August 8, 2010 at 15:29:20
You can do whatever you like over and over again and that won't solve the problem if doing that didn't help the first time.

Rarely, a ram problem does not show up when you use bootable ram diagnostics - it only shows up in the operating system itself. .
Try running a Windows based one.

Did you check the bios settings to confirm whether the settings for the ram are correct for the specific modules ?

Report •

Ask Question