Solved Phoenix BIOS stuck in boot

January 20, 2015 at 13:59:51
Specs: Windows 7
My Acer Laptop worked fine, then one day just got stuck in the BIOS boot screen.
If I remove power and battery, and interrupt the BIOS boot with F2 and then exit BIOS config screen (no changes) it boots up to OS fine.
I updated to latest BIOS and have also had a successful boot since using above method.
Yet after clean shutdown the BIOS gets stuck again on next boot.

Any pointers?

See More: Phoenix BIOS stuck in boot

Report •

January 20, 2015 at 14:18:01
It could be the BIOS isn't the problem, just a symptom. Run thru all the menu settings & change as necessary, then save your changes before exiting. I would run diagnostics on both the RAM & hard drive.

Report •

January 20, 2015 at 14:47:18
✔ Best Answer
Also try #1 response here - at least it is easy to try:

Always pop back and let us know the outcome - thanks

Report •

January 20, 2015 at 15:41:18
Put this on an USB thumb/flash drive & see if you can get your windows install sorted out.

Lazesoft Recovery Suite Home Edition
Screenshot ( SS )
How to Boot a Computer from a Lazesoft Recovery USB Device

message edited by Johnw

Report •

Related Solutions

January 20, 2015 at 23:27:06
By 'bios boot screen' do you mean the normal logo or posting screen when you first turn it on or do you mean it opens into bios setup? If it's the normal screen does it give an error message?

Instead of F2 try tapping F1. Often F1 is the key to 'continue' without going into bios setup.

Might be the cmos battery. Check that the date is correct in either bios setup or windows (when you have a successful boot). If the date is way off it's either a bad cmos battery or somehow the date was changed.

Report •

January 28, 2015 at 15:10:01
Thanks for all suggestions.
I tried several things, and am now working. The 20sec hold of the power reset button seems to have 'unstuck' the laptop.

Report •

January 28, 2015 at 15:24:58
Glad to hear it and thanks for the update. I was beginning to think that magic had evaporated because it has been some while since I've seen it work.

message edited by Derek

Report •

Ask Question