PCMCIA to USB adapter issue with win98

December 18, 2017 at 16:43:29
Specs: Win98 (1st ed), pentium 200 mmx
Just got this PCMCIA to USB adapter for my win98 CTX laptop. I can insert in into my win98 Compaq laptop's PCMCIA slot and it recognizes it, let me install drivers, and works great (but that laptop already has a built-in USB...). HOWEVER, when I insert the adapter into my CTX laptop (no built-in USB), it fails to sense anything is even inserted - I can insert other PCMCIA devices and all work fine. It's specs say it is a 32-bit Type I, II,and III type slot. The slot uses a Tritdent omega 92C094 PCI to PCMCIA Bridge and says PCIC.
Anybody know why one win98 laptop accepts the card and the other not?

See More: PCMCIA to USB adapter issue with win98

Reply ↓  Report •

#1
December 18, 2017 at 19:44:17
I see you have Win98 (1st ed) in your specs. Win98SE has much better support for USB. Are both laptops running Win98FE or does the Compaq have Win98SE? Did you try installing the drivers on the CTX laptop 1st & then insert the adapter? It's worth a shot, but it's possible the driver installation might halt if the hardware isn't detected. Did you check the adapter's OS requirements to see if Win98FE is supported?

Is the adapter something like this? >> http://www.bilder.tragant.de/produk...

message edited by riider


Reply ↓  Report •

#2
December 18, 2017 at 22:44:05
Full USB support did not appear until Windows XP actually (Windows ME to be precise, but that was a terrible OS in all sorts of ways so best to forget it) so you'll have to upgrade your OS.

Anyone who's still using any OS prior to XP really is making life difficult for themselves.

message edited by phil22


Reply ↓  Report •

#3
December 19, 2017 at 04:11:30
OK - lots of input, but...

Both are using the BEST Windoz ever - win98 - 1st ed (microslop stole and broke stuff beginning with 98SE...) ~ needless to say, I've used 98SE and would NEVER install it over 98 1st ed. (ie Win95 'fixed'). I have Win98 - 1st ed on seven (7) computers running fire modeling, autocad, word processors, etc.

As I said - the PCMCIA was recognized, installed drivers, and worked absolutely marvelously on the Win98 - 1st ed Compaq laptop, so yes the thing is 98 - 1st ed compatible.

Yep - installed driver first on CTX laptop, then inserted card - not even recognizing anything is inserted into the slot - weird! THIS is the problem, not USB function.

Roger on non-full USB support.... not a big deal, for lots of USB thumb drives, etc have software that allows Win98 1st ed to work with them.

The problem is not with the USB part, but with recognizing this Type II 32-bit PCMCIA card being inserted (not even a 'unknown device' comes up - just dead...), for other Type II 32-bit PCMCIA devices work fine (Boca modem, kangaroo drive, etc).

As far as XP goes, it has it's place, but not for my needs in this instance. I have an XP that plays the DVD games and some other stuff, but for the older CD games and applications it sux. There's many applications that got fed to the wolves with the move to NTFS by Micro$lop but I still run two Win 3.1 computers - again, there many DOS stuff out there that dislikes Windoz totally!

My internet, email, and modern things are run on Ubuntu 17.10... (ie LINUX)


Reply ↓  Report •

Related Solutions

#4
December 19, 2017 at 13:47:53
"Both are using the BEST Windoz ever - win98 - 1st ed"

Definitely a matter of opinion & I think most of the helpers in these forums would disagree with you. Old hardware & old software will only take you so far for so long but we have our share of posters who apparently enjoy a challenge.

Of all the Linux versions available, why did you choose Ubuntu 17.10? xx.10 versions only have a 9 month lifespan. It will reach its EOL in July 2018. The LTS versions are supported until April 2021. Mint Linux (based on Ubuntu) uses the LTS version as its base & then tweaks it along the way. I like the Xfce DE; it's simple, light on resources, & has a Windows-like feel. 18.3 is based on Ubuntu 16.04 LTS. I highly recommend it.

https://blog.linuxmint.com/?p=3480


Reply ↓  Report •

#5
December 20, 2017 at 04:29:52
First it'll be Ubuntu 18.04 for the next LTS release, not 18.3, but really not important... (especially since it won't be out until April 2018). Bought the laptop with 16.10 and have had to do upgrades to keep up with support... waiting for 18.04.

But more importantly - New development: tried to insert my NIKON Coolpix 100 (google it to see what the camera is like - you'll never believe it!) into the PCMCIA slot, which used to work long ago, but now the CTX Win98 1st ed only acknowledges something is plugged-in (bit better than the PCMCIA to USB adapter received..) but does not know what it is... hmmmm. Plug it into the Compaq and up pops explorer to browse the photos - which is what the CTS should do.

SO, looks like there's something amiss with the PCMCIA slot on the CTX. I've had to do some IRQ manual assignments over the years that could be why, or possible bad/corrupt driver. Will get back as soon as an answer is found. Got the CTX's CD with driver software and diagnostics that I'm gonna try next.


Reply ↓  Report •

#6
December 21, 2017 at 11:48:58
OK - so the CTX CD turns out to be a bust, nothing but win95 junk onit... Appears that this CTX 700 laptop originally had win95, built for win95, then win98 1st ed was installed and sold to me with the useless CTX CD, a win98 1st ed CD (priceless), a win95 CTX manual (useless too), and a win 98 1st ed manual. Could be an architecture issue ya think?

When booting up the CTX, it stops at the boot password screen where you can see on the little LCD display next to the keyboard, the icon for the lower PCMCIA slot detecting something (ie the Kangaroo Drive's PCMCIA card), but no icon for the upper slot where this PCMCIA to USB adapter (Dynex DX-UC202) is plugged in... appears not to be a driver issue or even an IRQ conflict ~ the thing just doesn't register on that laptop at all... but STILL works on the Compaq laptop fine. My Boca PCMCIA modem is fine in the top slot too. The Coolpix camera at least triggers the upper icon when plugged-in, just the drivers for it are not working now (works fine in the Compaq). I've tried the adapter in both slots - still no recognition/keyboard icon.

VERY bizarre phenomena and I am at a loss for what to do next - my main purpose of getting a USB on the CTX laptop is to do an image backup to a USB thumb drive. Any ideas on some other 'USB' adapter (parallel, serial, etc.) compatible with win98 1st ed?.

message edited by BatGirl


Reply ↓  Report •

#7
December 21, 2017 at 17:24:21
Just learned the difference between 32-bit PCMCIA software (reported by Windows 98 as a 32-bit PCMCIA) and a 32-bit CARDBUS device ... seems the problem is the adapter is 'CARDBUS' and the slot is PCMCIA... so adapter will never work in the CTX

see this for definitive info on PCMCIA vs CARDBUS: (ie 1990 vs 'later')
http://www.hpcfactor.com/support/ce...


Reply ↓  Report •

#8
December 23, 2017 at 04:29:59
So, apparently the early days (1990-1995) of PC Cards/PCMCIA were 16-bit (both cards and slots), and when USB with it's 32-bit needs came along, the CARDBUS-32 came along to make adapters. From what I can read by the guru's, the 16-bit bus can never be used for USB, thus no PCMCIA 16-bit to USB adapters could be invented.

HOWEVER, to heck with USB! Found a 16-bit PCMCIA to SD card adapter that I can finally do my image on for the CTX laptop w/win98 1st ed. Problem solved.

Merry/Happy Christmas, folks!


Reply ↓  Report •

#9
January 8, 2018 at 04:23:15
OK - got a SD card to PCMCIA adapter that is 16-bit, works fine so I now have a good storage area with lots of capacity to do a backup on...HOWEVER - Ghost 2003 can not find the SD card when it reboots to DOS to create the image....Tried my Ghost for Linux CD (G4L) but the darn CTX won't boot from it for some reason even though the BIOS has CD listed as first in boot sequence - booted fine on all my other Win98 computers (desktops and laptops) and imaged them all nicely to USB thumb drives - explorer can see the CD fine (but, will probably have the same issue as Ghost and would probably not be able to find the SD card upon booting up with G4L...sheesh!

SO, for now all I can do is just copy the contents of the CTX Win98 hard drive to a directory on the SD card (except for the swap file), and do the same for the kangaroo PCMCIA drive and the Zip100 parallel port drive.

Conclusion: CTX 700 laptop image is not possible without stripping half the hard drive of contents, then make a second partition on the drive to allow Ghost 2003 to image the first partition there and then copy that image to SD card - not worth sacrificing the drive's contents!


Reply ↓  Report •

Ask Question