PCI Card BIOS Problem (IT8212F)

November 18, 2011 at 12:13:36
Specs: none, i3 x86-64

I have a very strange problem with a IT8212F based PCI RAID controller - Innovision DM-8401r.
I bought a new motherboard (Asrock z68 Pro3 with the new UEFI BIOS ) with no integrated IDE controller with the idea to use this PCI card to add PATA/ATAPI support. I plugged the card into the first of the two available PCI slots, powered the motherboard and the BIOS of the RAID controller started. The original BIOS though doesn't support ATAPI devices, so I downloaded a special ATAPI BIOS from the ITE website. I flashed it, rebooted the PC and it failed to boot - it powers but remains on a blinking prompt. When I remove the RAID controller the PC boots normally.
The strange thing is that the RAID controller works perfect on any other motherboard that I tried. I flashed it several times with all the BIOSes I found - but no one of them boots properly on the new motherboard. If I erase the BIOS completely - the system boots, but of course the controller is useless.
Why am I posting in this section? :) - because that I came to the conclusion that there are only two possible cases - 1st - all of the new BIOSes that I tried are incompatible with this motherboard - I doubt this, because it would be strange that an older one would be compatible - and still all of them work perfectly on other motherboards.
And 2nd - The flash chip on my PCI card is 64kbytes, while the size of each one of the BIOSes is 48k. Is it possible that the remaining empty space can cause the problem?

Unfortunately I don't have a backup of the working BIOS, and I don't remember its version :(

See More: PCI Card BIOS Problem (IT8212F)

Report •

November 18, 2011 at 13:21:19
Why am I posting in this section?
Unless the answer is, "How do I write my own BIOS?" Programming is the wrong forum. If it is, then you're probably beyond the expertise offered on this site. Moving to Hardware.

Make sure the card is good. I suggest trying it in another, working PC.

Make sure the card is compatible with your motherboard. You might need to update your motherboard's BIOS first.

How To Ask Questions The Smart Way

Report •

November 18, 2011 at 13:58:40
Thank you for your answer!
I posted in the coding section, because the problem is clearly not hardware - the PCI card worked once (before the initial flashing) on this system and now works on every other system except that one.
It's all about Assembly - During POST the BIOS looks for a 55 AA in the BIOS of the expansion card. The third byte of the BIOS shows the lenght that is taken by the expansion card. In the original BIOS this byte is 5E which in decimal is 94. Which multiplied by 512 is 48128 - exactly the size of the original BIOS. I tried to change this to 80 which should be 64kbytes, but still it doesn't work. Maybe someone with knowledge in assembly and BIOSes can help?

Report •

November 18, 2011 at 20:24:33
I can't really help on the assembly programming side of things, but I own a it8212f based card and I can say a few things about.

1. The flash chip on my card is also larger than the firmware, the rest of the memory was padded with 0xFF originally. I always left the firmware unmodified, except for padding it at the end to match the capacity of the the flash chip. It has always worked fine this way.

2. It's probably not an issue for UEFI, but on my regular bios certain options(like USB legacy mode) cause the card to cease to function at all due to lack memory.

You say that it worked initially with the stock raid bios, at that it doesn't work with the flashed atapi bios, but have you tried it with the latest raid bios? I understand you want the atapi mode, but it could help to know if it's just newer bioses that don't work or if it's just the atapi versions.

I have a copy of atapi if you want it, I also have a couple of older raid versions. If you are interested send me a PM with an email address.


One more thing I forgot to mention is that I always found the things worked better disconnecting all disks for the flash and leaving the disks disconnected for the first cold boot. I know it sound strange but it seems to avoid the "disk not ready" errors.

Report •

Related Solutions

November 25, 2011 at 22:38:16
Thank you for your reply!
Unfortunately nothing seems to resolve this issue. I contacted a guy who has the same card and he promised to make a backup of the BIOS so when I receive it I will post back if there is some progress.

Report •

Ask Question