PC wont recognize my Sapphire Nitro Radeon R9 380 Graphics

March 6, 2016 at 15:05:08
Specs: Windows 8
I just built my PC and this is the first time ive ever built a PC and everything works fine except that my PC isnt recognizing my graphics card, i go into device manager and look at my display adapters and it only show the regular windows one. I currently have my HDMI cable plugged into the graphics card and can see everything on the monitor fine, im actually using the pc right now to type this. yesterday i had an issue with the power supply i was using so i got a stronger one, but was using the pc without the graphics card for awhile just to install some programs i knew i would be using once i got this all figured out. heres the full build.

Processor:
AMD FX-6300 Vishera 6-Core 3.5 GHz (4.1 GHz Turbo) Socket AM3+ 95W FD6300WMHKBOX Desktop Processor

Motherboard:
MSI 760GMA-P34 (FX) AM3+ AMD 760G SATA 6Gb/s USB 3.0 Micro ATX AMD Motherboard

PowerSupply:
CORSAIR CXM series CX750M 750W 80 PLUS BRONZE Certified Modular Active PFC

Graphics Card:
SAPPHIRE NITRO Radeon R9 380 DirectX 12 100384NT4GOC-2L 4GB 256-Bit GDDR5 PCI Express 3.0 x16 HDCP Ready Dual-X OC Version w/ backplate (UEFI) Video Card

I also took some parts out of an old PC I took 8 gb of ram, a cd drive and a 1 tb hard drive. I didnt clear the harddrive completely because i wanted to keep windows 8 on it so i didnt have to buy a new copy, not sure if some of the old pc settings are screwing with it or not. but everything else on it is working great.


See More: PC wont recognize my Sapphire Nitro Radeon R9 380 Graphics

Report •

#1
March 6, 2016 at 16:55:01
Is the Graphics Card disabled in BIOS?

Always pop back and let us know the outcome - thanks


Report •

#2
March 6, 2016 at 17:10:13
i cant get to my bios for some reason

Report •

#3
March 6, 2016 at 17:19:45
when i try to get to the bios the option never shows up

Report •

Related Solutions

#4
March 6, 2016 at 17:46:19
See this:
http://blog.lenovo.com/en/blog/how-...

Always pop back and let us know the outcome - thanks


Report •

#5
March 6, 2016 at 19:51:36
Are you sure you have your monitor connected to the add in card, and not the integrated graphics on the motherboard?

If that is not the case, did you install the drivers for the add in card? Your add in card will operate in the SVGA mode if the drivers are not installed. This is by default so you can see something on the monitor before the drivers get installed. You can't rely on Windows to install those graphics drivers.

Use the CD that should have come with the Sapphire card.


Report •

#6
March 6, 2016 at 23:00:06
yeah i installed the drivers with the cd and installed additional drivers online. and yeah i for sure am using the hdmi port on the graphics card, my mother board has no hdmi port.

Report •

#7
March 6, 2016 at 23:05:37
I kind of messed up earlier trying to find my own solution waiting for a reply :/ i uninstalled all my amd drivers because i thought the old drivers from the old pc might have been making the new drivers i was installing not work so i wanted to start fresh,(i heard this could fix my issue on another forum) and now that i removed ALL the amd drivers i cant use my mouse or keyboard when windows boots and i cant get to my bios before windows start (basically i can use the keyboard right when i boot but when windows starts booting it wont work anymore) and i read that it was because i uninstalled the amd drivers, would have been a nice thing for amd to mention before suggesting that route to fixing my issue, so i think i need to buy a copy of windows 8 now.

Report •

Ask Question