Solved PC turns on, no beep, no display on monitor.

June 20, 2012 at 13:21:53
Specs: Windows 7
PC recently decided it wasn't going to recover from sleep mode on a regular basis and then from boot either. Fans start whirring, lights on MoBo turn on, but no beep. Turned to my old friend Google and found a stream of ASUS MoBo problems, eerily similar to mine. Tried the most popular fix (remove battery, set BIOS to default settings, replace battery). Suddenly my PC was fully functioning again, for 2 hours I was able to go in and out of sleep mode and turn the PC on and off several times. Moved the PC upstairs and then, nada. It's completely dead now.

PC now turning on, fans whirring, lights on MoBo appearing, but no beep and no display on monitor. Removed the RAM (another popular fix), I didn't even get a 3-beep from the machine.

I'm a bit new to all of this, so any help would be appreciated. All parts are under a year old and I'm really not liking the timing of this, as I actually need it for a project at the moment, instead of it just being my gaming baby.

I have a feeling it's the MoBo, but the fact the lights come on and everything engages makes me a bit confused.

Thanks in advance,


- AMD Phenom II X6 Six Core 1075T 3.00GHz (Socket AM3)

- HIS ATI Radeon HD 6850 1024MB GDDR5 PCI-Express Graphics Card

- Asus M5A97 PRO AMD 970 (Socket AM3+) DDR3 Motherboard

- OCZ ModXStream Pro 600w Silent SLI Certified Modular Power Supply

- Seagate Barracuda 7200.12 1TB SATA 6Gb/s 32MB Cache - OEM (ST31000524AS)

- Kingston HyperX Blu 4GB (2x2GB) DDR3 PC3-12800C9 1600MHz Dual Channel Kit (KHX1600C9AD3B1K2/4G)

See More: PC turns on, no beep, no display on monitor.

June 20, 2012 at 14:31:13
✔ Best Answer
A common thing that can happen with ram, even ram that worked fine previously, is the ram has, or has developed, a poor connection in it's slot(s).
This usually happens a long time after the ram was installed, but it can happen with new ram, or after moving the computer case from one place to another, and I've had even new modules that needed to have their contacts cleaned.

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

Asus M5A97 PRO AMD 970 (Socket AM3+) DDR3 Motherboard

No onboard video

All Solid Capacitor
Uses 100% All High-quality Conductive Polymer Capacitors

OCZ ModXStream Pro 600w Silent SLI Certified

Output+3.3V@25A, +5V@25A, +12V1@25A, +12V2@25A, -12V@0.3A, +5VSB@2.5A

PCI-Express Connector 1 x 6-Pin, 1 x 6+2-Pin

Manufacturer Warranty
Parts 3 years limited
Labor 3 years limited

Radeon HD 6850

■500 Watt or greater power supply recommended

Probably has two 6 pin power sockets on it.

Assumng you
- are using the 1 x 6-Pin, 1 x 6+2-Pin connectors from the power supply to connect to the two power sockets on the HD 6850 card and they're all the way into their sockets....
- have checked the two power connections - to the 24 pin socket and the 4 or 8 pin socket - on the mboard to make sure they're properly seated...

If cleaning the contacts on the ram and re-seating it doesn't help, it's quite possible one of the two +12v output sections of your power supply is failing , or the power supply is otherwise defective.

Is the PS's fan blowing air out of the back of the case when the computer is running ? If it isn't, the PS components have probably overheated and have been damaged.

If you can try connecting a power supply from another working system that has a 500 watt capacity or greater, try connecting that.

"PC recently decided it wasn't going to recover from sleep mode on a regular basis and then from boot either. "

The computer system cannot stay in "sleep" mode.

You can have problems with Windows not recovering from Standby or Hibernate modes, if you installed Windows from scratch and did NOT load the main chipset drivers for the mboard after Setup was finished, but in any case, if you hold the power button in or down until the computer shuts off, the system cannot be in "sleep" mode when you start up the computer again.
If the computer will not start normally in that situation, something else is wrong.

"Tried the most popular fix (remove battery, set BIOS to default settings, replace battery).:

That's a popular myth.
Settings in the bios have got nothing to do with whether the computer itself boots (passes the post) normally, unless improper settings have been used by the computer user for overclocking the cpu and/or the ram that they cannot support.
If the computer EVER works fine with whatever settings it presently has in the bios, your problem is NOT caused by bios settings.
The computer should boot normally even when there is no Cmos battery installed, although you will get a message Cmos Checksum Error or similar because the time and date have been set back to defaults.

It was probably merely a coincidence that you doing that allowed the computer to work for a short time after that.

Report •

June 20, 2012 at 15:38:22
I do believe it was a coincidence.

Also note that before receiving your reply, I switched the RAM to different slots and I am now typing this from said PC.

I had a feeling this problem will reoccur, so I left this post up. I will most definitely clean the RAM contacts, as this may well be the fix.

Thank you for the extremely informative post :)

Report •

June 20, 2012 at 17:13:52
We're glad to hear that you solved your problem.

Thanks for the Thank you.

It's likely the ram had a poor connection before you moved it to other slots.

It makes no difference which slots you install compatible ram in for modern mboards regarding whether the mboard boots, but if you want identical modules to run in dual channel or triple channel mode (if the mboard supports that) they must be installed in specific slots, and all of the ram must be matched pairs or sets of three.
The only ram slots I have ever encontered that didn't work were slots in which a ram module had been installed backwards in, then the computer was booted, which fries both the backwards module and the circuits of that ram slot instantly.

Ram slots that haven't been used previously may have accumulated dust, lint, etc. in them that can cause a poor connection..

Report •

Related Solutions

June 21, 2012 at 14:45:44
Right, so an update for you.

Computer worked fine all day, until I decided to do some tests, put it into sleep mode. It woke up fine.

Put it into sleep mode again and left it for about and hour. Dead again for over and hour this time. I checked my power settings and 'allow hybrid sleep' was set to 'on'. I've switched that off. And I'll post more updates. But yeah, I haven't cleaned the contact points on the RAM yet. But are there any other solutions that it could be?

I only ask this, because the issue isn't happening 100% of the time, seeming as I've just used the computer for a day and am using it again now. So I want to try a few things.

House mate reckons he has a 500W+ PSU kicking about, so we'll try that and see what happens too.

I really appreciate the help :)

Report •

Ask Question