PC powering but not reaching BIOS.

December 10, 2010 at 08:22:03
Specs: Windows 7
I've search these forums and to my best i could only find threads from 2006 related to this, with no answers..

Basically i added more RAM to my PC, brought it from 2gb to 4gb, the RAM was the exact same type except for the brand. Now the PC will turn on, power's fine all fans are working, graphics/sound card fine but it's not detecting any devices, monitor included so i can only but assume it's not reaching BIOS. It's not a fault with the monitor either. I know some will suggest replacing the battery on the motherboard but that hasn't worked for anyone so far.

I had to fiddle around with the RAM to get it into the slots because it's in an awkward place, could it be that i just damaged the RAM slot's so now the mother board's shorting?

I got 3gb out of the 4 working but one stick wasn't in correctly and then my PC crashed, so i removed the new RAM and went back to the old sticks and it worked fine.

Any suggestions welcomed!

See More: PC powering but not reaching BIOS.

Report •

December 10, 2010 at 08:40:23
Actually when you got 3Gbs out of the 4Gbs working you probably had it right. 32 bit Operating System will only ever use around 3 Gbs of physical memory. The other 1 Gb is taken up with memory mapped devices. That is assuming you have the 32 bit version of Windows 7. If you have the 64 bit version non of this applies.

You need to make absolutely sure that the RAM is seated correctly and the the clips on each end are fully home. It is very easy to have one clip not quite home. The simplest way is to put the card loosely into the slot making sure the ends are in the clips then gently press on each end of the card together till is slots into place. You should here a distinctive click as each side slots in. Try and get both together. If you get one clip pressed in by itself it makes it a lot harder to get the other in.

Of course you have to ensure that you have it the right way round to begin with.


Report •

December 10, 2010 at 08:45:23
Thanks for the quick reply.

Yeah i have 32bit, i don't know if it was even reading the third stick because the system crashed before i had the chance to check. I replaced them and had them seated correctly but now i can't load anything to check because of the pickle i mentioned about. Also there's no beeps so i'm stumped as to what's the problem.

Report •

December 10, 2010 at 09:54:19
In the rare chance anyone else has the same problem, one of the RAM slots is now broken and when ever there's a stick of RAM in it it shorts everything so the PC can't boot up. Had the same problem with two forward USB slots on my pc.

So after much swapping around it boots. Though now i'm stuck with just three slots.

Hip hop hurrah.

Report •
Related Solutions

Ask Question