pc on but no display

Microsoft Windows vista home premium - 3...
June 16, 2010 at 03:48:40
Specs: Windows Vista, E4600/2Gb DDR2
my computer turns on but i get no display!

new motherboard, new pcu.

P5G41C-M LX Motherboard
Intel E4600
Nivida 8500GT
2GB DDR2


See More: pc on but no display

Report •


#1
June 16, 2010 at 04:22:36
U should benchtest the hardware before installing into pc case.
No system specs.

Report •

#2
June 16, 2010 at 04:40:07
tried removing video card, used onboard (didn't work).
Monitor tested on another computer. works fine.

Report •

#3
June 16, 2010 at 04:59:14
As kuwese said, you should always benchtest the hardware BEFORE you install it in the case. Now you don't know if you have a hardware problem or an installation problem.

"If you take the time to bench test your build prior to full assembly you will save yourself hordes of time in troubleshooting a faulty component."

How to Bench Test Your System


Report •

Related Solutions

#4
June 16, 2010 at 05:04:20
Take out the following components
-mobo, ram(one stick), cpu + heatsink, psu, keyboard. Connect them outside (don't use v-card first) use screw driver to start the system, now do u hear or see anything?

edit: the link jam posted explains better.


Report •

#5
June 16, 2010 at 05:30:15
tried bench test. no good. still no video or beeps.

Report •

#6
June 16, 2010 at 08:13:48
Try to remove ram and start the system, do u hear beeps? When u start the system do u see fans spinning?

Report •

#7
June 16, 2010 at 16:09:57
tried removing ram, it beeps. all fans running when computer starts.

Report •


Ask Question