PC build wont power up

Intel Core i7 extreme edition 980x hexa...
April 19, 2010 at 21:39:39
Specs: Windows Vista
Home built a Gulftown i7 extreme processor, with Intel 58SO Mobo, Corsair 850W PSU, Corsair 3x2 ram, Nvidia 260 GPU. Assembled everything, connected all power cables, case wires, etc...turn on PSU, green light on mobo comes on, but when I hit power button on case it flashes very briefly (1 sec at most) LEDs for the fans then shuts off. then when I hit power button again nothing happens. Need to drain power completely (green LED goes out) before it will flash the fan LEDs for 1 sec again. Very strange, I have built about 5 PCs so this isnt my first rodeo....not an expert however. I have tried another PSU from my working PC and it does same thing so doubt this is PSU related. Mobo I have tried 2 with the same issues, so dont think its mobo either. Any suggestions?

See More: PC build wont power up

Report •

#1
April 19, 2010 at 22:37:15
do you get a beep noise from your computer?

Report •

#2
April 19, 2010 at 22:42:45
U have built 5 pc's and u didn't know how to benchetest the hardware. Pull this components out mobo,cpu + heatsink,single stic of ram, psu, v-card. Connect the components outside of pc case & don't forget monitor, keyboard. Now start the system, what do u hear or see?

Report •

#3
April 19, 2010 at 23:24:14
maybe you are forgetting to plugin the 12v cpu power connector.

Report •

Related Solutions

#4
April 20, 2010 at 05:09:24
I agree with kuwese, you should ALWAYS benchtest the hardware before you install it in the case. Now you have no idea if you have a hardware problem or an installation problem.

Report •

#5
April 20, 2010 at 05:41:53
Sounds very much like a short circuit that is cutting of the power supply which isn't reset until power is removed.

Take it out of the case and test it then you will now for sure what it is.

Stuart


Report •

Ask Question