PATA2SATA2 IDE to Dual SATA Converter The pata2sata2 ide to sata...
February 13, 2016 at 04:10:23
Specs: Lindows, Pentium 4
I have three PC's with Pentium 4 motherboards that I am trying to install dual drive SATA laptop swap drive bays into. I've got two Kingwin KF-251-BK bays and one SIIG Dual 2.5" SATA MobileRack. All three motherboards have IDE connectors. I am plugging Startech's PATA2SATA2 Converter into the Primary IDE on the motherboards and running SATA cables out to the drive bays from it. And I am only installing a primary empty 320GB SATA drive for the time being.

I started with the computer with the MSI 845GE MAX (MS-6580 VER: 2.0) motherboard and the SIIG bay. The SIIG bay is constructed of some type of acrylic, no metal housing. It has a common SATA power connector and independent SATA data connectors. I got everything hooked up (All Power, SATA0, and SATA1) and plugged one 320GB drive into the master slot leaving the second slot empty. When powered on it did not recognize the drive as installed. It did not even recognize my DVD drive now on the secondary IDE connector. I found out I had an un-keyed, IDE cable hooked to the DVD drive. I corrected it and that resolved the problem, but getting into CMOS would be delayed by some 40seconds or more. I disabled the slave of the primary IDE, and that delay dropped down to some 5 seconds or so, which is much better but still slower than normal.

I used the Kingwin KF-251-BK bays with the next two PCs. The Kingwin has two completely independent 2.5" metal slots.

With the ECS EliteGroup P4S5A REV . 1 . 2A motherboard I had moved things around a bit and was only getting a blank screen on boot up. I was forced to clear CMOS by jumper to recover. After that, it boot but it would only see the 135GB or so of the 320GB drive. I tried another drive. I tried it on SATA1 but its still not seeing it right.

I moved onto the PC with the Intel D845HV motherboard using another Kingwin KF-251-BK. I opened the box and noticed some Hard Drive Insulators that were not in the other box. Is it possible the problem with the ECS machine was the drive shorting out against the metal construction of the Kingwin? I'll have to come back to that. So, I went ahead and got everything hooked up inside to the Intel motherboard and put the protective insulator on the SATA drive. This time I can not seem to get into BIOS at all so long as the PATA2SATA2 converter is plugged into the IDE of the motherboard. It just hangs there on "Entering Setup" until I get impatient after a couple of minutes and reboot. I unplugged it and reboot and it went right in. So, I tried disabling the primary slave and reinstalling the converter, but it still just hangs on that screen.

I'm going to try insulating the other drive and booting the ECS system again.
I'm thinking of trying and swapping the PATA2SATA2 converter out in the Intel System.
And the delay getting into CMOS on the MSI, short as it may be now, has me a bit worried after how well this has gone on the other two systems.

Can you think of anything I'm missing here? Some other CMOS settings maybe? Any reason it might not like the missing slave drive even with it set to none?

See More: PATA2SATA2 IDE to Dual SATA Converter

Report •

February 13, 2016 at 05:02:35
"Can you think of anything I'm missing here? Some other CMOS settings maybe?"
Play around with Secure Boot & UEFI settings.

What is your operating system?

Report •

February 13, 2016 at 06:47:20
The systems he's asking about are 10-15 yrs old - socket 478, no PCIe, no SATA ports, PC100/133 or DDR1 RAM, no secure boot or UEFI. That's why he has to use adapters. Personally, I wouldn't waste my time trying to adapt/run SATA HDDs on any of them.

And who runs Lindows anymore?

Report •

February 13, 2016 at 15:30:15
Lindows was just a joke. I couldn’t think what to put there, so I chose Lindows as I will be using both linux and windows. All the drives I am using are currently empty. I will be using the swap drives with different operating systems, networking the machines to my DIY server, and possibly doing some distributed computing. I went with the 2.5” bays as they fit two drives in a 4” bay that would otherwise be empty, the SATA drives are readily available, I can easily & quickly clone them, and it’s one step toward upgrading all three machines. New motherboards won’t be in my budget for quite some time, so I am using these Pentium 4’s because they are what is available. I didn’t expect this to be the stumbling block its turning out to be. I am doing this to learn anyway and treating it as sort of a hobby.

I masked off the PCB and boot the ECS machine again, but it still only sees 137.4GB of 320GB. I tried a different drive, same result. Maybe I need a BIOS update (it’s currently at AMIBIOS V1.21.06). It’s either that or it’s a hardware issue.

I swapped out the PATA2SATA converter between the ECS and Intel machine, but it didn’t help or hurt anything for either’s case.

I then played around with setting USER drive values on the ECS box, but it only lets me change LBA mode, BLK mode, and 32 Bit mode to either ON or OFF. I can also set PIO Mode between 0 and 5. The CHS values display the same for any combination of these and do not appear to be independently assignable themselves which I find odd.

I thought I saw something in CMOS on one of these boxes concerning UEFI or EFI, but can’t find it now. I remember it standing out to me as odd, because I didn’t expect it. I even did a google search on it that night. Maybe it’s in some submenu I am not seeing now.

message edited by ISAmad

Report •

Related Solutions

February 13, 2016 at 15:48:15
"so I chose Lindows as I will be using both linux and windows"
What version of Windows? too much ram, can be an issue for some versions.
Too much ram, can also be an issue on some motherboards.

"I am doing this to learn anyway and treating it as sort of a hobby"
Best way.

"Maybe I need a BIOS update"
MSI 845GE MAX (MS-6580 VER: 2.0)
The above has > Live Update 5

"I tried a different drive, same result"
Was it much, much smaller?
I would test with the smallest you have.

"Maybe it’s in some submenu I am not seeing now"
You have to disable Secure Boot to see it.

message edited by Johnw

Report •

February 13, 2016 at 16:22:52
Windows XP Pro at first since I have three copies of that available and the server is loaded with Windows 2003 Server, so it should be compatible. I have at least one copy of everything from Microsoft Dreamspark that I plan to play around with later.

I remember seeing that Live Update 5 before, if I remember right it was no longer available or something. I may have to update BIOS more manually.

The SATA drives are all 320GB, the lowest I could find. Faster for cloning. I could plug some IDE drives in of larger and smaller sizes and see if it recognizes them correctly.

And I'll see if I can find that menu item again.

Report •

February 13, 2016 at 16:28:11
"I could plug some IDE drives in of larger and smaller sizes and see if it recognizes them correctly"
That's what I would do.

Report •

February 13, 2016 at 16:51:19
I just downloaded the ENGLISH manual & here is what it said.

Q: Can Live Update Series support WinXP?
A: Live Update Series version 215 can support WinXP. Download it from http:/

Looks like there is no > efi, uefi or Secure Boot as per riider's comment.

BIOS Setup on page 59 of the manual gives good info.

Report •

February 14, 2016 at 02:29:46
ECS board:
I was going to try and plug in IDE drives of different sizes, but it looks like I don’t have an IDE drive around larger than 137.4GB.
But it sounds like a BIOS issue now anyway. The 137.4GB is a limitation of LBA 28-bit addressing.
The closest link I can find for downloads from the ECS site is for the P4S5A V1.0.
Mine is the P4S5A V1.2. I see people referring to it as V1.x, but it seems a bit iffy to me.
And anyway, the latest BIOS update for that ECS board is dated 6/10/2002, which pre-dates LBA 48-bit addressing (2003) according to wiki.
So, that won’t be of any help to me for this situation.
Intel board:
The intel board is already at its highest level BIOS. I found a note about larger drives on the internet archive: “You can use the Intel® Application Accelerator to access the full capacity of hard drives larger than 137 GB”.
Looking that program up in google it appears the utility has to do with setting up RAID drives. I’m not sure how this helps. And since the system seems frozen when the hardware attached anyway I’m not sure how any utility that has to be installed on a hard drive to access that hard drive is going to work things out.
MSI board:
The only issue I am having right now with the MSI board is that short delay booting into CMOS. It sees the full drive size. The delay is troubling, but it seems like a shot in the dark to go updating BIOS for a fix. Nothing in their revision history is hinting at a fix to me. The rule of thumb is to never update BIOS without a reason. And I can’t pinpoint one at this point. I am at revision 3.31a (2002-09-02).
!Which unfortunately now that I look at it doesn’t jive with my earlier findings about 48-bit LBA addressing being released in 2003. Sigh, wiki. Do I take the red pill or the blue pill? Hmm, the post screen shows it as 10-14-2002, not Sept 9th, 2002. My current version BIOS don’t match up with its release date, hmm. Well, now I don’t know what to think . Knowing wiki, 2003 is probably inaccurate, and development usually leads production so documented and coded dates are no doubt not exact anyway.
I found this standards document online, notice the date Feb 2002 (revision 3B no less).
Looks like it is back to looking at the ECS board.
ECS board:
Well, I took a chance and went ahead and updated the BIOS to 6/10/2012 and it worked. It can now see the full 320GB’s.
I wasn’t happy with the process though. To update I had to download two exe files. There was a DOS utility (aminf342.exe) to install the ROM file, which was packaged into an executable (p4S5a020610.exe). When I downloaded the BIOS executable, I was treated to a warning message at the bottom of internet explorer that said “ this file may be harmful and does not have a lot of users”, followed by an on-demand scan message from Norton that the file was safe. Then, I found out that the global and European links to download the utility were broken and only the china link was working. So, I used it and received no messages from IE or Norton. I manually scanned it with Norton and it passed, but Norton file insight was a bit off putting. It responded with “Error, File not found or information is not available for this file format”. Then, I had to extract the ROM file. I used win-zip to do it. Winzip extracted two ROM files, one with LAN and one without. And it warned me that “there are some data after the end of the payload data”. I used the one with LAN. After flashing and loading optimal defaults, the PC tried a network boot after finding nothing else bootable. This got me thinking, I will have to find out how this network boot stuff works. I disabled “Try other boot devices” but saw no other settings to configure it.

Anyway, moving further down the rabbit hole. To update the MSI BIOS or not to update? And what to do about the intel board.

Report •

February 14, 2016 at 05:46:16
"To update the MSI BIOS or not to update? And what to do about the intel board"
You have done real well so far, I'm off to bed now, be interesting to see what decisions you make.

Report •

February 14, 2016 at 15:18:36
I am just going to leave the MSI board's BIOS alone for the time being. Hopefully, it works well enough. And it could be an interesting experiment to try making it fail later just to get a clearer picture of what the updates will fix.

For the intel board, there are a few things I could try:

I could try finding a clipping utility to resize the drive to where 28 bit LBA can see it.

I could try loading an OS somehow and installing the intel application accelerator, but I'm not sure the best way to do that when the machine won't even boot.

I could look at using a PCI SATA add in card. One with BIOS on the card that supports 48bit LBA otherwise I might as well go with the intel application accelerator solution. But then I would have to spend money to do this. And I'm not exactly sure what I will get.

There is a setting in system BIOS named "PCI IDE Master BUS". I think this would allow it to boot from an IDE add in card without onboard BIOS.

I read online SATA drives will show up as SCSI cards in BIOS. I'm not sure how their setup compares to mine though.

Either way this system BIOS doesn't know what a SATA drive is.

I supposed I could use a PCI IDE add in card with PATA2SATA2 converters just to make things really convoluted. At least it would make sense if BIOS saw them as IDE and not SCSI. But I bet it would be slow as a slug and catch on fire.

Since the intent was to add swap drives that would eventually run different OS's (not just windows), a hardware solution would be preferable.

I think clipping the drives is my best bet. So... I'm looking for a clipping utility now.

Report •

February 14, 2016 at 16:05:31
Well, the drives a western digital. I contacted them for a solution as I didn't see a download. They've got some nice information to read, would have saved me allot of surfing.

I am considering partitioning the drive to see if that helps, but it would probably be best if I could clip the capacity down.

They may not respond until after presidents day.

If you know of a common generic clipping utility that you could recommend, I'd appreciate it.

I guess I'll load up the two systems that boot while I wait.

message edited by ISAmad

Report •

February 14, 2016 at 16:24:21
"If you know of a common generic clipping utility that you could recommend, I'd appreciate it"
Nope, had not even heard of that.

"I could try loading an OS somehow and installing the intel application accelerator, but I'm not sure the best way to do that when the machine won't even boot"

Linux CD?

Report •

February 15, 2016 at 06:31:38
Instead on wasting any more money on SATA adapters, PCI cards, etc, I suggest you invest in a more modern system (board, CPU, RAM). You're not doing yourself any favors by trying it use outdated hardware with P4 CPUs & its NETburst architecture that never were any good to begin with.

Report •

Ask Question